Honeywell THermostat RTH6580WF

I have several Honewell RTH6580WF Wifi Thermostat's.
I understand Hubitat can't communicate with Wifi devices, but I have these Thermostats
connected to my Smartthings hub.
I have Hubconnect installed and I can see the Smartthing hub, but I can't can't see the THermostat's
in the drop down menue.

How can I control the Thermostat's with Hubitat (like pusching a button to change the temperature)



I have the same thermostat recently added the following driver code:

I have it authorized in both webCoRE and SharpTools without incident. The Honeywell service remains the weak point. On SmartThings, I had to actively re-login. So far, the Hubitat driver seems to auto-recover as noted here:

+1 on using that driver.

One problem I ran into with this driver is that my Honeywell thermostat often didn’t respond to the Poll command, leading Hubitat to lose sync with the thermostat’s temperature and set points. If you run into the same problem, a simple workaround is to turn off polling in the driver and create a rule that uses Refresh instead of Poll:

This seems to work well. I’d advise against a shorter background refresh interval, as calls to the Honeywell service are rate-limited so more frequent refresh calls would reduce the number of automation commands that you can send per hour.

I copied this app what do I have to do now ? I still can't see the THermostats

I installed webcore, and added the switch I want to use to change the temperature on the Wifi thermostats and now I/m stuck. How do I connect the Thermostats ?
That's all new for me

Problem solved.

I left the Thermostats on the smartthings hub and added a Aeotec Nanoswitch just to Smartthings to control the settings.
Everything runs on Hubitat except the Thermostats. I think that is the easiest way to do it vs Hubconnect and Webcore. :wink:

Sorry if this seems pedantic, but it is driver code, not app code. I also apologize that I was too lazy to supply the link that includes full instructions. See below: