Honeywell T6 Zwave Thermostat


The issues with erroneous temperature reporting with this thermostat (Honeywell t6 Pro z-wave) continue platform I just paired one of these to Hubitat yesterday evening.

The erroneous temperature reported is corrected within milliseconds. Here's a snippet from the event log:

Do you need one of these thermostats to debug this? I can probably lay my hands on a second one and send it to you.

I have one, working on a dedicated driver for it right now, so far I've not received any bogus temp readings.
Can you enable debug logging and see if you can capture one of those bootleg temps?

Will do.


Haven't been able to capture a errant temp yet. However, did find another bug. The thermostat (at least the unit I have) sometimes repeatedly sends the current temperature back to HE (example below).

While that is going on, if any commands are sent to the thermostat, the setting on the thermostat is changed; however, the thermostat doesn't report the changed setting back to HE, so the HE device page is no longer in sync with the thermostat (refreshing the device page makes no difference).

The only thing that puts them back in sync is to wait 5-10 minutes until the temperature reports stop and send a different setting change (different from the one tried above) to the thermostat.

In the example below, I tried setting the thermostat state to off. The physical thermostat reports as being off. HE reports it is still in heat mode.


don't know what to tell you about the excessive temp reporting, this has nothing to do with the driver...
The device is doing this on its own, the unit I have certainly isn't doing this.

It doesn't bother me much because it reports the correct temperature within milliseconds. I may try excluding and including the thermostat again.

Have you encountered the second issue? Thermostat not reporting successful setting changes back to HE? That one does bother me a lot more.

which settings specifically?, thermostats have lots of things to set...

The ones I tried were:

Set Heating Point
Set Cooling Point
Set Thermostat Mode

Note: This issue only happens when the thermostat is repeatedly sending the current temperature to HE (see below). While this is going on thermostat actually changes its setting, it only doesn't report the change to HE (so Hubitat and the thermostat become out of sync).


well sure, the device is too busy sending temperature events to respond to any commands...
I can't fix this, there's either something up with your mesh or the device itself...

1 Like

Going to try excluding and including.

I got some news/data for you. When I pair the thermostat in what Honeywell calls "Battery Mode" (which I assume is a FLiRS mode), it works perfectly. No spurious temperature readings and stays in sync with HE.

Changes to the thermostat are reflected instantly on the device page and vice-versa.

When I pair the thermostat in 24V mode (powered), all that crap returns. But if I pair it in battery mode and then add constant power - it works just fine.

I have one of these for almost a day now :slight_smile:
I've observed the temperature flood once so far, and yes, mine is in the 24VAC mode as well.
My understanding from the manual is that in the battery mode 24V power is ignored completely, and the unit operates purely on batteries (thus depleting them much faster). Plus the nice faint backlight is not possible in the battery mode...
But modes could only be changed when the thermostat is not paired :frowning:

I imagine there is a firmware in these - is there a chance that it is upgradable?

Hi Lev,

That interpretation is partly correct. Here is what happens:

If you pair in 24VAC mode and then shift to batteries, it continues to function in powered mode and will drain batteries.

On the other hand, if you pair in battery mode and then add 24VAC power, it will continue to function in battery mode - even though 24VAC is used for power. This is easy to verify. Simply pair it in battery mode, then add 24VAC power and pull the batteries. The thermostat will be fine and "Device Info" indicates it is in battery mode.

The thermostat doesn't lose its equipment settings when you exclude/include it. So should you decide to switch it to battery mode (with 24VAC power also connected) - it isn't that much of a hassle.

Hey @mrutenbeck, I think this is your model and I know you've seen it flood your logs with a bunch of current-temperature readings (not sure about the incorrect readings, just a bunch of repeated entries). Perhaps pairing it in "battery mode" instead of with 24V power (then secretly switching it back like above so you don't have to keep actually worrying about batteries) will work around these problems and keep your Z-Wave mesh a bit happier, as @aaiyar discovered.

I didn't have to do any of this, i put the batteries in, added ac power, then included it.
I've included excluded it several times so far with batteries in and under ac power, have not not seen any wonky reports...


One difference is that I never had batteries in. Just AC power. Also - is there a way to check for differences in firmware version? Wondering if the thermostat firmware version you were sent is different than the one some of us seem to have received.

FWIW, working perfectly now. And no chattiness so far. And very responsive to commands from HE.

I'm a happy camper.


Wondering if the thermostat firmware version you were sent is different than the one some of us seem to have received.

I don't know if this will work for you but it might be worth a try.

[Honeywell Firmware](http://Wondering if the thermostat firmware version you were sent is different than the one some of us seem to have received.)

Sadly, with mode=Battery, still:

@mike.maxwell @lev @mrutenbeck

FYI - there are at least three firmware versions out there:

01.04:03.00 (this is the one my thermostat has)

Maybe some of the differences we're seeing are firmware related.

I had the same issue with the temperature reports and not staying in sync. @bertabcd1234 installed a driver for EM Enhanced Z-Wave Thermostat that seemed to help somewhat and then later switched me to Radio Thermostat CT101 where it’s been working well. I verified that I am running the firmware @aaiyar. I’m going to try switching to battery mode to see how that works.

1 Like