HomeKit not certified

Tried adding Hubitat to HomeKit but it’s showing as a non certified bridge and all my devices are showing as non responsive. What am I doing wrong.

These are two separate issues. Hubitat is not currently certified, so you will see that message until it is, which is a goal.

For the "not responding" issue, you could try disabling and re-enabling HomeKit from the app. I see one post where a hub reboot helped. I'd also make sure you're on the same network with your phone as your hub, unless you have a Home hub set up for outside access. If nothing else, an engineer may be interested in looking at your logs.

1 Like

I tried all of these and still nothing. Is there a way to push this issue to an engineer?

Tagging @gopher.ny

Are you on the latest software for your appletv or homepod mini?

Is the word home in your Hub name?

For myself I deleted the home on my home kit, renamed my hub not to have the word home then added it to home kit and all was good. (This was during beta when I had that same issue).

Should not matter anymore since Victor added “Hubitat” to every HE hub name given to Apple Home.

What iOS version are you running on your devices?

Agree but trying to narrow things down. I just posted in the beta forum an interesting bug. If I click my scene controller from my Lutron integration everything in homekit goes unresponsive, uncheck it and it goes back to normal. I wonder if there are some other device types that do the same thing.

I saw that. Very odd. I think there is some underlying issue here and perhaps on the Apple side as well. I noticed that if I add any new child bridges from Homebridge, they don’t show up (or their devices) in Home since the optional Home upgrade.

1 Like

Interestingly enough my whole section of button controllers seem to do the same thing. Wonder if that is what's causing some of the issues for others (button controllers)

1 Like

This worked for me.

I had the same issue dsimpsonjuice described. Deleted the hub (named "Home") from HomeKit, renamed my hub, re-added it to HomeKit and everything was fine.

Thanks for the advice!

Try Rebooting whatever apple products you have that are HomeKit hubs. ie home pod Apple TV, iPad. Reboot all of them. If its home pods make sure to unplug them for a few seconds.

Is this due to them being lan devices? They shouldn’t show up at all, right?

Define lan devices... Such as other hubs or hub integrations to hubitat? My lutron switches and dimmers show up fine and work fine. Just seems to be buttons that cause the no response.

1 Like

I thought I read that lan devices including wifi bulbs, Hue bridges, and Lutron wouldn’t be supported in the Homekit beta. I know that Hue bulbs don’t show up.

1 Like

My Lifx wifi bulbs and lutron switches/dimmer work fine. My Lifx wifi strips also work fine... Hmmm

As long as you have a HE driver with a defined device you have a chance that it is supported, if you are using an app for the integration probably not.

1 Like

I think that changed, Only barrier devices aren't allowed. They allow the custom drivers and what not. @gopher.ny posted that at one point around .112

Mesh devices aren’t supported

Download the Hubitat app