Homekit Integration Failing

I have the new HomeKit integration set up on the Hubitat side, but when I try to connect to it via the home app, it throws a connectivity error. My hub is on a different VLAN than my wireless, but that has never posed any connectivity issues before. Has anyone run into this?

Have you configured your router to permit mDNS across VLANs? Without that, the Home app will never discover Hubitat. Otherwise put Hubitat in your wireless VLAN.

1 Like

Damn, that’s what I was expecting. Looks like I’ll have to play with my network to get things flattened.

Timing out on the Home app side? Apple Home is having trouble finding bridge. In my case I believe it’s the unified bands on single SSID

I have enabled Homekit Integration as well and having failures getting it to connect. Only way has been to select " reload devices " and eventually it works. But then after setting up the Bridge and device, the devices show " No response " from the HomeKit app.
Apple Hub and HE device both connected via Wired connection to same subnet. No Router between them and not connected via Wifi.
Have removed the Homekit App and re-installed and i get the same result.
Apple IOS 16.1 and latest HE update.

We're working on the issue. In the meantime, if you can PM me the hub id, I can check the engineering logs on the hub for possible clues.

Ended up getting mine working by wiring it through the Wireless router so it’s on the same VLAN as the rest of the wireless network.

Putting the hub on the same VLAN didn't help me, still getting "Accessory Not Found". Any other ideas on how to make this work?

I've restarted integration and devices numerous times with no luck.

Are there any restrictions that would disable traffic on ports 5353 (UDP) and 21063 (TCP)? Are there any multicast restrictions or custom settings on VLAN? If you have a later model Kasa plug with HomeKit integration, can you try putting it on the same VLAN and checking connectivity?

Following are nmap scan results:
PORT STATE SERVICE
5353/udp open zeroconf

PORT STATE SERVICE
21063/tcp open unknown

The hub is currently in "local net" (though I'd like it to be isolated), this VLAN has not restrictions whatsoever.

Just to confirm, you scan the QR code, and after a minute or so of thinking Home app complains that accessory is not found, is that correct?

that's correct

So I'm not sure what changed but it finally worked, I rebooted my phone yesterday maybe apple has some bug or something... ¯_(ツ)_/¯

1 Like

Download the Hubitat app