Homekit Integration, blank app page

Running the latest firmware, going to the HomeKit app page brings up a blank page as below:

Using the Safari on iPad iOS 17 without extensions. Reboot brings it back. What’s going on?

Was it a one time thing or does this keep reoccurring? Does HK still work or does it stop working and then you check and find this?

HK still works. I just got the sense that the UI elements don’t appear for one reason or another. Other apps don’t show this behaviour.

This is on a C8 by the way.

Edit: reboot does not fix the issue.

I also wanted to mention I had the HK app installed while it was in beta and transitioned into the final release with the software update a month or two ago.

Have you tried clearing your browser cache?

Yep. Tried this on a desktop under Firefox on Windows too and no change. Log shows a recurring error:

Did you happen to delete a device that was being shared on that integration? The null is a good clue to that, it may be looking for a device to display on UI which no longer exists. There is warning when you delete devices about removing them from apps, but usually the devs have some checks in place so the app does not break. May have been missed in this app. @gopher.ny will know by that error whats going on.

I did shuffle devices around a while back, but not since the last time I used HomeKit successfully.

Should I remove and re-add the app? Is there a way to remove devices safely?

I am not sure if that will blow away your pairing code and settings, I assume it would but not sure. I would not do that yet unless you are OK with having to redo the entire setup. I would wait for @gopher.ny to comment on here first, he may be able to push out a hotfix for it since you provided the code error above.

Yes, use the "in use by" at the bottom of the device page and go into each app it is being used in and remove it from the apps before deleting the device. I think a warning pops up telling you that when you click to remove a device. Although doing an exclusion may not warn you and just removes it.

I have the same issue. Anyone find a workaround? All current devices are working fine, but I obviously can't make changes.

I ended up removing the app, rebooting, and re-adding the app and it seems to be working ... for now. It kept the pairing code too.

Last time I tried removing the app I did not reboot and had the white screen.

… and it’s back to a blank page. :face_with_spiral_eyes:

@gopher.ny or @bobbyD can a dev chime in here please?

@nbrew is it creating the same error in the logs as before?

I was seeing the same error as before, but the page went away after a reboot. Still holding for now.

If you're still seeing this issue, please PM me the hub id. I'll take a look at the engineering logs on the hub.

Seems to be resolved with a removal, restart and reinstall of the app.

My homekit integration was showing completely blank on my pc browser dashboard so I deleted it and reinstalled it but it's just showing blank and not letting me set it up again. how do I fix this please?

@user6476 I moved your post to a more relevant topic. Try the steps listed above, remove the app, reboot the hub, then reinstall the app.

If still not working please check your logs for errors and post a screenshot.

Shoot, my pictures uploaded, but not my narrative. :slight_smile:
I am having issues with my Homekit Page showing blank. I followed the suggestions listed above, including uninstalling the homekit app, rebooting the hub, and reinstalling the app.

That appeared to do the trick, up unitl I added a new device, then I am back to the same error / blank page.

I updated to the new hub version last night, hoping that might fix it, but it didn't.

I reset my z-wave radio to kill a stubborn ghost that wouldn't remove even with a PC Z-wave Stick. Before doing that, I renamed all of my ZW devices to add a "_OLD" to the end of the name, then reset the radio." All of the old, reset devies of course still showed in Homekit. I wanted to use Homekit to easily track my newly added devices, so I went through and disabled homekit on all of the "_OLD" devices. Perhaps I did that too fast, but it seems that AFTER rapidly removing old devices from homekit, this error came about.

I sent a PM to gopher.ny as well asking for help. Any insight would be greatly appreciated.

Looks like you possibly deleted a device which was still authorized in the app and the app does not have null checking in it. Usually deleting the app and then reinstalling it would fix this. After you delete the app have you tried rebooting the hub before installing it again? Not sure if that would make sure the HK service is totally shut off so it is cleaned up when you reinstall it.

I would expect on a new install of the app that the authorizedDevices list would be empty.