HomeKit - Honeywell T6 Thermostat

So far, the integration is working great for certain devices, but one hole I've found is that if I have the thermostat mode set to "Auto", it doesn't show the heating & cooling sliders separately and it's impossible to set the setpoint of the thermostat. If I set it to Heat or Cool, I can then set the setpoint.

It's definitely possible to have this work as it works OK from HomeBridge, so thinking it might just be a miss. I tried both the generic Z-Wave thermostat driver as well as the Honeywell specific ones with no change in behavior.

Has anyone else run into this or figured out a workaround?

I have a T6 as well, and I switched it to the "Generic Z-Wave Plus Thermostat" driver, and now it works in homekit. (I'm having trouble with scheduling, but that's a different issue, probably).

Edit: Now it works fine with the "Advanced Honeywell T6 Pro Thermostat" driver too. So, maybe it was moving to .116 that fixed it.

No, the driver was out of date, as described in the other topic.

Download the Hubitat app