Homekit devices not showing up in shortcuts

Not really an HE question at all....

IOS 16.1.1. I have successfully added homekit integration and a couple of devices, which I can control manually from the home app just fine.

I'm trying to create a shortcut that turns on and off some homekit devices. When I try to add a home action in the shortcuts app and click on Scenes and Accessories, all that comes up is a blank white screen. None of the devices I have added to homekit show up.

I've googled and it appears to be a known issue but no one seems to have a solution, which I find really weird. I'm wondering if it has to do with the homekit integration still being in the certification process...?

End goal here is to have my alarm system arm itself and all the doors lock themselves when my iPhone plugs into CarPlay... I'll do all the locking and stuff on the HE side based on virtual switches, so all I really need to do on the iPhone side is turn on the switches when CarPlay becomes active.

Hmm, I think this is working for me.

A few people have mentioned in another thread they can’t get the Home app to work with Lock Screen widgets.

Out of curiosity, are you able to do that?

Have t been able to get that far.

Sorry, I might just be making things more confusing.

It should be a separate process to get the Lock Screen widgets to show up, not strictly related to what you’re doing with Shortcuts.

It’s just that some people seem to be unable to add the Home app to their Lock Screen. I’m able to do that, and it looks like I’m able to create a Shortcut too.

I haven’t actually done it, but judging by your screenshot, I’m not seeing the problem you are. After tapping on “set scenes and accessories,” I see this:

I’m just wondering if it could be the same underlying problem for the Lock Screen widget and your issue with the Shortcuts app.

I tried adding widgets - no go there either.

Even though I'm Apple fanboy #1, I'm rapidly coming to the conclusion that IOS 16 is riddled with bugs. I've also had wifi issues, all of which are well-documented in a number of forums. All in all have to say the homekit experience (no fault of HE) is disappointing.

1 Like

Lock Screen widgets working fine here on iOS 16.2 beta. Should be public shortly.

No problems for me on iOS 16.1 either. I’m not sure why some people seem to be having issues.

I have the exact same issue. I was excited to manipulate devices controlled by my Hubitat using Siri, but so far the documentation is weak to say the least. I managed to stumble my way through toggling a simple switch in Apple's Home App, but that's as much as I've achieved.

Hubitat, please enlighten us on how to use Siri with Hubitat. I'm guessing it's an issue with iOS, but since there is no documentation from Hubitat, my guess is you haven't tried to test Siri integration. If you can't get it to work, us mere mortals have no chance.

I use Siri routinely with my Hubitat devices included in the HomeKit integration -- and have zero issues with them. What is the problem you are having? Be very specific.

The things I do include:

  • Turn switches on or off
  • Set dimmers to level
  • Find out what level a dimmer is set to (question to Siri)
  • Open or close shades
  • Set thermostats
  • Find out what state and temperature is a thermostat (question to Siri)

The documentation for Hubitat’s HomeKit integration is here.

I’m not a developer so can’t say for sure, but I’m not sure it’s possible for this integration to “work” in the Home app but not with Siri, or require some additional steps from the user.

Both Siri and the Home app are on the iOS end of the integration with HomeKit (Apple’s framework for integrating smart home devices).

Hi Bravenel. What was in the original question says it all...maybe too much. This part is what I find pertinent.. "When I try to add a home action in the shortcuts app and click on Scenes and Accessories, all that comes up is a blank white screen. None of the devices I have added to homekit show up." What device is irrelevant as nothing shows up. What you're trying to automate is also irrelevant, as nothing show up.

I banged my head against the wall a few days ago on this, and got no where. This question prompted me to try again. I thought perhaps it had been enough time for somebody to figure it out. I tried it again...same result. Tried yet again...nothing. Tried a third time (same exact steps), and much to my surprise, up comes a list of devices. What was the magic that caused it to suddenly work? No idea. Each time I tried, I searched around the internet to find a new nugget of information. Always the same advice, so I just kept trying like a delusional madman.

Some sort of network timing? Alpha particles? Aliens? Ghosts? No idea. The lucky folks with the combination of factors that make this stuff reliable probably think the rest of us are nuts. I swear, we're not. Just unlucky.

@bravenel For the record I don't think my issue has anything to do with HE... that all seems to work fine. I just figured maybe someone here had the answer.

I have a shortcut running on my Apple Watch that is turning on a power plug on my balcony.

1 Like

I agree with you. I doubt its related to HE. I was hoping that somebody here had stumbled onto some network setting, or a place to see logging in Homekit that might provide a clue.

I still wear a mechanical watch. Hard to give it up. But that is cool.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.