HomeKit - Accessory out of Compliance

As the title suggests, having issues with the app updating so reset it. Now I have this message come up and it won’t work.

Can you PM me your hub id? I'll take a look at the engineering logs (although not on Thanksgiving :turkey:). In the meantime, can you start start with one device/accessory, then add one at a time, wait for it to show up in Home app (or not), and see what breaks it. I may be able to spot it in the engineering logs, but this is the fastest way to narrow it down.

1 Like

I also am getting this when trying to add a Window shade but adding a different type of device works. I also notice that none of my hueBridgeGroup devices are showing up as devices to add to the HomeKit integration. FYI I currently use Homebridge v2.

This much is normal: LAN devices are not supported (but if they are official Hue bulbs, they can be integrated directly via the Hue Bridge).

Will do in the morning, since my original post I have added a few at a time and waited for them to come though. I think I just overloaded it but trying to do so many at once. Many thanks.

Sent information via PM, thanks.

1 Like

FYI — I started with one light, it went well.
Then more and more until it finally fell over with 33 devices. Got messages telling me hub was overloaded. ( I have 2 hubs networked together )
I did remove apps and anything I could think of to lower load on hub. After a reset or two and apps removed, I’ve not seen the overload situation again.

So i started to reconnect HomeKit. I decided this time to just adding contact switches and water sensors — about half ). Tried resetting the QR code, and finally figured out that I also had to “unpair all controllers”. That got it to where it would start to reconnect. It scans QR code ok, but then I started getting the dreaded “accessory out of compliance”.

Since then, I’ve not been able to get it to where it will allow me to re-add the bridge to HomeKit.

Any thoughts?

Ok an update. Tried the reset and this time removed everything but one item from the list before repairing. That got me thru.

Perhaps bringing on that many devices is an uncertified action?

It shouldn't be. Most likely, there's a particular device that's tripping it. The best way to find it is adding one device at a time and watching Home app update. If you go that way, please let me know which device (or devices) it was.

How do you go about deleting the non-responsive devices already added to HomeKit? The 'remove' button referenced in Apple's documentation isn't there. I was contemplating removing the bridges and devices I've added and waiting until the situation is resolved. Don't, however, want to complicate things unnecessarily.

Just uncheck the device in the HomeKit integration app and give it ~20 seconds to reflect the change in Home app. To remove all devices coming from Hubitat in one shot, click/hold on an unresponsive device tile to go to a device details, then click gear (:gear:) button at the bottom. Select Bridge, then Remove bridge from home.

Thanks Victor. I tried last night to uncheck devices in the integration app and that change never propagated to HomeKit. I ended up removing the bridge(s) which then took care of the devices. I'll wait until things settle down with the integration to try again as I'm running 16.2 beta on all devices and that seems to be causing at least some of the challenges.

Thanks so much for all your hard work! Definitely looking forward to being able to natively link Hubitat devices to HomeKit.

1 Like

Download the Hubitat app