Homekit Accessory Not Found

I just bought a Habitat (elevate C-7) primarily to get a few z wave devices integrated into Homekit. I'm starting with a Honeywell T-6 Pro thermostat. I have a medium sized Homekit smart home with garage doors, light switches, Unifi cams and doorbell (via Homebridge) and use 2 Apple TV's as my Homekit Hubs. Unfortunately, I just can't add the Hubitat bridge to Homekit and get the dreaded "Accessory Not Found" message.
Hubitat 2.3.4.133
Apple devices are all on 16.2

I do believe I did not upgrade to the new Homekit architecture when it was briefly available last month fwiw. I didn't even have any devices in Home until a couple weeks ago. I can find my Hubitat at findmyhub from my iPhone that I'm trying to add it to Homekit with. They both have 192.168.0.X ip addresses and are in the same LAN. I've restarted my switch, router, phone, iPad, Apple TV's, and soft reset the Hubitat 3 times.

I've restarted integration, relaxed and un-relaxed home hub pairing security, and reset QR pairing code dozens of times. No joy adding Hubitat to Homekit via QR or the code. What gives? I've got daughter bridges in HB running on VM's and never experienced so much troubles. I gotta be missing something here. Your help is appreciated in advance.

Did you set a static IP on the Hub settings or is it using DHCP and getting IP/DNS from the router?

Go to settings >> Network Setup >> Click Network Tests
Try doing a Trace Route to something basic like google.com, or ping one.one.one.one (not 1.1.1.1).
This will test if DNS resolution is working.
If its not working you need to fix your DNS settings.

Just a stab in the dark, not sure if the HK pairing needs cloud/DNS access for anything? But the DNS not working is a cause for all sorts of random problems people seem to have.

Are you running vlans? Are you running static ip? Is relaxed security turned on in the Homekit integration? (At the bottom)

My Hubitat has a static IP, I’m not using VLAN’s, traceroute and ping come back fine so DNS seems to be working well.

Oh, and I’ve tried it with relaxed security and without relaxed security at the bottom of the HomeKit integration page, no dice.

Just to play devils advocate, you could very easily add the app Homebridge-Hubitat-Tonesto7 V2 by Tonesto7 to Hubitat, and the corresponding Homebridge plugin since you already are running Homebridge. This can be run concurrently with the Homekit beta app. I have two hubs with both apps running on each and no issues. The Homebridge-V2 app on HE creates the config file in the app that you can paste into the Homebridge config.

1 Like

Switch it to DHCP and do a reservation in your router instead. Make sure both homekit and the hub on the same subnet. Then restart the integration

1 Like

DHCP with IP assignment by router was my primary configuration. I've since tried DHCP, as well as Static from the Hubitat. None of them work. All configurations pass all network tests as well.

Are homekit and hubitat on the same subnet? For giggles I would press the network reset button on the bottom of the hub for 7 seconds with a toothpick or paperclip. It is the only round hole out of all the square ones. (This will not reset the hub, only the network settings)

1 Like

Have you tried adding it with only one device selected? Could it be one of the selected devices that is causing a problem? I am at a loss, since you said that you have Homebridge running already and everything is running on the same subnet (assuming that you’re not having issues with Homebridge).

I reset the network on the bottom of the device, no joy. The only subnet I'm using is 192.168.0.0/24.

I only have 1 device added at the moment, the Honeywell t6 stat. Homebridge is running my Unifi cams and Flo by Moen to Homekit and it works great.

My smart home is a MyQ Home Bridge, a Lutron bridge, a Homebridge instance with a couple daughter bridges inside a virtual machine on the network, and native Homekit devices with a couple Apple TV 4k's (2021) to act as the hub controller.

In Hubitat which driver are using for the thermostat?

1 Like

It shouldn't, the integration relies on mDNS broadcasts to advertise itself.
At the risk of stating the obvious, this sounds like an Apple device (home hub) can't find the hub.
Can you try creating a new home (without home hubs) in the Home app and try adding Hubitat integration there? The Apple device (iPhone, iPad, Mac) should be on the same LAN as Hubitat hub. This setup should connect direct and test out whether it's something wrong with the integration vs. something is wrong with connectivity.
If that doesn't work, please PM me the hub id, and I can take a look at the engineering logs on the hub.

2 Likes

You're right, it does seem as simple as the Apple device can't find the Hubitat bridge. It didn't work with a "test home". You're comment on mDNS intrigued me as I don't know much about that. I did find a setting to enable multicast DNS in my Unifi router, that didn't make any difference but I'm not sure it should as I'm not using multiple subnets or VLAN's.

Mdns is what Apple uses to find devices on the network as far as I know. I believe that’s what bonjour is.

1 Like

My issue is similar, I get an "Accessory Already Added". I do have Vlans, but confirmed that the Hubitat and Homebridge are on the same Vlan. I set the relaxed security on Homebridge server as well. Is there anything else?

Reset your QR code and re add

Sorry I figured mine out, adding this here for anyone else. I was able to do it by using - Unpair Bridges / Cameras / TVs / External Accessories . I had several here under the Home Bridge server settings. http://192.168.XX.XX:8581/settings

oakweb- we have opposite problems! You're too connected and I cannot connect still lol.

1 Like

I figured it out. It is a Unifi/Apple thing. I had to disable "Multicast and Broadcast Control" in the settings because with it checked it wanted to clamp down on all things mDNS unless it was added to an exceptions list (which none of my devices were).

2 Likes

Download the Hubitat app