Homebridge tonesto7 Alarm trigger doesn't work

Installed home bridge, everything OK but security system in homebridge.

I can easy change Away-Home-Night-Off. But I can't trigger alarm in home app.

  1. I armed away
  2. Triggered motion sensor
  3. HSM shows that there is intrusion. OK
  4. My siren is ON. OK.
  5. Security system in home app shows nothing. BAD

As I know, when there is intrusion, home app should show that there is alarm.

What am I doing wrong.

Tried to readd the HSM device to homebridge, but nothing

probably should move this post to [RELEASE] Homebridge Hubitat v2.0 so @tonesto7 knows. This is for his latest version btw.

1 Like

I'm pretty sure this was working. This is going to be challenging to test because the wife is home but I'll see if I can duplicate it.

I can also confirm this - this just happened to me yesterday. On latest versions of HE and plug-ins.

@dsh1705 @Ken_Fraleigh @alpol017

Sorry I haven't got back to you on this. I tracked down the issue and a fix was just released for both the Hubitat app and plugin (v2.5.7).

Please keep in mind that while it works you will see a warning in the Homebridge Logs:

This plugin generated a warning from the characteristic 'Security System Target State': characteristic was supplied illegal value: number 4 exceeded maximum of 3. See https://git.io/JtMGR for more info.

This message is harmless.

1 Like

Fantastic! Thanks for this fix - just so you know, I am one of the folks who support you via PayPal (doesn’t everyone who uses this? :grinning:)

1 Like

Yeah! It works. Thank you!

Just had an alarm trigger, but no notification in the Home app - maybe the issue is back?

I will check to see if there was a code regression.

I see an update to the app and plugin - problem solved?

Yeah. Issue is back.
@tonesto7 help us please :blush:

Is this just since updating to 2.3.1? I’m pretty sure this was working on 2.3.0.
I’ll try to remember to test mine when I get home. Dummy me didn’t think about trying this during the beta.

I've tried fixing this but i've been unsuccessful. I'm sending the right values but Homebridge doesn't seem to think so.

I haven't had a ton of time to devote to my HA projects but if someone wants to tinker with it and figure it out I can push out a fix ASAP.

1 Like