Home Remote dashboard for Hubitat

I saw you posted on the Hubitat forum :slight_smile: I appreciate you calling me the "developer" of this integration, but that's far from the truth. You are so much better off with help from Bill versus me! That said, I do want to help as much as possible.

After Bill's update tonight to the designer, I was able to successfully sync and control a couple of devices. I put some minor changes for the plugin script on github. I would start with one device, say a switch, and the new plugin script and see if the error goes away. Just put the new script in Home Remote and rediscover devices. If the error goes away, then you can add things back incrementally and maybe identify the cause.

Or, if you prefer, Bill now has a Hubitat Hub, and creating his own integration is planned - which I'm sure will be miles ahead of this. I'd put that out a couple of months though.


I modified and posted the plugin script code to better utilize the templates. Not all devices will fill in automatically, but it should be a good starting point.

After completing the initial steps, syncing devices should create a list like this. If it identified a device, it should have an icon.


and data should be filled out per device identifying which built in template template Home Remote should use.

To use the built in templates, you would then add the devices to the home group:

And then when you run the simulator, it should pull up the recognized devices.

Obviously that is with no customization, which I assume anyone who tries this program would want... but hopefully it will help someone see some results rather quickly.

@shadowjig I have no idea if what I changed will help with your issue. I hope so. I played with it for quite a while tonight and didn't see that error.

1 Like

Thanks for all your help on this. I got the designer to work and all my devices show up and can be controlled using the simulator however once I transfer the file to my iPhone all the devices show up with unknown status and when I try to use a switch it says ""Settings is null". Any idea what is going on?

Unfortunately no. But, that doesn't mean I can't come up with some BS :).

I don't have any apple devices, but I did see in the home remote threads some issues with the new version and iOS. I'd make sure the app is up to date. I honestly didn't pay attention to the iOS issues so not sure what they were or if they were all fixed yet. I'll try to find the posts again later tonight. It also takes a bit for the updated apps to show up in the app store.

If you have an Android device, maybe test on there to confirm it is an iOS bug.

1 Like

Okay...thank you for getting back to me. I'll keep an eye out for the iOS app update and I'll try searching theyre forum as well.
It's great that Bill now has a Hubitat so hopefully he'll add native support for it soon. I have been looking for a fully customizable dashboard app like this for a while now.

Update: It is working now with the latest app updates. Now to learn how to use the designer software...


I'm running into an issue that I don't see anyone else post about. In my logs I'm getting this error immediately after Poll Requested:

java.lang.NullPointerException: null on line 295 (poll)

I'm not well versed in this code but this is the line it's referencing:

lastPoll = Date.parse("yyyy-M-d'T'H:m:ssX", lastPoll)

Any ideas or suggestions? Thanks for any and all assistance for this newbie!

Hi Kurt -

I don't actively use this particular code to connect to Home Remote anymore (more on that in the next post for everyone who reads this), but that is actually a benefit because I just installed it from scratch. Unfortunately, I'm not seeing that issue.

Some starting questions:

  1. Have you made any modifications yet to either the Hubitat App Code or the Home Remote Plugin Script?
  2. Were you able to sync your devices into Home Remote, looking similar to this (I brought in 2 devices labeled kitchen, the others were automatically added):
  3. Is this happening from the simulator in the designer app, or after you've moved the project to an end device?

A general post about the current state of this project:

Home Remote, designed by someone wholly unrelated to me, is chugging along great with new features being added all the time. I'm still actively using and promoting it.

I originally worked on this code, with the developer of Home Remote, to get a connection between Hubitat and Home Remote after switching from SmartThings. Code is not my specialty! But I was motivated to get my dashboards back up after moving to HE.

The main issue with this integration is that it is using HTTP to connect. Using this code, Home Remote gets its status updates by constantly polling the hub. This can put a strain on your hub, however, does work well and is snappy in a lot of cases cases - such as if you want to access the system from outside your network or if you only have a limited number of devices you are trying to control. This code worked really well for me for a while with an always on dashboard - then I multiplied the number of always on dashboards I was running and dramatically increased the number of devices being polled (100+).

I have currently switched to using MQTT as the connector between Home Remote and Hubitat. MQTT has it's downfalls as well - The first is that the MQTT broker / server needs to be run on a separate always-on device to act as a middleman between Hubitat and Home Remote. The second downfall is you'll have to figure out on your own how to get some form of secure out of home access (I'm using a VPN). The huge benefit of MQTT is that it doesn't constantly poll the hub, nor does Home Remote need to constantly parse the poll data coming back from the hub. The MQTT code only "activates" on state changes of the selected devices, sending status updates without the need for polling.

For anyone trying to set this up using MQTT, I would highly suggest @kevin's MQTT app:

and then you'll need the MQTT plugin script:
(see the February 12th post with the example as an attachment)

I am still interested in keeping the HTTP code working as well, but as I'm not using it I often won't realize something has broken - nor does it get top priority. If you see any issues, or have updates to the code please let me know. After loading up this code tonight I see there are at least 2 issues that need correcting:

  1. The latest version of Home Remote assigns templates automatically, so that part of the plugin script can be deleted
  2. For a color bulb, switch,level and color temp are working, however color is not. I believe something has changed on the Home Remote side, which should be easily fixed in the plugin script.

I'll put these two on the to-do list, if anyone else gets to the first, please share!

1 Like

Thanks so much for your speedy response. I'm not really sure what the problem was. I deleted the app, replaced the source code again, and added the app back, this time with only a couple of switches just to start simple, and all is well! Time to mess around with Home Remote Designer and see what I can cook up!

1 Like

I've had all sorts off issue with the app since the major update happened late last year. I'm noticing that the updated version of the Hubitat code and the script I can't access my hub remotely. I may try and start from scratch and see if that makes a difference. Also the connection between Home remote and Hubitat is really slow on the LAN.

Unfortunately, the major update to Home Remote around December 2019 changed a lot of the background settings, and the December release of Home Remote that updated your old project might not have transferred/upgraded everything perfectly - it didn't for me. I believe that the latest versions transfer a lot of the settings better, but if your project fie has already been upgraded you must either upgrade again from a saved pre-December backup version of your project or manually fix things that are no longer working. I've gone the manually fix route, which has helped me learn a lot of the new Home Remote features. PM me with any specific issues and I'll see if I can help. The good news is, the new version is a lot more powerful... Home Remote can do so much, but can be very confusing/time consuming. The December update compounded that with the new features that were added and all the settings not transferring correctly.

I haven't noticed this, but as said I don't really use the HTTP connection anymore, I'm using MQTT. But I'll definitely help however I can. I'll try to get to updating the plugin script to better work with the new version this week. But I have no idea why it wouldn't be working remotely - I don't think anything changed there. Really there isn't much to the script (or I wouldn't have been able to figure it out!). Possibly you changed/updated your OAUTH credentials, and Home Remote needs to be updated to match?

I don't think, though just guessing, this specific issue is related to the Home Remote update. The code / plugin for MQTT does need to be relooked at, but I don't think it should have affected speed - either it works or it doesn't. I think the slowness will be more related to the number of Home Remote dasboards polling / number of devices being polled - if you have increased either of those. This HTTP code isn't great for large applications, the MQTT does work much better, if you are willing/able to give that a try.

Is it slow on sending commands from Home Remote to Hubitat, or for Home Remote to poll the changes from Hubitat back to the Home Remote dashboard - or both?

I ask because I did change a setting recently in the plugin script on github for how often it polls the Hubitat hub for current device statuses. The code looks line looks like this:
I forget what it was before, but right now it is asking for device changes every 3 seconds, which actual times could be longer than that depending on how long it takes to actually parse the data. I increased it because I was concerned it could be bogging down people's hubs (though I've had no reports of such), you can decrease that value and it will poll the hub more often. That shouldn't affect how quickly hubitat reponds to a change from Home Remote though - just how quickly Home Remote notices a change from Hubitat.

Glad to hear it is working, and Good Luck! Let me know if I can help.

Hi AndyM!

Just wanted to post up to let you know and possibly get some help, I think there has been some updates that broke your original integration (it was working great for the last few months). I noticed that my bindings became broken and it had to do with being case-sensitive. I fixed all the capitals so now the bindings/commands work but something is broken in the polling.
I get the following issue in the log.

Any ideas what I could do? Any help would be massively appreciated.

Got it working..
I deleted the following points in HR:

I re-synchronized the devices (notice they have come in with uppercase now)

I modified the HR Plugin and HE App by doing a Find and Replace (in notepad). It doesn't like the space:

Seems to be working perfect!

Hi Jeff,

Sorry for my slow response. I'm glad you got it working!

This integration definitely needs some love with all the changes on the Home Remote end, I just haven't had a chance yet as I've been focused on getting mine up 100% with MQTT.

The naming conventions in Home Remote have changed a little, as you saw, to be more compatible. The Log device probably isn't needed anymore, as he has built a log into the plugins, so I can probably remove that. There are a couple other clean-up items as well. I hope to get to this soon. Sorry I didn't get to it before it caused you trouble.

You certainly need to apologize for nothing! I'm not sure you need to make any changes other then change "Last Poll" to "LastPoll" like I mentioned above. Seems to be working well. I appreciate yours efforts this far!

I'm not a coder but, I was able to track this down with clues here and there. Any problems worse than this, I will be at the mercy of someone smarter than me!! When the time comes, I will adventure into writing code for something simple but, for now, I am a master of the copy/paste.

Hopefully Bill doesn't keep making changes that break this!

Thank you!


I want to thank @damore.jeff for his help on getting this working again. I didn't notice it was broken as I'm using @kevin 's great MQTT code as it is more efficient with the number of devices I'm sending to my Home Remote dashboards.

With Wink starting to charge and people switching to Hubitat, I've reached out to the Home Remote developer and he tells me an official Hubitat integration is near the top of his list - hopefully by the end of next week. I'm a hack when it comes to code, so there is no sense in me updating my github code only for an official integration to come out days later.

So huge props to Jeff for fixing the issues. His code can be found here:

If for some reason Bill @ Home Remote isn't able to do an official integration, I will of course update my code. But on the more likely side, if he does update, I will end this thread with a link to his official code and close it out.


The official integration was earlier published today in the 3.1.0 release.


Per OP's request, this topic has ran its course.

Information in this thread is old. It may still be valuable and give some ideas, but it relates to prior versions of Home Remote and a no longer actively developed integration. Instructions on how to set up the new integration are on the Hubitat topic linked above and The Home Remote Community forum, link was also listed in the first post .