Here we go again & again

Errors for RM app (this less than 24 hrs after a soft reset and restore to try to fix slow down and seize up issues)....

I was getting errors on Google Home app. Blew that connection away and rebuilt it. Now I'm seeing this RM app error (didn't spot this one before).

Would just like a few days with this wretched hub without any issues.

I'm also seeing errors on Sensibo (as posted on here under that thread).

My other hub at different location works fine with no reboots necessary and similar apps (GH, Sensibo, etc. no errors).

People have mentioned in other threads that a dodgy lan cable or power supply can cause issues.
Have you tried changing these to see what happens.
I don't know if this works or not as I have not had the issues you are getting but it might be worth a try.


Column not found indicates database corruption, which could likely be the cause of many other problems.

Have you rebooted recently? I think it does a database recovery during boot...

Last time I had DB errors made a back up and did a soft rest

Time to do a soft reset.

Yes, I think the OP knows that... He just said it has been <24 hours since his last soft reset... Yes, it looks likes he needs to do it again, for whatever reason though.

I know I would be very frustrated if I got database corruption in <24 hours after a reset, too.

Just an off-the-wall question, there aren't any special characters being used in rule/device names are there? Commas, quotes, etc...? Is it truly database corruption or query corruption?

Ha ha ha again? These errors follow a soft reset (within less than a day).

This hub is rebooted nightly.

Yes getting mighty frustrated with this wretched hub...

No commas or quotes but many use hyphens. But so does another hub at a different property that is completely fine yet runs a similar set of apps but fewer devices. It's strange indeed.

Done already. This situation follows a soft reset. And today the hub's remained up but slow at times and yet fine at other times. As an example, went out to the terrace this evening, the lights didn't come on. Went back out 10 minutes later, lights came on as designed. No obvious issues I can spot in the logs.

Time to log this with support I think. Right now this hub is more or less worthless.

Is the hub getting too hot?
You shouldn't need to rebuild the DB so often

With a hub reacting like this, I would look to external or hardware problems


Possible power issues too?


Either intermittent power loss or 'spikes' or the like
@Angus_M do you have your hub on a UPS?


1 Like

No, it's running quite cool. It's in the lounge which is air conditioned most of the time. I don't think that's the issue. I'm going to try it upside down anyway just in case that helps.

I wasn’t going to jump into this conversation because of the high level of animosity.. But had to throw that out there as a possibility..

1 Like

Have tried the suggestions I made?

1 Like

I'm trying a new LAN cable currently. If no improvement tomorrow still then I will try a different PSU.

1 Like

Didn't think about this. Maybe. I'm trying a new LAN cable today as suggested by @bobbles above. If that doesn't help I will try another PSU. It's not on a smoothed supply. Maybe I can try to get a smoothed UPS or something if it will help.

1 Like