HEmail Fails to Send to Local Relay

I'm trying to use HEmail and I keep getting this failure in the log:

I'm using a Synology NAS as an SMTP Relay, and tested that separately and it is working fine.
I have the settings set as follows. I'm using the Synology NAS' username and password for the Email User and Email Password fields. Can any help me in determining what this error is and how to fix it? Thanks for your replies.

Looks like you need to include an integer in the sendMsg call... After the message text... Does the driver include a sendMsg method (command) that includes a String and integer parameters?

A link to the driver you are trying to use would be helpful...

I'm not a programmer and this is beyond me. Here is the source:

How are you trying to call the sendMsg method / command, are you calling it in an action in an RM rule?

I'm the original author - @kahn-hubitat forked my version and made some great adjustments you might want to check it out..

Otherwise happy to troubleshoot but it's been a while! I now use Node-RED and secure email.



All I'm trying to do right now is test it. I'm entering a test message in the Send Msg box at the top. Nothing gets sent, and the log has the error msg above.

Sorry, guys I'm new at this. All I'm trying to do here is (eventually) get an email message when a water leak sensor is tripped.

Try adding an additional parameter that is an integer of 250.

Tried the V2 SendMail and got the same error

What about adding an additional parameter?

Where would I add an additional parameter? The device screen only has a "Configure", "Device Notification Text", and "SendMsg".

Hmmm.... I would refer you to @erktrek ..... How are you trying to initiate the call to the sendMsg method / command?

Just typing short message in the SendMsg box on the device page then clicking SendMsg. This as far as I've gotten.

maybe originally but now it is totally different as it has child processes etc.

mine still will not work if your isp requires ssl or tls connections..

1 Like

try device notifications instead of send message

1 Like

@kahn-hubitat tends to produce better versions of my drivers, so would suggest @kahn-hubitat 's version of any driver...

1 Like

He is the original author of this driver.

1 Like

Then you are in good company :wink: If you need any assistance let us know....

Not true but thanks


Okay, I decided to drop HEmail and switched to SendmailV2. I created a simple notification that when a button is pushed, it sends an email. STILL doesn't work. My SMTP relay log is blank. Maybe someone can look through this debug log and determine what I'm doing wrong.

log is self explanatory whetever email server you are using is not allowing relay as it says recipient address rejected.. error is on your server side.