Help with Zooz Zen74 S2 Dimmer controlling Fibaro RGBW

OK. Let me preface this post by saying that I am a Hubitat Noob (just jumped from ST and Wink years ago), and the answer is probably (hopefully) something very obvious that I just don't understand yet. I'm hoping that despite all the noob eyerolls and temptation to simply say "read the F-ing Manual" somebody has the kindness of heart to walk me through my issue.

So I have a Zooz dimmer. It is set to "physical control disabled" so that it doesn't actually cut power to the RGBQ strips. Then the strips are controlled by a Fibaro (V1 I think) RGBW controller. I am able to control the Fibaro from the "Device" in the App, so it is definitely working.

I used Button Controllers and set it up so pushing button 1 (I'm assuming that means "toggle up") does an action that is a Dimmer capability and triggers a "custom command" for setWarmWhiteLevel, with a number Parameter of 100.

It seems to me that this should turn on the warm white LEDs...but it does not. What am I doing wrong?

I’m not familiar with the light strips you are using, but why use custom commands instead of the built in ones?


Set Color or Color Temperature Bulbs should do what you want. Otherwise you can try adding an “on” command to the custom commands that you are sending, although a “setlevel” should turn it on unless there is some sort of prestaging involved.
Also, you may need to have “scene control” enabled for the Zooz dimmer (on the device page) for button presses to function properly.

That might be my problem. I don't see the same options as you. I only have:

I tried the "set Dimmers and Bulbs" and did "set Dimmer to 100" and that didn't work.

Wait..."Scene Control" on the dimmer seems to have atleast helped, in that I can control the Fibaro now..

I still don't know why I don't have a "set color and color temperature" action, but I can atleast turn the strips on.

Sorry, that was an older version of BC. It should look like this for you

Thanks. I think I've got it now. I'm still learning how to control the colors and get it to come back to the right shade of warm white, but I think it's just trial and error from here. Thanks for the help.

TLDR for the thread....Set the dimmer to enable Scene Control.

2 Likes

Check this driver if you want to unlock all the settings for the ZEN74

2 Likes

Download the Hubitat app