Help with motion sensors

So I decided to focus on one issue at a time instead of trying to do 10 things at once. I got lost with all the responses (Which is a good thing the community help a great deal) bad things I need to take baby steps which I realized and be able to do 1 thing correctly before branching out to other things. So I proitorized my focus. Motion sensors. This is my big thing at moment since I have a good deal of switch and sensors hooked up now. Thinking 40. I think I got the basic rules machine down but I dont. Everything works fine using app or alexa. I had a person rdp to my laptop and set up the basics which I can build off of his work and do trial and error. Before I was able to do that 1 motion sensor at a time stopped responding. Not due to battery power. I checked to see if motion sensor were showing in events nothing but battery status. Checked to see if the load was trying to be turned on nada. So Ill give as much info as possible and screen shots to attempt for some just to say your so dumb just change this it will work. The motion sensor is a ecolink z-wave2.5-eco. I have 8 of these. The load switches are enbright, honeywell, jasco. Everything the nice member had checked if current drivers are installed. He repaired my network which is kinda when they started dropping out. My home is 900sf small home and I have a repeater.

Hopefully this gives a insight to issue.

What I’m seeing here is that the rule is setup to turn on the lights, but not off. And in the logs, I see that they are being turned on digitally, but manually turned off. Is that what’s happening?

To have the rule turn off the light, you will need to add one last command at the end:

Add the following:
Do this action: “Turn off”
Select switches to turn off* “Garage Lights Load”

I am also seeing instances where there is motion active, but nothing in the logs showing that the switch is being turned on. That could be because of a Z-Wave issue. Can you post your Z-Wave details so that the community might review it to see if there might be some problematic devices?

My idea is because these motion sensors have a 4 min run by default and either laundry or garage is occupied many times for more the the 4 min I want then to reset the program until the sensor does not see activity for 6min laundry or 10 min garage (which is where I do most of my work) So light does not turn off until activity has stopped for a certain period, which there is a rule for this. I can post z-wave details if I know what your referring to. In isy there is a simple way to send a very detailed log that captures everything to upload. Not sure how it works here, seeing everything has a app. Does hubitat offer a way to send logs(complete logs of every app and device?) This would be most helpful for people to review. I go to z-wave logs/ all and its blank

What we need is a screenshot of the Z-Wave Details screen (not the Z-Wave logs). This could take the form of several screenshots to be able to show everything. This (screenshots) is the preferred approach to share this information.

You get these from Settings -> Z-Wave Details

The one person who rdp to my computer fixed all this. I have tried refresh/repair in different fashion. Some of these switches are literally 10ft from hubatit hub actually 7. I can control them via the hubatit app though. The motion sensors are within 10 to 20 feet with 2 probably 8ft and direct line of sight.

Okay. Someone else might see something I’m missing, but to me everything looks good on the Z-Wave front.

Are you saying that sometimes there is motion in the garage (after it has shown motion inactive on the “Garage Lights Load” device screen or a dashboard where it is present), then motion is triggered and showing triggered on the device or dashboard, but the light doesn’t turn on. However, right after this, you can turn on the same light via the device or dashboard?

Was exactly like that with the exception that I no longer even get motion events. Started out fine sensor would detect, then sensor would detect but not trigger load, now seems sensor does not detect (not 1 but all) This all started after rebulid/repair mesh. I haven't even troubled the community to use a dashboard I just want basic rules to work or figure out why they don't. I want to add so many things but see that the gui is a bit complicated so I want to focus on 1 issue at a time. Once I figure out motion sensors I may be able to figure out other things before posting my next challenge. If I get 2 working then I can set up other 6......Its z-wave to z-wave nothing added in the mix.

Your approach is good, start small and learn before growing.

As for the issue you are encountering, it is odd. Sometimes people have a few devices that report power and this can overwhelmed the mesh (I had this issue myself in my early days…). However, from what I can see, your switches seem to all be Jasco and as far as I know, these don’t support that functionality.

It is possible however that the mesh needs to stabilize, especially if you ran some “repairs” on it which have been known to cause issue in the past. I would recommend that you shut down your hub, unplug it for a few minutes, power it back on and then see if things work better after the mesh has been given a few days to settle.

A side question, so you have an option on the top of that same Z-Wave Details screen to update the Z-Wave firmware? (Not just “update” which is there to update the settings…). If you do, I would recommend that you run it and update your Z-Wave firmware. This can help resolve some known bugs with the firmware (it is provided by a third party to Hubitat).

I am not an expert!

It has been my experience that letting the Z-Wave network stabilize is inscrutable magic. It just works. It seems to take even a matter of days. I have found no way to rush it. If I have been turning off breakers to install switches, etc the Z-Wave network takes this personally and becomes quirky just when I am installing and testing a new device. If power goes out to the whole house I just expect a flaky Z-Wave network for a few days. Doing Z-Wave repairs and other struggling does not help and may make it take longer to repair itself.

Remember, I am just making this up!


It has stabilized for 3 weeks, firmware was just updated a few days ago. The switches have been installed over a 3 month period so plenty of time to stabilize. Not sure how to proceed, since im itching to move on to next setup but want to wait unit this is resolved. I was a bit tired the other day to check but leak sensors seem to be working fine and much farther away then motion sensors are placed.

I’m assuming that the problem persists since the first post was submitted? Motion can be seen in the device details and the light is not turned on?

Also, to be clear - the app as it is will not turn off the light, it will only turn it on.

I found my error in the not turning off as I had watched a youtube video and know the logic with Isy but it does not have the inactivity part which I assumed it would just turn it off, but I added a line. Yes issue is still present. I just excluded 1 sensor which is a pain why didnt z-wave plus have a universal inclusin/exclusion process. Like hold set button for 5 seconds. Some are tap up and down, some are tap up 5x, some are remove battery ugh. So now new issue to add insult to injury. I excluded the sensor for testing, included it, shows up in devices but cant add to basic rules. It does not show up. There has to be a simpler way.

I think the exclude and include worked not sure what broke so If I can just see it in basic rules Ill try to do a new program. Not sure why it does not show up. But this may be the fix once I get it to show up. I remember something about authorize but I thought it was only for dashboard. Been a while since I added anything and was a pain. With test mode it is reporting now while testing. The bigger question is why did 4 stop at (Ithink same time). So basically how do I get it to show up in basics rules, Ill do trial n error before I ask again. I get the jist of if/or then now similar to ISY just different format. Im getting the hang of this.

That’s odd - I have never experienced that. No authorization required. Once a device is setup, it should just appear and be usable everywhere.

Glad to hear you are starting to get the hang of it! :smiley:

So per screen shots its clearly responding, its in device list but does not show up in basic rules. BUG? Obviously not a network issues if its working.

Not sure I understand… I see “Garage Motion” in the Basic Rule screenshot…?

you see it before I excluded it and included it, look at last screen shots. Before yes it was there but after removing it and adding it no longer shows up. Screen shots included

Also once sensor was added have 3 ghost rules.

All these saved in basic rules without me adding them because I cant. No clue why they are there. They self added when I added motion sensor. Maybe this is a bigger part of issue. Sensors dont show up and when added they add basic rules. How can a sensor add a rule when it does not show up in rules? I mean you can see all the screen shots, makes no sense. But dont want to try other same sensors to get more ghosts. This is exactly why hubitat needs phone support. Weather paid or free for a period one cant buy z-wave devices and not get answers swiftly. The community is a awesome tool which I use but where do I turn if people are stomped? You have answered several questions very well but where do I go if you run out of answerers? Or the community? is there another more advanced forum to post to? Im with z-wave and hubitat to win it and you guys did a great deal to video all this most my questions are answered in 20 -30 min. Im just a bit frustrated just added 3 switches not included yet but just want motion to work.n Thanks for any help, now for testing need the motion sensor to show up in basic rules. Night all

I see it in the last screenshot…

Ghost rules I have never seen before… Probably a result of removing the attached device - I would recommend deleting them and re-creating them, just to be on the safe side.