Help needed for new user

Hi there. I'm a new Hubitat user. I came from Smartthings. I was getting tired of outages, and am optimistic that my user experience will be much better on Hubitat. My internet is very spotty, so I like the idea of having my automations locally. I had some of my stuff on webcore with ST, so occasionally I would have things not work.

The reason for my first post is that I received my C7 yesterday and set it up. However, I am unable to get anything Zwave to successfully exclude so that I can start pairing the 25-30 devices I have. I tried on a cpu as well as my mobile phone. The countdown timer starts, I press the buttons on the switches, but nothing. I've tried about 10 different devices, all known to be working. I did a reset of the zwave radio.

Is it possible something is wrong with the hub? I've never had an issue excluding using the Smartthings hub.

One other thing. I'm not sure if it's related, but I'll mention it. I saw a notification for a newer firmware available, so I started the process. It locked up at the "applying update" stage. I left it sit for about an hour but it stayed there, with the blue led on solid. I could not get into the web interface for the hub, but was able to get into the diagnostic menu. I rolled the firmware back to the previous version and rebooted, now I can login to the web interface, though still on the old firmware.

Thanks for any advice for a newbie to Hubitat.

Welcome to the Hubitat community @jessie.slimer . Many of us have come over from Smartthings and are glad we made the move.

You can email, or maybe @bobbyD is on and can help you quicker. :ambulance:

1 Like

@jessie.slimer Here is another thread on your issue. It could help you too. I don't have a C-7 yet, so my upgrade went just fine. issues with upgrade - Support / Devices - Hubitat

and ... C7 - to Update Failure - Support / Devices - Hubitat

Jessie, a question. Is your Z-Wave radio (on Z-Wave Details page) set to your region? Your profile doesn’t say where you live. Your Z-Wave radio must be set to the same region as the radios in your devices. Perhaps it would help if you posted a screenshot of your Z-Wave details page.

Another thing to try would be to reboot the Z-Wave radio. Only way to do this is to do a clean shutdown of your hub from the Settings page, wait until the hub’s light goes red, remove the power to the hub (at the wall, not at the micro USB connector, which is fragile, the solder joints can break), wait 30 seconds, apply power, let hub reboot to green light. Doing a shutdown does not reboot the Z-Wave radio; need to remove power.

You can exclude your devices from your SmartThings hub, and then include them w/the Hubitat hub. Doesn't matter which hub excludes the device, the result is the same for the device. However, the result will be better for your ST hub if you excluded your devices from the ST hub and then include them on your Hubitat. That way your ST hub gets cleaned up as a part of the process, you don't leave behind a bunch of dead devices on it. I did a "rip-off-the-bandaid" approach when I moved from ST, excluded everything from ST and then included them to HE in the order I describe below. I did my locks and garage door (sometimes tricky devices) the very last.

When including, start w/mains powered devices (repeaters, switches, dimmers, outlets) closest to your hub first, and then move outward to devices farther away. Does not hurt at all to reboot the hub after a few inclusions (reboot option on the Settings menu).

Yes it is set to USA, which is where I am. I just tried your suggestion of the power down and remove power plug with no luck. Thanks for the help so far.

Unfortunately I don't have access to the Smartthings hub any longer.

Thanks for that. Sounds like my exact issue.

Have you tried an include without the exclude? If you deleted the device from ST sometimes it would do the exclude for you.

That doesn’t matter. You can exclude from the Hubitat hub. Perhaps you have a weak mesh, and need a repeater. In my experience, the SmartThings hub’s antenna had greater gain than the antenna on the Hubitat hub. The fact that the Hubitat C-7 has a 700 series Z-Wave chip should give it greater range, though.

Try bringing the Hubitat hub near the device when excluding and including. Remember to shut the hub down cleanly if you unplug to move it, or get a long Ethernet cable.

1 Like

I did try to include, but none of the devices will show up after many attempts. The hub is in my living room and I'm only trying with the handful of zwave devices in the living room and kitchen which is the next room over. It shouldn't be a range issue. It's almost like the radio is not working. Zigbee is working, I've paired a couple bulbs.

What are the devices? Brand and type?

Have you tried resetting the devices, and then trying to exclude them using HE, and then try the include?

They are jasco/ge dimmer switches. Some are zwave plus but most are zwave. I did try the triple tap up, triple tap down to reset the, and got the flashing blue led confirmation.

That may very well be the case. If you didn't do so already, please send us an email at along with your hub's MAC address and the purchase order details, in case we need to send out a replacement.

Odd...that's about the only type of switch I own (actually, now that I think about it I only have Jasco/GE/Honeywell switches, a few Z-Wave and the rest Z-Wave plus). They have always paired "nicely" for me. Was about to suggest your radio may be dead, but @bobbyD beat me to it! :slight_smile:

I tried again tonight, following the advice of 672southmain. I used a long extension cord and a 150 foot long cat6 cable that I made a while ago to test ip camera locations. I moved the hub around the house to within feet of each device, and was able to get all of the zwave devices excluded then included, minus my Schlage door locks (I'll mess with those later). Some of them took a few tries, but its all in there.

I'm guessing that either I have a lot of interference in my living room, or I overestimated the power of the Hubitat radio.

Thanks again everyone for the suggestions.


I just shrugged my shoulders and put a bunch of Ring Alarm Extender v2 devices around. Our house has a bunch of mirrors, lots of brick (fireplaces, etc.) and ceramic tiles. Must be hard for the radios, but I got it to work with the repeaters (8 of them).


Best thing to do now is let your mesh sit and percolate for a few days, the Z-Wave Plus devices will work out routing that they are happy with (and the routings sometimes looks a little off, but in my experience they seem to make the odd routings work, and can continue to self-adjust in the future).

After that would be when I'd do the locks. Did it that way on my migration...the locks and garage door opener were the last mains powered devices I added. Worked well for me, they've been solid w/zero issues since I added them.

1 Like

Cool, thanks for the tip. I'm going to have another go at it next weekend. Everything has been working great so far. Huge improvement over ST.

1 Like