Help! Large Z-wave mesh very unreliable (migrating from smartthings))

Hi everyone. Really frustrated and really need some help.

I have a large zwave deployment in my home. All switches/dimmers throughout are zwave or zwave plus (I'd say about a 60/40 mix). Motion sensors are also a mix of zwave/zwave plus. There are about 200 devices total.

I've migrated all the devices from smartthings where I previously had no issues (e.g., turn a light switch off and it turns off relativley quickly). With hubitat things are hit or miss. Sometimes swithces will respond, other times there will be no response - or a super slow response 10 to 20 seconds later. At other times if, for exmaplel the automation is to dim to 100% - it will only make it to 10%.

I love hubitat for its configurability but the unrealiablity is driving my family nuts (if you walk into a room you don't know if the light will go on instantly, in 20 seconds, or at all).

There are so many mains powered devices in this mesh network I can't see how range would ever be an issue. Does anyone have any suggestions on how I can troubleshoot this? I've run many MANY zwave repairs, and still the same issue.

With thanks

A couple questions:

  • Did you unpair/repair everything away from ST and into HE all at once, or a bit at a time?
  • Have you done z-wave repairs?
  • How long have you let it settle since you migrated everything?
  • How long has it settled since your last z-wave repair?
  • Is the ST mesh still active at all?


1 Like
  1. The mains powered devices I paired in one shot (about 50 devices). The battery devices (mostly motion sensors) I added 5 or 10 a day.
  2. Yes, it been settling for a few weeks at least.
  3. I do zwave repair by going to zwave details / repair. I can see it working in the log (setting SUC route, etc.)
  4. I just ran two zwave repairs this morning.
  5. ST Mesh is gone - I've unplugged it.

I also note that a lot of the devices needed to be next to the hub to pair... network inclusion didn't seem to work.

IMHO - do a safe power off on your hub and then unplug the power from your hub for a minute or so and plug it back in. Then let it power back up. Give it some time. 15 minutes. Then run a zwave repair.

What are you using for rules? Do you have anything custom installed on your hub or all stock apps at this point?

Mostly stock apps - I do have myq chamberlin (commuity app) installed that works great.

Ok I will try that and see if it helps.

IMHO - I truly think you just added too much too fast. By shutting down your hub completely and leaving it a few minutes, you will hopefully reset anything crazy with the radios.

You could have connected the hubs with hubconnect to enable a slower migration from smartthings to HE.

If that doesn't work, you might have to remove some of the problem devices and rejoin them one at a time. Seems like an awful lot of devices to add all at once. If you look at the documentation, nowhere does it say to add everything in one shot. I think you created more work for yourself. If you create some virtual devices, you can insert them into your rules avoid breaking your rules as you remove and rejoin them more slowly. Good luck!

Just my opinion.

1 Like

How long are your repairs taking?

Any idea why the documentation says to add in batches? I don't understand the significance of this since with smartthings I just added everything in one shot, ran a few repairs, and was off to the races.

About 1 hour to 1.5 hours or so. Looking at the logs everything seems to repair fine. Battery devices are of course not touched.

As I mentioned before, I did have to pair some of my ecolink motion detectors (zwave only, not plus) at the hub, then move them to their final location on different floors. They seem to work fine, sometimes.

I will personally request that the documentation be changed to represent a cap on that number then. Thanks for pointing that out. 50 devices, in my eyes, is an ecosystem. Not a batch.
I have nothing nice to say about comparing anything Hubitat to smartthings. So I'll just not say it. Besides, I simply stated my opinion. Not an argument.

There is nothing in the zwave specs that I know of which would require you to add devices in a limited batch number. I believe this is urban myth.

There is certainly good technical reasons to add close to far, as that influences how the neighbor table is built. So I'm not disputing that part of the advice.

So unless they can cite specific/tangible technical reasons that there is a limit on how many devices can be added (not rumor of FUD), I hope they do not change the documentation, as it would just be perpetuating this myth.

My strong suspicion is that the OP is having issues because he has so many regular Z-Wave devices. Habitat simply does not support standard Z-Wave very well. It is very much geared towards homogenic zwave plus meshes.


One of the things I would do to help troubleshoot is to determine if its the hub that is keeping your automation slow, or if its the actual mesh. You may have to watch some logs to determine this.

Another thing to look at, make sure you don't have everything securely joined. There is a setting in zwave settings and it should be set to locks and garage doors only. Everything else should be regular joined or it can slow down the mesh.

1 Like

I don't know. I just checked one of my hubs and it has 66 Z-Wave devices, 170 devices total. I bet that fewer than 7 of those devices are Z-Wave Plus. I have a solid responsive mesh. I did nothing special other than pair them starting closest to the hub and working out. I also took care not to introduce phantom devices from pairing and un-pairing devices, insuring that every device paired cleanly. The Op may be having hub slowdown issues with a lot of rules and devices. I eliminated that issue by using HubConnect and multiple hubs.

I don't have many rules - only a few (5 tops) motion lighting rules ... but the sluggishness has been stopping me from adding more so I can troubleshoot.

It's possible I have phantom devices as I had to pair/unpair a bunch of devices that were very stubborn to connect. I thought hubitat does trash collection each night to remnove these (after I force remove). Is there something else I should be doing to ensure phantom devices are removed?

Were you able to pair battery powered devices in their original location far from hub ("moving out") ? Many devices I was unable to do this - so I either brought the hub close or paired at the hub them brought the device to its final location.

If I'm not mistaken, I believe after a "Z-Wave Repair" has finished. It could take up to 24hrs before the Mesh settles down. So repeating a Z-Wave Repair one right behind the other in a small time frame, will not help for large setups.


This as you called out is urban myth. If others think otherwise please show me the specification or guidelines from Silicon Labs or Z-Wave Alliance.

This is valid in all Z-Wave systems. Build outwards starting from the controller. This builds the routing table and mesh as you add. A proper inclusion process has the included node perform a neighbor update to build the mesh as you add devices.


I feel like I quoted most of your post @JasonJoel but I couldn't resist it was too good. I just had to jump to agreement.

1 Like

Only 3 devices were Z-Wave battery powered. I probably paired those near the hub because they were portable. 2 Z-Wave Sirens and 1 Z-Wave Smoke/CO. All of the Zigbee devices were paired in place just like all the mains powered Z-Wave devices. Some of the Zigbee devices were in a metal well house 100 feet from the hub. I was impressed.

Does rebooting the hub make the sluggishness go away for a while?

There is a few people having z-wave issues on here, you could try a nightly reboot for a few days. I hold off on any repairs just do a few reboots and see if it improves.

Also I found moving my z-wave plus devices closer to the hub helped a bit

Edit I haven't had hub slowdowns but reboots seemed to help with the z-wave issues (z-wave radio was locking)

1 Like