Help identifing and removing ghost

Hello Hubitat Community

I'm experiencing a z-wave mesh network that randomly will get crippled where no device is responsive.

I've checked the Z-wave Details to fine 3 "ghost" nodes. 2 of the three were easily removed with the remove button. However, I have one suborn node that I cannot remove.

I'm attempting to find the ghost device; I assumed it was the next in the list "Garage Door" (Linear Go-Control Garage Door controller) which is also the device that is no longer controllable at all in Hubitat even after reboots. Last activity was several days ago. I tried removing the Garage Door controller from power and then removing the device in Hubitat, shutting down Hubitat powering it on and tried removing it again. I then tried all the subsequent devices in the list and few above - removing them from power and removing the ghost. so far nothing has worked.

What is the recommended next step? or should I attempt something different?

This is my Zwave details:

Looks like the likely suspects that created your ghost are either of these two...

Sounds like you've tried the appropriate steps and they aren't working for you.

Your ghost has a lot of neighbors, which can make it very difficult to remove it. @jtp10181 has created a set of steps that can help w/removing a ghost like yours w/out having to use a UZB stick and PC should review the steps and consider giving them a try. The alternative would likely be using a UZB stick w/PC Controller which is detailed in the Ghost Removal topic.

I've excerpted Jeff's steps that don't require a UZB stick from the Ghost Removal topic:

Simple first steps - try these first
The hub may not be able to remove Ghosts that have too many existing neighbor nodes. In these cases you can use the following steps before having to move to using a Z-Wave USB stick.

  • Use the Z-wave mesh tool [BETA] A Z-Wave Mesh Tool [C7 and 2.2.4+ Only] to identify the neighbor nodes that the ghost devices are hanging onto. Use the
    image arrow in that app to expand the ghost device row to see the device's neighbors - see the "Neighbors" column in the cap below:

If you exclude the neighbor nodes, then the ghost node should also be removable. Steps:

  1. Create a virtual device for each neighbor.
    -- Add Device at top of Device page, choose "Virtual" device type, and choose virtual device types that match w/your actual devices.
  2. Use the Settings>Swap Apps Devices tool to swap out each neighbor w/a virtual device (this maintaings your automations using these devices)
  3. Exclude the neighbor devices
  4. Use the HE hub steps above to remove your ghost(s)
  5. Re-include the neighbor devices
  6. Use Swap App Devices again to swap the restored devices back into their automations, dashboards, etc.

I would not try those drastic measures of removing all of the neighbors just yet.

What hub model is it?
How it is being powered (included supply or other)?
How long was hub running since last reboot when you took that screenshot?

If you want to remove the garage door controller why dont you just exclude it? Although if it just stopped working then that tells me it cannot find a route to the hub. Z-wave devices very rarely just drop themselves off the mesh unless they got factory reset somehow.

1 Like

AFAIK he doesn't want to remove the Garage Door is working. He has the ghost just above it that he thought might have been created from the Garage Door device.


1 Like

Ah, yes, scanning faster than my brain can comprehend, evidently. Totally missed that, thanks. :slight_smile:

What hub model is it? C-8 V2.3.8.123
How it is being powered (included supply or other)? included power supply
How long was hub running since last reboot when you took that screenshot? ~18 hours

I wasn't sure if excluding the garage door was the right thing to do. I was trying to confirm is this ghost device was indeed the garage door. Could it be? even with a different device type name?

Update: Garage door randomly started working. and this was in the logs:
Failed node 0D remove status: 0 SDK failure node is no longer in failed node list
Node OD was the ghost device...

Now the Automation Button Controller is not responding. on zwave details refresh i get a remove option...

That is the default response when there are neighbors listed for the node still. Not sure if its a bug from SiLabs or intentional.

Shut down the hub and unplug for 30 seconds then power back up.
Wait 5-10 minutes, then do a full repair.
Make note of any failed nodes at the end.
Manually try to repair any that failed, hopefully they all work eventually (except the ghost node of course).

Then do not mess with it anymore and let it sit for a while and see how things go.

1 Like

Okay will do
Just ignore the ghost for now? Deal with it later?

You wont be able to get rid of that one without a USB stick and chances are that just the one wont cause too much trouble. So yes just ignore it for now.


Shut down and back online. 15 minutes later a full z-wave repair shows 0D and 0E failed...

Did you try to then repair just the garage door 0E ?


I would just observe it for now then and see what happens.
Next time there are issues get a screenshot of the z-wave details before you reboot or shut down (the stats gets reset when you reboot).

1 Like

I was successfully able to remove the ghost device via a Z wave stick.
Thanks again for your help on this.

1 Like

So I have what looks like a ghost but it does not appear in the list when I use PC Controller and the Aeotec Stick. I had a couple of other ghosts and they did appear when connect with PC Controller and I was able to remove them. Any ideas what I can do about 0x80?

Are you sure you looked for (128) in PC Controller? It will be listed by the decimal number not the hex.

Have you shut down and powered off the hub for 30 seconds to restart the zwave radio?

Have you excluded and re-paired the USB stick?

Yes the hub has been shutdown for a couple of mins. In fact I've just done a successful hub migration from a c-8 to a c-8 Pro and this has come across. Just added the PC controller again now and here's what it sees. Definitely no 0x80(128) in the list. What am I missing?

Since that ghost node only has the one neighbor, you should be able to remove it just by doing a refresh on the hub, until you get the remove button, then remove.