Help I cant connect to my hub

I can't connect to my hub the automations work just fine but I can't connect to my hub I tried rebooting it but it didn't work

What do you usually enter into your browser address bar to reach the hub?

I’m guessing you enter its IP address based on your redacted screenshot.

So is it possible the hub’s IP address changed? If that’s the issue, then rebooting wouldn’t help, because your router may assign new IP addresses when connected devices reboot if you haven’t assigned a DHCP reservation.

If you try browsing to does that find it?

If that link is not finding it, the network settings could be bad and not allowing it to connect for some reason. Do a network reset: Network Setup | Hubitat Documentation You will know it worked when you let go of the hidden button the LED blinks and then the hub will reboot.

Also, what color is the LED on the hub? Should be either blue or green.

1 Like

Probably green, since OP mentioned automations continue to work.

Green = hub is on, platform is loaded

Blue = hub is on, but platform did not load

I agree it’s most likely an IP network-related issue of one kind or another, interfering with access to the hub UI.

1 Like

I am having connection issues this morning too. Didn't get a chance to mess with it before work, but remote access was not working but I was able to connect directly through the assigned IP address. Google also was unable to talk with the Hubitat.

sounds like a DNS issue. Set a reservation on your router's DHCP server for the hub. Press the network reset button on bottom of the hub for 7 seconds with a paperclip or toothpick (it will be the only round hole out of all the square ones). After it's done rebooting you should be good.

Im 16 i do not understand also its connected via wifi because i have no access to ethernet

Look at the first two replies, those are the first steps to take. If you do not understand parts of it you will need to be more specific as to what is confusing.

Step 1:

Step 2:

1 Like

Yes it is finding the hub

Also my hub is red and green flashing between both

Red/Green means it is not connected. Pull the power on the hub and wait 10 seconds then plug it back in. See if it will reconnect to Wifi when it reboots.

1 Like

I did what you said and is still flashing red/green

I it just took a second its working now i can now connect to my hub in my browser again thank you so much :slight_smile:

1 Like

It’s unlikely you’re having the same issue as the OP.

If you still need assistance please create a new thread to discuss your issue in more detail.


Flashing red/green is how the hub reports that it’s not being assigned an IP address on your home network, like @jtp10181 said.

Do you ever lose electrical power? Sometimes when all power is lost, the hub reboots before the router does. And the end result can be what you’re seeing.

The WiFi capabilities of the hub are newer and inherently more potentially problematic than its Ethernet connection, so it’s also possible some other bug was at work.

1 Like

if that does happen would it reconnect on its own?

It's supposed to but doesn't always. That said be careful in just pulling the plug. That can lead to database corruption and you will have to do a restore.

1 Like

As Rick said, the hub’s network connection should restore itself each time the hub reboots (including from a power loss).

But the more often a power loss occurs that affects both the hub and your router, the odds are greater that the hub will at some point reboot before the router, resulting in a failed attempt to establish an IP address on your LAN.

We haven’t actually established whether that’s likely to be happening in your case, though.

So, is your house prone to power outages?

1 Like

how would I safely unplug it?

no it was just moved n power outages