Hello and problems with a Schlage BE369

Hello everyone...

I'm new here porting over from Nexia. This is my first post.

After a little bit of a learning curve I've now gotten 31 devices to successfully work on HE including a Schlage BE469ZP Connect lock. Added some rules. Even added a user driver i got form GitHub for a Fortrezz water sensor. I like the flexibility of it all and options for complex rules.

I am now stuck on getting an older Schlage BE369 lock to work. After many cycles of excluding/including, I've gotten the device to enroll. The device does show on the list of Z-Wave Details menu as follows:

However, the device never shows up on the Devices menu so I can't do anything with it.

I've factory reset the lock, removed it and re-added it multiple times. I even took it off the door and put it on top of the HE hub just to get it to pair. I also used the Discover and Repair buttons.. Repair does the ping and returns completed but that still does not make it show up on the Devices menu.

Any ideas? (and keep up the good work!)


Looks like it didn't successfully complete and is now a "ghost". Remove the batteries from the lock, and then hit the refresh button on the zwave details entry - with any luck it will fail and allow you to remove and start over.

When you do get back to trying the reinclude, try doing it within 4-6 feet of the hub.

Many thanks for the reply.

I was able to remove the lock and re-pair it.. this time 4-6 feet away from the hub.

Still same results. I forgot to mention the first time that when the Hub finds the lock, the z-wave enrollment never gets past the "initializing" state...

I looked in the z-wave logs and all i see is traffic from the lock, a sequence number for the packets..... This is a snapshot from the logs:

Thanks again,

Looks like you're still getting noise (negative RSSI, and some retransmits), can you try pairing 6-18inches away from the hub? Problem is that the lock goes into whisper mode (low power transmit/receive when pairing) to minimize the possibility that someone could be trying to intercept the key exchange.


Thanks for clarifying what the log meant and insight into what may be happening.

Still no luck.

I must have tried 10 more times... i even moved the hub to a more quiet location (it was next to a some other WiFi devices) but no joy. The closest it got was about a dozen packets without retransmissions but then they started again.

Will try some more later..

Thanks again,

I hear that they are sometimes very hard to pair. If you have zstick handy sometimes it’s easier to use it to pair with.


I have a Schlage BE469 Z-wave lock as well. I had issues trying to pair it. It had previously been paired with Smartthings.

I removed the lock from the door and brought it within a few feet of the hub. You might be able to accomplish the same thing by using an extension cord to move the hub close to the lock. Make sure you exclude the lock from the hub and check for any ghost devices from previous pairing attempts. Then do a "reset to factory" for the lock. Since a lock is a secure device, make sure you write down the security codes from the lock so you can enter them during the pairing process. Once that is done, put Hubitat in Z-wave inclusion mode. Then put the lock in pairing mode with it no more than a few feet from the hub (direct line of sight).

You may find like I did that you need a Z-wave range extender/repeater between the Hubitat hub and the lock. I used an Aeotec range extender for that purpose. I had a HVAC return duct that was blocking the path between my hub and the lock, so it would not work without the repeater. If you get a good connection without the repeater, that is great.

Locks are one of the more difficult devices to connect, but it will work sooner or later.

+1 on making sure you have good extenders in between your hub and your doors.
In particular if your model is not the zwave plus version. After doing that my locks are super solid. But I struggled a lot before that. Also after adding extenders, I had to let it settle for about 3 days.

1 Like

100% this. The BE369 is a z-wave 300-series product so repeaters are likely to be very important once it is in its final position.


Updated the HE firmware this morning, waved a chicken over the lock :stuck_out_tongue_winking_eye: (I think i just dated myself). Tried again in hopes that there was some bug fixed.

Still no good.

I then tried to add the lock back into Nexia and it didn't work!.... (which is good and bad... it was working before :slight_smile: )

I think I'm going to chuck this one to a bad lock and move on. Everything else worked.

Many thanks for all the replies.

  • Luis

The Schlage Connect locks are rather expensive, so do not give up without a fight, even if it goes 9 rounds and your cornerman has to go through a couple of jars of Vaseline in the process. :woozy_face:

Z-wave locks are one of the more difficult devices to connect. Make sure the lock is within a few feet of the hub when you attempt to pair it. Then make sure you have a beaming repeater within a few feet of the lock so signals will be sent from the repeater to the lock until the lock receives them. Depending upon the location of your hub, you might even need another repeater between the hub and the repeater closest to the lock.

Go back and make sure there arent any ghosts left or you will have issues

For my Schlage, when I originally paired them to Hubitat back when I first got the hub, they paired in place. Which is unusual.

When I upgraded to a C7 recently, one lock paired in place, one I had to bring the lock into the same room as the Hubitat, and one lock I had to literally lay on top of the hub to get it to pair. Not sure why the difference between 3 identical locks.

In all cases, it was critical to do a full reset on the lock, exclude it from Hubitat (even after the reset), pull the batteries, and reinstall them. Only then will it include.

1 Like

This more than anything. My experience has been that just when im thoroughly frustrated of exclude include fail rinse repeat and ready to give up the thing pairs and works. Really cant find any rhyme or reason to it. Like many i get the hub and lock close enough to touch.

For the most part my lock has worked pretty well with a few intermittant issues.

I will add i have never had to fully reset the lock to get it to pair.

1 Like

Resetting the Schlage lock to factory setting is not difficult. It only takes a few seconds and can eliminate potential issues, especially if the default programming codes were changed. You just disconnect the battery, press the Schlage button to discharge capacitors, reconnect the battery and hold the Schlage button until the controller resets and the button turns green. This will allow you to use the default codes on the lock to reprogram it and connect it to your hub.

If normal exclude/include procedures fail, a reset might be just what is needed.

1 Like

I have reset the lock multiple times as described above, moved it next to the hub, etc...

The lock still works and I can add codes manually... All I'd really be getting are some events, the lock code manager and remote activation. This particular lock is old and does not lock itself.

I will try again and report back.. just need some more patience... and new batteries :slight_smile:

Thanks for all the replies.

If the lock has any fimware prior to 7.8 then I wouldn't bother. How old is the lock?


Pretty old. It worked with Nexia but now i cant add it back on that either. It’s fine… it lives on the door to the garage. I was just looking to synchronize codes and maybe see it working. Everything else works just fine with the HE.

Out of curiosity do you have any other ghosts in your mesh? (no in/out clusters)

No ghost devices. 24 other Z-Wave devices working properly.

I tried again today after upgrading to and this is as far as I got…. the inclusion process finds the lock but never finishes initializing. Finding the device as security S0 device is progress but the lock never shows up in the device list.

Refresh, Repair or Discover seem to have no effect.