Has anyone tried connecting a Keywe Smart Lock yet?

z-wave
driver

#21

We have a sample headed to the lab...


#22

Any updates?


#23

Yeah, currently the lock will not complete pairing due to not following some specific security specs regarding what reports should be available prior to completion of the secure sequence.
We changed some of those bits around on the hub side, that broke pairing for some other locks, so we had to revert those changes.
We have figured out a way to completly resolve this, however it's not an insignificant amount of work, and therefore integrating this lock has been put in standby mode.


#24

Yea! and Bummer!!!
I bet there isn't any custom driver code i could load as an individual user in the custom drivers section?


#25

That won't help it complete the join...


#26

Reviving a fairly old topic... but just to give my status on this:
Installed a KeyWe lock today and paired it. On the Hubitat pairing page it said it was initializing and that never went away until the page was reloaded. But when I went to the Devices list, "keyWe Z-Wave Lock" now exists and can be Locked/Unlocked from the device page. However, the Current States area is showing blank... The driver is listed as "keyWe Z-Wave Lock" automatically from the Hubitat, I have not tried to do a custom one.


#27

I have one still in the box...after reading all the nightmare stories about locks, I've been reluctant to install it....now I'm...less reluctant...lol

Thanks for posting this!

S.


#28

This driver was specifically written for this device, try enabling debug logging, then hit configure, if that doesn't sort the reporting let me know.
I have early engineering examples of this lock, I was informed that the final production version was being released with revised firmware, so I'm not sure if the issue resided with the new firmware or not.


#29

I enabled Debug off the bat (since I am working on my own drivers I like to see what others have done). Below are what I saw in my log after a couple actions, hope they help.

After telling it to lock via the Device:
parse: zw device: 1A, command: 9881, payload: 00 71 05 00 00 00 FF 06 04 00 00 00 , isMulticast: false

Then it auto-locked itself (because the door was still closed):
parse: zw device: 1A, command: 9881, payload: 00 71 05 00 00 00 FF 06 09 00 00 00 , isMulticast: false

Then I told it to Refresh because still no Current States and it put 3 commands in the log (in order of which one happened first):
parse: zw device: 1A, command: 9881, payload: 00 85 03 01 05 00 01 , isMulticast: false
parse: zw device: 1A, command: 9881, payload: 00 85 03 02 05 00 , isMulticast: false
parse: zw device: 1A, command: 9881, payload: 00 62 03 FF 00 01 FE FE , isMulticast: false


#30

It was not too bad. One problem I had is that the deadbolt would not extend without the key in it... but this turned out to be because the lock itself had been in the "locked" position when installed, so the key was actually UNLOCKING it. After taking it back off the door and correcting that, which might have been my fault originally, and putting it back it worked perfectly. Their support was very responsive via email, although I wish they had useful information on their website.


#31

couple of questions, If I recall this lock would not report correctly unless it actually joined and finished the discovery process and selected the KeyWe driver upon join...
In any event, I have two of these, and I'll take at look at a fresh join, since it's been many months since I've done this.


#32

Sorry... If there is anything I can do to help or test out, let me know. I have no problem being a guinea pig for such things as long as it helps others out.


#33

This will likely turn into a Z-wave frame capture diagnosis, just as it did to get it working in the first place...


#34

I can confirm the behavior @snell reports. My KeyWe paired...halting at initialize, but later (after a Zwave Repair) showed up in the Devices list. I am able to lock & unlock it, but get no state reports or events whatsoever. I do get debug messages in the logs however.

Scott


#35

Same here. :frowning_face:


#36

Interesting to note that there are at least 5 of us here that own KeyWe locks, out of the ~3700 locks in the Kickstarter (single backers mostly but also the locks from multi-lock rewards).


#37

same problem with the unlock/lock but no other features. added another repeater did a z wave repair and same issue.


#38

I have two samples of this lock. When I wrote the driver, many months ago it paired and worked correctly. I'll have a look at it in the next week or two and see what's up.


#39

found an issue in the driver, an update will be in platform 2.1.1


#40

for what it's worth ive been able to use most of the functions by switching to the generic z wave lock driver.