Groups and Scenes app question

I second this. I have used @bravenel's "all-off" app for a while for my goodnight and everyone-is-gone routines. It works great. I can't remember the last time it failed to turn off a device.

1 Like

Awesome thanks. Better late than never to this room lighting app party!

Going to try Room Lighting tonight. But can you help me understand these two options:

  • Do I need to select "Tun Off even if already partially off"? I'm surprised this isn't the default option - when the switch is turned off, I would expect all devices in the group to be turned off.

  • I don't understand what the "Select Switches that Determine All Lights are Off" option does. Why is this not just "all devices in the group" as the default?

What I need to understand is how using the activator device to turn off all devices at bedtime works. If I use the activator device to turn off all devices, that presumably immediately turns the activator device to off - so how can I use the activator device to also confirm that all devices are indeed off?

Yes, you want that turned on.

I can't recall the exact setting, but, if I recall right, there's a setting to leave the activator device on unless all the devices are turned off.

If there is such a setting, I can’t find it. :frowning:

Had to go dig it up; it's the indicator use option. You want "any on." If any device in the table is on, the activator device will stay on. This will not tell you which devices are on without going to the app page for the RL instance. If that's really a need for you, you can use this app to create a group that will provide a list of devices that are on. The attribute can be displayed in a dashboard.

Here's a link to the manual, but it does not explicitly explain that option.

@bertabcd1234 there's a section for "advanced use of the indicator" but not a section for standard use. I'm not sure that everyone would be able to infer from the section what it actually does.

Hm. Well I figured that would be the case when the activator device is not the device used to turn things off. But last night when my goodnight routine turned the activator device off in order to turn all of the devices in the group off, the switch attribute of the activator device turned “off” before all of the devices in the group had turned off. I will try again to test later as another sample, but that one sample would suggest I will have to create two identical groups, one to indicate the status and one for an activator device…

Looks like it didn't! I just added a quick section on this, which might help. Thanks!


Ok, I’m still not seeing how to do what I need. Maybe I’m dense and need it spelled out for me. From what I can tell, I need two groups:
(1) one group of lights to create an activator device for turning all of the lights in the group on or off
(2) a duplicate group of the same lights, where the activator device is used only for its indicator of indicating whether all lights in the group are on or off

Is this what I need to do in order for the activator device to serve the dual purpose of controlling the lights in the group and also indicating the status of all lights in the group?

No, I think just using the Use group device to indicate if any members are off? option will do what you want (all on = not any off).

I don’t see that option anywhere. The problem is tho that when I turn the activator device to off, it turns off immediately, even before all group devices are off.

You will need to not have Use group device to indicate if any members are on? selected in order to see the option I mentioned above (as they are mutually exclusive). There could also be other options that affect the availability of this option that I'm not thinking of right now, but I think that's it (play around if not). If this is an old Group and not one you just created, you also might be dealing with changes since a previous version (though it hasn't been touched in a while, and I'm not sure if this was ever different).

As for the behavior you described, if on/off optimization is also disabled (if not, I could see this happening) -- and I'm not sure if this is normal or not as I have not tested that exact setup -- then I'm not sure what else you could do. I suppose creating a separate one you don't use for activation, as suggested, might work around the issue, but I don't recall this coming up before. The only other thing I could think of is to try Room Lighting instead, which can also set up instances like "groups" but has many more (and different) options, some of which might get the activator/indicator device to work how you want all in one.

It sounds like using the activator device to control the group (I believe OP has already moved to RL) will overwrite whatever the "indicator use" setting is set to. I can't test to see though. If that is the case, then verifying by opening the RL instance and checking the table is your only option.

Either way, there is no option to see what is on/off besides looking at the RL instance. Unless you use the Sensor Groups+ app that I linked to.

EDIT: Went back and RTFM. I forgot there's a separate attribute called groupState that is what the "indicator" option maps to.

1 Like

Is this documented anywhere? I can't seem to find it via a search including in the main Room Lighting thread. It would be nice to see it added to the RL documentation.

1 Like

What kind of devices are you trying to control? I.e., Zigbee, Z-Wave, Lutron, Hue, Wifi? How many devices are in your command? You might want to post a screen shot of your Room Lighting setup.

If you have a lot of Zigbee devices in the setup you should use the Zigbee Group Messaging option. It will send a single command to all the Zigbee devices instead of sequential commands to individual devices.

One thing to try is to use the 'Command devices on/off irrespective of reported state (Force)' option. It will add a 'Force' column to the device control part of the table. Normally Hubitat won't send a command if it believes the device is already at that state. This option forces a command to be sent irrespective of the reported state.

I don't believe so. I just recall it from a conversation on here (that I can't find now) and from experience. You can remove power from a device, turn on debugging in the app, and turn the instance on to see the three logs (and their failures).

1 Like

I've got 65+ switches/bulbs in the group, most of which are zwave. It works well the vast majority of the time. I'm guessing from your comment that this is somehow too many to control at once, so I'll look on the community for alternative ways to turn this many devices off at once (at night).

I'm far from a Z-Wave expert as I only have a handful of devices. The Z-Wave mesh network needs to be in good condition to perform well, especially with a lot of devices. Within your network you need to have no ghosts, minimize any power reporting, and have strong links between nodes. There are lots of threads on Z-Wave mesh network performance. Of current active posters @jtp10181 and @csteele are among those who help a lot of people with their Z-Wave issues.

I think it would only be a problem if you are actually updating all those devices at the same time. I would think that's not the case the majority of the time.

In RL, optimization is on by default, meaning it only sends commands to devices that need it. Say device A is already turned off and you turn off the RL instance. As long as the device state in HE shows that's the device is off, then RL will not send the commands.

There is the force option, as mentioned above, that tells RL to ignore the status and send the commands regardless. That's only needed for two scenarios.

  1. You have older non-Zwave Plus devices where the status may not always be accurate.
  2. You have mesh issues causing the device status to not update properly.

For the second option, you'd be better off figuring out why that is happening than to bandaid the situation.

I would do some testing. Turn on the group, wait a minute, and check the RL table. Do any devices still show as being "off" or have a red X? If so, start checking their connectivity. Once everything is showing "on" then try turning the group off and check again.

I had a large group like this, but never got around to pulling it into RL. I used Groups and Scenes which has a metering option to stagger out the commands and that worked rather reliably. IIRC, this feature wasn't included in RL as the consensus was that the newer zwave firmware (for the radio) made it a non-requirement.

I have far less devices than that, and I have mine broken up into two groups with a 2 second delay. Would it make sense to make two RL groups divided by floor or something like indoor and outdoor? I do use RL for other things but for my goodnight I did it right in RM with the main lights first, and then some other less used lights second. I trigger it with a button in the hallway. I used RM so I could have the hallway light actually come ON, then go off after a 2 minute delay.
If you made two RL groups you could do something similar using RM to turn them off with a delay. You can see I have some RL groups in here and some individual lights.

As for the indicator, if you are using an activator with RL, I would check the "groupState" after a few seconds and if it is NOT allOff then you could give another off command. This should work regardless of the indicator settings in RL.


You could also use this option as well (below) which would consider the group to be "on" if anything is on. If you turn OFF the activator, it will flip to off, but may then flip back to ON if all the lights do not turn off.