Google Home Integration throws error: the parameter "state" must be set

I hate to resurrect an old thread, but this seems to be happening again. In the AM yesterday, (7/29/22), there was no issues with the link between the Google Home and my C7 Hubitat. In the evening all the devices in the Google home app showed Offline, but worked ok in Hubitat. Attempted to relink the account in the "Made for Google" selection, logged into the hubitat site, and got "The parameter "state" must be set in the query string". Did not see many other threads on this.

1 Like

This error is usually generated when a user attempts to authorize an incompatible device with Google Home. If you are using a custom driver, please be sure the capabilities are all compatible with Google Home.

Currently, Google Home Integration only supports the following: switches, dimmers, thermostats, RGB, RGBW and ColorTemperature bulbs.

1 Like

Thanks for the quick reply, I kind of thought that as well, so prior to opening the thread I removed all the items from Hubitat, and attempted again to re-link the account and it still failed. Also just to add that my devices have not changed in weeks, that was linked from Hubitat to Google Home, it worked in the AM, and everything was offline in Google Home in the evening.

I was doing further Troubleshooting, and one of the things might have fixed it, just in case this happens to someone else. Have no idea WHY it happened, but at least it is working.

  1. Opened up Googles Account Linked page and un-linked the Hubitat
  2. Rebooted the C7.
  3. Disconnected my phone from the home wireless, (just in case my Pi-Hole or firewall was blocking something).

When I went to re-link with Google it it worked, sorry for all the chatter, thanks for the support!

1 Like

I had the same problem. I just rebooted my hub and went into the Google Home integration app and pressed Done. All good after that.

1 Like

yeah i didnt want to setup it all again so i restarted my phone and my hubitat and it worked

Thread resurrection spell cast!

So I've been having Google Home issues for the past week. Last night even the Hubitat controls were not working well and I discovered what appeared to be a Z-wave crash as my entire topology was 90% red. I performed a shutdown/unplug for 20 minutes and it resolved that issue.

However, I still cannot get Google Home to work. I have tried everything I can think of. The odd part is that it seems Google Home is having issues getting to the Hubitat cloud service. Sometimes it will log in and other times it will say an error has been encountered with the page. Once I get in and select the hub, I only get the same " the parameter โ€œstateโ€ must be set" error. This happens for the included Google Home and the Google Home Community apps.

Everything has been working fine until this week and I haven't made any changes.

Currently, I have no devices assigned to either App, GHCommunity is disabled and I removed the GH built-in app and tried to start over and I still get the same error. I am out of ideas.

In an unfortunate turn of events...I went into my Hubitat account to get the MAC to load the maintenance page and it says I have no Hubs registered....

Apparently one of my DNS servers stopped working and I didn't have both assigned to the Hubitat network config....sigh

1 Like

Yea, Hubitat is very sensitive with respect to being configured on the hub for a static IP address. Many users have fallen victim to the DNS server entries issue that causes the hub to lose cloud connectivity. I personally simply use DHCP with my router reserving a fixed address for each of my home automation devices. This has worked well for me.

Glad to hear you got it sorted out!

1 Like

Anyone else seeing issues with Google Home recently? I have been getting the parameter "state" error today as well. My google home integration decided to stop working about 2 days ago, so I went in yesterday and reconnected within the google home app, and had no issues getting through the menus. Though it did not fix the connectivity issue, and devices were still offline.

Today I tried removing Hubitat from GH, and upon reconnecting, I am getting the state error. Hub reboot between removing and reconnecting as well, and no luck. I am not home, but connected through VPN to my home network at the moment. I am going to try to reconnect later today when I am home, and see if that helps. Just wanted to see if anyone else has been seeing GH connectivity issues lately. Nothing network wise has changed for me recently either.


I solved my issue by removing empty "Device Type" categories from the Google Home Community app section in Hubitat. I had some left over ones in there from devices I no longer used. I didn't think it would be a big deal leaving them in there empty, but I guess it was. Removed the ones that had no devices assigned and then the google home app was able to get past that "state" error and work the next time I tried to update the devices list.

END OF UPDATE - Original post follows

So I've been using this for a long time now (Years?) - I removed some things from the home integration and goto update the devices from the google home app and get this (The parameter "state" must be set in the query string.) - Oh how I'd really not have to disconnect and reconnect my hubitat devices from google home. I've got so many custom routines in the home app that use the integrated hubitat devices it would be a nightmare to re-do. The Hubitat devices already in the Google Home continue to work.. But I can no longer add or remove anymore devices since it will not update, always throwing this error. Is there any debug log to look at to troubleshoot this? - I don't see anything showing up in my logs when google is supposed to be updating or connecting.

Of course I've tried the normal things, reboot the hub, check the google console settings again, tried on and off wifi with my phone, etc. Tested network communication with the hubitat hub and everything is connected and working.

Thanks for any advice!

I also started getting this error this week when attempting to link my Hubitat in my Google Home App. In my case, the issue started after I set my Hubitat to a static IP. Even though the internal IP address of the Hubitat didn't change, the issue persisted through several reboots until I set the Hubitat back to dynamic IP and then it was able to update. This isn't ideal but I'm able to keep the IP address static in my router settings.

How you are doing IP reservation now is the best way to do it IMO. Better to have the router dish the IP's, rather than a device try to assign itself to one. Easy way to have two devices fight over the same IP, especially if you have a device off, and then turn it back on and it is trying to connect with an IP that is already in use

1 Like

Most common issue when setting a static IP on the hub is incorrect DNS settings, which would cause the hub to not be able to resolve DNS and thus unable to connect to external web URLs. This is why DHCP with a router IP reservation is recommended.