Google Home declares several devices as offline

Hello everyone,

since Google forced downgrade a few weeks ago, I'm getting the message, that several of my devices are offline. Google will still turn them on/off, but in the app, they are always shown as offline. When I turn them on at the Hubitat-App, they are shown as online in GH for are moment, just to go offline again. All my GH devices have a steady IP, as this seemed to be an issue in the past. Interestingly enough is, that I'm experiencing this problem mainly with virtual devices, created to control my Broadlink stuff, also some virtual devices not connected to Broadlink and two advanced Zigbee Bulbs (Tradfri Drivers).

Here some Logs:

Anyone any Idea? GH seems to have problems in general right now, but this is a new level...


@gopher.ny Is this due to the new firmware that google released due to the court loss to sonos?

Not sure, going to check it.

If this gives any clue: Every time I add or remove a device from the Google Home integration, my devices at the GH-App work normal again for a short time (about 5 minutes).

Did a quick test, both ChromeCast button and Nest hub worked off the bat. I'll keep watching if they drop off or otherwise misbehave later today. I had to wake the hub up, it wasn't available as a cast option in Youtube at first.

1 Like

I think there is a misunderstanding. I was not talking about the Nest devices. I was talking about devices, connected to HE, which get connected to GH using HE's GH integration. Those devices (mainly virtual devices and two Zigbee bulbs) are shown in Googles own app as offline. Google will still act on them, but somehow the communication between the HE and Google in this way seem to be defective.

Ok, I tried something, and I'm more confused now...

My Tradfri drivers, used with the advanced zigbee bulb driver, didn't update their status, so I hit configure, which solved the problem for a moment and made them show up in my GH-App again. After a few minutes, back to no syncing. When I use the GH-Community app, everything fails to sync as well.

Right now, I'm not sure, if it is a problem with my HE or GH. Also I'm getting these logs, which I don't have any idea, what they mean... Any help is appreciated.

The error messages are created by my Broadlink. Is it possible, that this is messing with my system?

Just a quick update. Deleting and readding the devices didn't do anything. For some reason, my GH doesn't seem to like virtual bulbs and advanced zigbee bulbs. When I switched the drivers, everything seems to work fine again. I remember, that I had this problem before, which "solved itself" after a few days. In hindsight, I think it was a GH update and now, after the rollback because of Sonos lawsuit, I got the same issue again.

1 Like

Ha, I'm not the only one with this issue!