Gocontrol Lightbulb

I have a gocontrol a19 light that I would like to get connected to HE. It won't detect it at all. It's no longer connected to my smartthings. Any input would be great. Also, is there a DH for it?

I'd be surprised if the generic z-wave bulb doesn't cover it. You've flicked the power to it on and off like 4 times usually? (While in device discovery mode.)

Also I bring the hub close to the device. Long Ethernet cables or a WiFi repeater with an Ethernet port are super useful when pairing.

I've flicked and clicked and no go. I know it's not connected to my ST hub. It's in the light right next to the hub. It just won't connect. It's the damdest thing.

1 Like

Have you tried to exclude it using HE?

1 Like

I've had to put the hub in z-wave exclude mode and re-exclude devices. It's like they get confused and don't pair properly the first time. Especially when leaving ST.

I got it paired! There is no generic zwave bulb to choose.

set it to generic zwave dimmer

1 Like

Chose dimmer and no go. It doesn't control it.

1 Like

Have you hit the configure button?

1 Like

yah no go on it

I know it's not an RGBW bulb, but I'm curious, are you able to operate it with the Hank Bulb driver?

1 Like

You could try @mike.maxwell's Super Basic Z-Wave Parameter tool to configure it.

Tried that. No go. I know that ST just used the generic dimmable handler.

I can tell you that when i switch back to the generic dimmer that i can at least see change in the handler on and off, but the light doesn't react.

At least one of those drivers should work with almost any switch so something might have messed up during inclusion and you may need to remove the device and add it again.

This is not the first time I added it. I attempted it back when I got the hub a few months ago with the same results. It's not listed as compatible. Gocontrol has always been difficult for me.

I'll add it back to smartthings and confirm what driver it's using. Might as well start there.

It uses the zwave dimmer generic. paired right up within about a second with smartthings. I'm going to reboot my HE and then pair it again.


It's working! Removing and adding it again seems to have taken care of the issue. Thank you all for the help on this.


I am BIGTIME glad I came across your post here. I just fired up my HE for the 1st time and the first device I am trying to pair and get to work is a LinearLinc Z-Wave bulb. FAIL FAIL FAIL for an hour straight. My cats all think I've been yelling at them and are staring me down wanting to eat my face. Finally...Generic Z-Wave Dimmer does the trick! THANK YOU!!!