Giving up on battery level checks

I've exhausted all the links for reporting battery level warnings. I've tried the HSM battery notification rule and yesterday tried rule machine 4.0 to report a battery level below 60% and neither reports my ST water sensor whose reading is already 49% of its battery level. I have it tied to pushover. When i test the rule i get a notification, and my log shows a 49% battery level, but it doesn't trigger the rule. Is it something with smartthings water sensor or that the battery was already below my less then or 60% battery level rule.

If the battery level started below your threshold and hasn’t dropped further since you created the rule machine rule, then that’s probably the issue. An event has to occur in order for the rule to trigger.

I believe that it is dependent on the device reporting interval or a battery level change. Another problem is that lithium batteries don’t drop voltage in a linear fashion and will be close to EOL when the percentage starts dropping, therefore they may not make it to the next report before going offline.

This app can give you a report of battery levels below x threshold as well as let you know about devices not reporting in. Great App. @bptworld


Yup. This is one of those must-have apps. That and a dashboard of all your battery devices.




To be truthful I've wanted to install the device watchdog app for awhile now. Not being a programmer, I've been relucant because I've seen many updates ( which is great and noteworthy) and I'm embarrassed to admit ,but i don't know how to update an app once installed. I'm learning but not there yet.

Very simple to do. Most apps will have incorporated the import capability. After the app is installed either do the following:

  1. Click import and save
  2. Go out to app github location, click raw, copy and paste into existing app/driver
1 Like

Soooooo much appreciated! With the know how now to update an existing app, I'll give Device Watchdog a try. Thanks to all for their comments and guidance

Definitely the battery dashboard.

I'm finding that each unique device handles battery reporting differently. Have also tried different options for monitoring battery levels and not able to find something that works across.

Also have a couple devices that report in about every 6-9 months and once they do... dead

Been using device watchdog for a month or so now and have received 1 notice of low battery :slight_smile:


That is definitely the case. The only devices I have that report on a regular basis are my Samsung buttons.

Not only do different devices report differently---different batteries discharge differently :slight_smile: So 10% of one type != 10% of another, necessarily.


I have a lot of devices that report battery regularly (Xiaomi temp/humidity sensors, Samsung water sensors, etc).... BUT I also have a lot that don't...

My Keen vents only did 2x - when new batteries were in and then when they died from low battery. My kwikset zigbee locks only reported 1 time - when paired, etc.

It is really hit or miss depending on the device and how the driver was written.


Very true. You may not (likely won't) ever see 10% on a lithium battery. Below 30-40% and they are usually toast before the device will report back in again.


Sometimes, my Iris v1 sensors report negative values :joy:. Probably some unsigned integer conversion issue, but still funny.

1 Like

And not every device that uses a battery reports on it. That is the case with the Sage Doorbell Sensor, which I know tony3286 has. The battery capability is commented out in the driver, but I assume this is the case because the device didn't report on it.

I think around 40% is the end of the road for most lithium batteries. It will take a year or more for the battery to get to 50% and a week after that it’s dead. If I get a battery report below 60% I just replace it, unless it’s in the freezer, or garage in the winter.

1 Like

Thanks for watching my back Hal ! AND thanks to all - with your advice and help, I installed Device Watchdog and works PERFECTLY


I am noticing one of my v1’s doing the same negative level reporting... did you ever find a fix?