Ghosted on ghost issue. How do I create/submit a support ticket?

I ended up with a Ghost PC stick as you'll see below:

How do I exclude them?

Should I take the USB out of the computer first?

Unplug the stick from your computer.

Shut down your hub, at the red LED pull power, wait 30 seconds, restore power and let it boot up.

Go to Z-Wave details, hit Refresh for the ghost UZB stick. The Remove button should appear, hit that.


I followed these steps:

Unplug the stick from your computer.
Shut down your hub, at the red LED pull power, wait 30 seconds, restore power and let it boot up.
Go to Z-Wave details, hit Refresh for the ghost UZB stick. The Remove button should appear, hit that.

And was able to ger rid of the ghost PC Controller. So now all I have is the "good" one.

At this point the PC Stick is not plugged in.

Please give me step-by-step instructions on how to proceed from here. (Do I have to remove/exclude the "good" one, can I just plug the PC Stick back in and then run the SI software, etc.?)


You can leave it in your Z-Wave details page...nothing should route through it (I never saw anything try to route though my UZB stick when I left it in my Z-Wave Details), so it shouldn't cause any problems, and should be there if you need it again.

If you want to remove it normally, the instructions are in the Ghost Removal PDF in my topic.

So I plugged the PC Stick back in and started up the Silicon Labs software. After it did an update and I logged in I got these 2 windows.

What do I do now?

Depends on what you are trying to do...

The full instructions for using the UZB stick w/ghosts are in the PDF download available in this topic:

Click Tools then open PC Controller. Same as you did before to get into it.

From there you can exclude the stick from your hub if thats what you are trying to do (I assume instructions are in that guide as indicated).

Otherwise you can just leave it plugged in (no need for the software) and it will act as a repeater. Mine is near the center of my house and does repeat sometimes. I just leave it plugged in all the time.

I got to Network Management per the instructions and I can see my devices.

Since I can see the devices I then went to step 15 that says:

15.Exclude your Ghost: IMPORTANT: Make sure you remove power from the device that caused the ghost which is almost always the next device in the Z-Wave Details screen in HE. Flip a circuit breaker, pull air gap on a wall switch, remove batteries, etc. The ghost device must not have power.

a. Find and click on your "ghost" device. In the picture above, device 21 is the ghost device.

b. Click on Is Failed in the upper right pane-hopefully it will mark the device as failed. You’ll know the ghost device has been marked failed when the name of the ghost device text turns redlike this.

c .Then click on Remove Failed

d. If the ghost is not removed, try clicking on NOP and maybe Is Failed again a few times to see if that works to get it into Is Failed status

Here is my ghost device # 86 so I air gapped # 87

As you see, it worked in PC Controller and removed #86

Screen Shot 2024-03-04 at 5.58.49 PM

However, I still couldn't remove it from Hubitati.

So 15 goes on to say:
NOTE: Not commonly, but in some cases when removing a ghost, the ghost will disappear from PC Controller but persist on your hub. This can occur if the UZB stick is not connected to your hub’s mesh while removing a ghost in PC Controller. The ghost is removed from the UZB stick’s mesh but isn’t removed from your hub. In that case try the following:

  1. Exclude the UZB stick from your hub

  2. Reset it, if it has a reset option

  3. Re-pair the UZB stick to your hub

  4. Remove the ghost node again in the PC Controller app

I was able to exclude the PC Controller from Hubitat by using the Discover and Remove method.

I then put Hubitat into Include Mode and plugged in the PC Stick but it wasn't found. I can't find the instructions on how to include it again.

I have the Zooz 800LR Z-Wave Stick ZST39 LR. I don't see anything in the instructions on how to put it into inclusion mode. (Which is why I thought all I had to do is plug it in and put HE into inclusion mode).

BTW the Zooz instructions say The 800 Series Stick can only be reset by the host software while it's in SerialAPI mode. The device is reset once an appropriate command from the host software is sent to reset the Z-Wave network. There is no way to manually reset the S2 stick if it's not controlled by host software. So I have no idea what that really means or how to do a Factory Reset if that is needed to re-pair it to Hubitat.

I'm hoping that isn't the case, but can you point me to the instructions on how to paid the Z-Wave stick to Hubitat?

BTW, am I correct that there is no Add Device from the Z-Wave Details page, just to Exclude one? If so, I'd like to add that to the Wish List.

Instructions to include the UZB stick to Hubitat are at the beginning of the instructions.

Anything specific to the Zooz stick is beyond my pay grade, I have never seen/used one, sorry.

Sometimes it can take multiple tries to include a UZB stick to HE, so I would start by:

  1. Hub: Shut down/pull power/wait 30s/restore power
  2. Try the UZB stick inclusion process from the instructions several more times to see if it will join

@jtp10181 may have some additional wisdom on this.

Thats a lot of words.
What is the issue exactly? I think just trying to reset the USB stick?
There is a "RESET" button right in PC Controller, that will reset any stick I have ever worked with.

Once reset the guide has inclusion instructions, the stick does not enter inclusion mode just by plugging it in.

Sorry if I'm being verbose but I'm trying to give a lot of information so people know what I've been able to accomplish and what hasn't worked.

I'll look for the reset button in PC Controller, but I looked and looked and searched the forums and used google but I couldn't find how to include the PC Controller back in. Let me see what happens after I use the PC Controller's reset button.

The ghost removal guide has detailed instructions for how to add a USB stick as a secondary controller to HE.

I don't know how I missed it before, but I got the PC Controller to be included in Hubitat using Step 10.

I air-gapped device 87 and then went back to step 15 and clicked on Is Failed. 86 did turn red but I cannot get it removed from PC Controller even after trying NOP and Is Failed multiple times. I also tired restarting PC Controller and that didn't help. I even threw the breaker for that room to be sure the power was off to 87 but that didn't help either.

Remove Failed virtually instantly gives me the error message Remove Failed Node failed (see the last screen shot below).

I don't know why PC Controller worked yesterday to remove it but it is not working today.

What should I do now?

Here you can see 86 has turned red and I was running NOP after the Remove failed:

Here NOP has finished.

I then clicked on Is Failed as also suggested and then clicked Remove Failed again.

Here you see the error message I get every time I try that:

BTW, there is one curios thing in that PC Controller is in there twice now:

Personally I think that if it is a ghost (where no device is attached to that node), powering down other devices is totally worthless and just a myth. There is no logical reason as to why that should make it work any better.

Maybe the z-wave on your hub is stuck. I think if the stick is attached to the hub correctly it has to relay the removal to the hub as it happens. So if the hubs z-wave is having an issue it could cause a failure? I would power down the hub totally and unplug for 30 seconds then boot back up. You could also unplug the USB stick for about 30 seconds to restart its radio as well.

1 Like

Honestly, it might make it worse. During a device exclusion from the controller, I believe controller notifies all powered up devices that the device is being removed from the network and to remove it from their neighbor tables.. If you've powered off multiple devices unnecessarily when removing another device, those devices won't receive that info and may still think they can send info thru the now removed device. In other words, the ghost may still exist until the neighbor devices have their tables repaired manually.

1 Like

So some major good news. After gracefully shutting down the hub, pulling the Z-Wave stick, air gapping #87, and excluding the ghosted Z-Wave stick I was finally, finally, able to remove ghosted device 86 using PC Controller. YEA!

So I am left with 1 other problem Here is a device that I'm saying isn't technically a ghost because it has a path (albeit with many hops), but as you'll see, 75 has no name:

I happen to know that it is the Master bathroom toilet fan because I can't find that name when I search for it in the Z-Wave Details page or on the Devices page. Since it has a path I put the switch into discover mode and then started a Z-Wave exclusion hoping to remove and then re-include it, but Hubitat didn't find it to exclude it.

I then tried the Discover button which caused the Remove button to appear. But when I pushed that it says PENDING, which seems to not go away.

How do I fix this device?

When you put the switch into exclusion mode, and exclude on the hub it should find it and either remove it or say unknown device excluded. If even that is not working then the switch probably cannot reach the hub at all.

You could try factory resetting it and then including it as a new node, but if exclusion is not getting picked up inclusion probably wont work either. This will also leave you with 4B as a ghost that you would need to remove.

I tried to exclude it again, and Hubitat said it was excluded, but it didn't go away.

I then tried to remove it with the PC stick, and while 75 turned red I could never get it to go way. Remove Failed kept giving me this failed message:

I tried to remove it with the PC stick after gracefully power cycling the Hubitat and replugging in the PC stick, with the same result: 75 turns red, but won't get removed even after several NOP, Remove failed tries.

I did a factory reset on the switch and then was able to re-include it. I'm not sure what steps to do at this point to get rid of the 75 ghost. I didn't want to start clicking on discover (and then hopefully remove) or to try to use the PC stick without asking here first as I don't want to mess it up. If I use the PC stick should I air gap the switch first? If I should try the Discover/Remove first do I air gap 75 after Discover but before Remove or leave the power on all the time?

So I gracefully powered down Hubitat and pulled the Z-Wave stick for a couple of minutes. I then plugged the C-8 back in again and after I got the green light I plugged the Z-Wave stick back in. Then I started Sil Labs and the PC Controller. I then air gapped my Master Toilet Fan (as you'll note from above I'm sure the ghost belonged to as that name disappeared from my device list when the ghost appeared), and to be safe I even powered down the next one, #76. PC Controller has device 75 turn red. When I 1st clicked Remove Failed it took a took 15-20 seconds I'd say before Is Failed, failed. After that, I tried NOP, which says "Send NOP completed" in less than a second and then I clicked Is Failed again. Is Failed then fails virtually instantly too. I tried repeating the NOP/Is Failed routine a good 5-6 times and Is Failed fails virtually instantly.

I know I see most folks say they never had the PC Stick fail for them - but I did find a post here and there that said it didn't work for them. Although I got it to remove one ghost, after weeks of trying as set forth above, the vast majority of the time I get a ghost to turn red and then either it isn't removed from the list, like here, or it wasn't removed from Hubitat, as also detailed above. So I'm certainly not finding the PC stick to be some wonder device.

I also tried the Basic Set On and Basic Set Off but going around my house I could not see it turn anything on or off and nothing shows up in the Hubitat logs when I did that.

I also could not remove 75 in Hubitat. When I click Repair button it fails. When I click the Discover button I do get a Remove button but that says PENDING until I reboot the hub.

I certainly don't want this ghost hanging around forever to eventually corrupt my Z-Wave database, but I'm at my wits end on how to remove it.

I know on some GE models the air gap cut power to the relay but the Zwave chip remained powered. Know yours is Inovelli but you might try flipping the breaker and try.