Ghosted on ghost issue. How do I create/submit a support ticket?

I am having 3 problems that I posted about here that started when I got a ghost:

I was getting responses until Dec. 29. I thought that I'd wait a few days as it was New Years, but I haven't gotten any further help in the 3 weeks since then even though I tagged @rlithgow1 @TArman @bcopeland.

Since the community isn't helping me I want to submit a support ticket to Hubitat directly, but cannot find how to do that. I've looked all over, including under Support, but that just suggests I read the FAQ, watch some videos or post something to the community.

BTW, here are my 3 issues:

  1. I got a ghost on 1 device and then a second device. I know what the 1st one was, and it came back in (since it has a route), but it doesn't have the device attached to it and it isn't on the devices page. How do I fix this problem?

  2. As to the 2nd ghost device, I don't know what device became ghosted, but I did everything they said to remove a ghost, including buying a Z-Wave stick, getting it set up and then turning off all the power in my entire condo by throwing the breakers (one at a time and even all of them at once) and making sure any smart plugs were not plugged into a UPS, but I could never get it to be removed (i..e turn red in the app). In fact, it seems I even ended up even worse as it looks like I now have a ghost PC Controller:

What's even worse is I'm not sure which PC Controller is the ghost, as 129 shows an "x" and check in the PC Controller App, and 131 has 2 check marks, but 131 isn't in my Z-Wave details. Perhaps that is why I can't remove the "real" ghost, but I don't know how to fix this.

  1. All of the switches, smart plugs and smart bulb in one room are suddenly turning on since this happened. I tired to disable the one app that has all of these devices in it:

Yet it doesn't show that it is stopped or disabled:

Like other apps I've stopped do.
Screen Shot 2024-01-14 at 4.05.07 PM

Why is that? How do I stop it?

How can I get these resolved from Hubitat? I'm not 100% sure if the people I've tagged are actual Hubitat employees, or just extremely knowledgeable and helpful people that have been helping out for years, but they and everyone else has stopped responding to this thread.



I can't help with any of the ghost stuff, but for #3, you only disabled the action in the rule (which may or may not be good enough - I'm not sure).

But to get it to show "Stopped" (or "Paused") like your Batt is low example, you need to use either the Stop or Pause button on the rule's setup page -- in your shot above, those 2 buttons are above the red Remove button at the very bottom.

1 Like

This one looks like it was an attempted add that did not work, and then you added again and it is working as another device. If it has a route, that means it is powered on and communicating with the hub. For that one, you would need to figure out what device it is, power it down, and try the refresh method until you get the remove option OR move on to the Z-Stick method.

For the Zstick, did you follow all of the directions here (to the letter)?
-Thread: How To: Remove Z-Wave Ghosts (including using a UZB Stick)
-PDF: Dropbox - Hubitat Remove Ghost Instructions.pdf - Simplify your life

You may need to exclude both instances of the controller and then start at the beginning. Go step-by-step and pay particular attention to when it recommends things in bold (like using NWI method or classic learn mode). The first few times I had to use it, I printed the file and lined each step out as I did it (old Navy QA methodology).


You can't, there is no one-on-one support available unless it is a warranty claim. If you want that type of support you would have to pay someone for it.


To be clear, there's nothing special or unique the Hubitat staff can do for you - there's no magical backdoor they have access to for removing ghosts.

The z-stick resources the community has provided and tried to help you through are as good as things get. As @tray_e says above, following those instructions carefully & exactly is essential to success.

If that process truly doesn't work, then the last option on the table is to nuke z-wave and start over.


I will add to follow those instructions very carefully , but add if you have a C8, when you get to the step that talk about select learn , I have found that does not always work with the C8 and have had to use Classic Learn. Other than that I have always had success with the z stick ghost removal process. Better luck actually than the native process.

If it had a route it wasn’t a ghost. But when doing a removal, remember power for the causing device needs to be pulled before trying to remove it.

That is also an option, but it s really a thermo nuclear option if absolutely nothing else works.

What kind of device is it? If it’s a switch, doesn’t it have an air gap switch so you don’t have to lit power to the circuit?

OK, since you have PC Controller and since the device appears to be a switch based off your screenshot, go to the Network Management tab, select device 75, then click "Basic Set ON" and then go around your house looking for the switch or light that just turned on. You can alternately hit the ON and OFF commands to help you locate the device. This will help you identify WHAT device is device 75. Then, in Hubitat, create a virtual device, but select the appropriate type for that device, ie "Generic ZWave Switch", or whatever is appropriate. Create the device, then change the network ID. You'll have to tell Hubitat that you think you know what you're doing. Then you'll enter "4B" in the ID box (without the quotes. 4B represents 75 if hex). After you do this, save the device, then immediately hit initialize or configure at the top of the device page. It should sync Hubitat with the switch and you should be golden.

129 is the ghost. 131 is your current Z-Stick PC Controller. Below the buttons in Network Management ALWAYS shows the details for the controller, and it says the current is 131, according to your screenshot.
If you already had a device for your previous ZStick controller in Hubitat, just go to it and change the network ID from 81 (129 in hex) to 83 (131 in hex). If not, it doesn't really matter, honestly.. but you could add a new virtual device, select the device type as "device", and after creating it just change the network ID to 83.

According to your screenshot, you have not disabled this rule. What you have done is disabled the action in the rule. Therefore, the rule itself will still show active in the main Apps list.


So more weirdness. When I push the Stop button it say it is stopped (see upper right corner):

But when I went out to the Apps page it didn't show it was stopped:

So I went back in, and now it doesn't show it was stopped.

So I stopped it again:

(And BTW, I'm using the Done with Button Rule button in the lower right to get back out every time).

And, as before, it doesn't show it was stopped on the Apps page (and I refreshed the page to be sure that wasn't the problem) and when I went back into the app it doesn't show it is stopped.

So it isn't staying Stopped. Any idea why that is happening and how I can actually stop it?
In the meantime, I reassigned that app from my (Stuart's Den) Fibaro KeyFob 6 Held (the + plus sign) to 1 Held (the Square) to try to make sure it isn't the KeyFob itself that is faulty.

I tried to follow the Z-Wave stick instructions exactly, but it took me days and days to even get to the step where I could try to do the exclude. (It was a struggle even getting it to install and every step along the way needed multiple, multiple tries).

I had tried just doing the air gap before when I had issues with my switches (all are Inovelli) but I found that throwing the circuit breaker would work reliably where "just" doing the air gap didn't (and yes, I made sure the power to the switch was off after I did the air gap. Why that is I just chalk up to the great mysterious Z-Wave Gods).

I will try the suggested steps for the other issues and report back. BTW, I had asked about support tickets as I saw them mentioned when I did a search and I was reporting that I was still having issues 3 weeks ago and nobody was responding any further.

While I think some of those who respond are Hubitat employees, and I know they are a small company, just IMHO that there should be a way to converse directly with Hubitat to get their official position and assistance on an issue (especially in cases like this one where nobody had responded further for 3 weeks).

Oh, one last thing. What is the "nuclear" option? To have to rebuild the entire mesh and re-include everything one at a time?

Would reverting to a backup that was created when I went from one hub version to the next fix it?

I just played around with the Stop/Pause options on one of my Button Rules -- I discovered the trick is not intuitive, but after pressing Stop or Pause, do not hit Done. Instead just back out of that page. Hitting Done strips out the Stop/Pause for some reason.

The nuclear option would be to wipe ZW and start over. Obviously not a desirable path, so hopefully it doesn't come to that.

This will force reset your ZWave radio, which will remove ALL ZWave devices from Hubitat's memory (while leaving the orphaned device drivers in place).

You will have to factory reset and then re-included everything all over from scratch.

This is the ONE case where you don't want to hit the "Done" or "Update Rule" buttons, as those buttons re-enable the rule. So when stopping a rule, hit "Stop" and then hit the back button on your browser to go back to the apps list. Refresh the apps list and it will show (Stopped)

1 Like


Stop although is a stop is not designed as a disable which is what the OP wants.

Stop is designed to stop a rule while your working on it, because if the rule runs when you're changing stuff it can cause issues with your rule.

If your trying to disable a rule for a period of time you should use the disable option on the app and driver UI and tick it's box.


From the above I see that Rule Machine rules can "stopped" but Button Controller Actions are "disabled".

So that certainly explains some of my confusion. Maybe Rule Machine rules should be "disabled" instead of "stopped" to help avoid such confusion. Also, just like Rule Machine rules say they are stopped on the Apps page, I would like to see Button Control actions also be labled as disabled if they are.

In any event, since I had disabled the rule for my Fibaro KeyFob button 6 held, it shouldn't have run, which made me think the KeyFob button wasn't defective. As a test I reassigned those actions to the KeyFob button 1 held. Nevertheless, all the lights, fan and plugs turned on again by themselves last night which makes me even more confident it isn't the KeyFob. I may create a virtual KeyFob and assign those actions to it to see it if still happens and/or maybe remove 1 item from the several that are getting turned on to see it that rule is still being run.

However, something dawned on me that I had overlooked when trying to remove the ghosts before, and that was that this KeyFob or one of my other 2 Fibaro KeyFobs and and/or my 1 Aeotec button controller may be the ghost item as I never removed the batteries from them when I was trying to remove the ghost. I'll try that and see what happens.

I use Stop in RM all the time when I want to disable a rule, I think the check box next to it does nearly the same thing. I saw somewhere from a dev that Stop unschedules all the triggers, where pause leaves it scheduled but just does not act on the triggers.

not quite.

yes this is correct.

however disable completely disables the rule from the database you can't get into it, edit it or do anything with it unless you re enable it.


Yeah I used to avoid disabling things because of how the boxes looked. Now with the new UI it is much less annoying so I went in and started them, paused, and then checked the disabled box. I actually like that better now, with the box and strikethrough it is much more visual that they are shut off. Thanks for the inadvertent tip!


So while I was sitting in my den all of the devices came back on. From the logs below I see what was turned on, but I can't tell from them what told them to turn on. How can I determine what app or device (a switch, my KeyFob, etc.) told them to turn on?

BTW, I did take the battery out of the KeyFob for my den (which is the room that all the devices turn on in) and tried to use the PC Controller, but it didn't work. But that may be because I still have the 2 PC Controller issue listed above.