Ghost Nodes Removal

You may need a stick.... The issue is not with hubitat but with the Silabs SDK that is the issue.

Honestly it's very simple. Load the silabs software on your pc or laptop. Plug the stick into your laptop. Start pairing on Hubitat and then pairing in the SiLabs software and it will pair with the hub. From the Si Labs software find the ghost and remove it. Exclude the stick. The instructions are very step by step and very easy to follow once you have the software in front of you.

1 Like

I’ll give it a go as I think it may be why one room is suddenly turning on all the devices in that room every now and then starting after the ghost appeared.

Can you give me a link to the stick you recommend?

Do I need to power off the device I think the ghost was related to when I remove the ghost?

Is the stick useful for anything besides removing ghosts? (I’m asking as I might as well get the most out of it)

This will do ya

Thanks. Ordered and will be here tomorrow.

Can you please send me a link to the latest instructions?

Is this it?

@danabw Whats the current link for the ghost removal instructions?

@Stu_The_K ...


Doc (linked to doc included in the topic):

NOTE: Always best to start at the topic as it includes info on using the much improved HE hub built-in ghost removal options, which are sufficient for removing most ghosts these days. Both the hub's built-in tools to remove ghosts, and the effectiveness of the instructions for using them (thanks to @jtp10181 in particular) have improved over time.

If the hub's built-in ghost removal tools aren't sufficient then time to use a UZB stick with the UZB instructions PDF.

1 Like

BTW, I am still periodically trying to use the Remove button to see if I can get Hubitat to purge it. When I have been doing this I've killed the power from the breaker box to the switch that spawned the ghost. I do have a question though. I've noticed sometimes the Refresh and Remove buttons looked liked raised buttons, but other times they are flat. (See screenshots below). Why is that and what does that signify?

You know, IIRC I've seen that as well and I don't remember everry asking about it!

Tagging @bcopeland to see if he has any wisdom about this, or maybe it's a @gopher.ny/HE UI question.

While the instructions to use Hubitat say to not keep mashing the button too quickly, I"m wondering how quickly is too quickly? If I push the Remove button and the page refreshes (usually takes 15 - 20 seconds) does that mean I can then push it again?

Yes, if the page refreshes and comes back you can try again...I usually wait a little longer after the page refresh to try again. In the past I've had devices take up to 10 or so tries w/Remove to work, and of course in some cases it just won't work.

There was some new info one of our members discovered recently when trying to remove ghost devices generated from UZB sticks that had partially joined...he shared the information in his post here (below) and another post of his a couple posts down in the topic - worth reading/looking into for your case as it might allow you to do the remove w/out having to get/use a UZB stick if you don't already have one.

Note that if you''re going to remove/re-pair devices, you'll want to use the Swap Apps Device to swap a virtual device into all the automations for the real device first, do the remove/re-include, and then swap the "new" real device back into all your automations.

I am running Parallels and Windows 10. I got the Zooz 800 Z-Wave USB Stick ZST39 LR. I can log into the Simplicity Studio but it keeps saying it it has a network error when it tries to update. I ran the Microsoft network fix wizard and it said it was fixed. I went to using Edge in Windows and confirmed I had a speed > 100. In SI a network panel opened up. I haven't the slightest clue what I am to do with that. I tried closing it and relaunching SS hoping that now that I was connected to the internet on the Windows side all would be well. But I still can not update the software.

Also my stick is just showing up as USB-Enhanced-SERIAL CH9102 (COM3).

I also when I went under Tools I saw I do not have the PC Controller software. When I went to add it I got the same network error. I then went to run again to be sure I was still on the internet on the Windows side, but I wasn't. I run the Microsoft Network Diagnostics again. Again it said The default gateway was not available, but it was fixed. When I run right after that I it works and I see I am connected. I went right back to SS and this time it took me to an update screen, and it shows it is running, but ultimately error'ed out again. However, SpeedTest continues to give me speeds so I don't know why this is happening or what to possibly do about.

I now have 2 ghost in Hubitat after 2 weeks and my one room has all of its switches turning on randomly ever few days.

So I'm totally stuck at this point. Please help.

Below are some screenshots I took:

Screen Shot 2023-12-23 at 3.50.47 PM

One thing: I found the PC Controller on the Installation Manager Tools page, but it won't let me install it until the other updates are done.

Tagging @rlithgow1 as I've never used Parallels so don't have any experience w/that.

You need to share the network interface with the parallels VM. There should be settings in the VM. In windows click start then type CMD and hit enter. You will get a command line box. Type ping and your gateway interface (your router). Usually it's whatever your ip address is but .1. If you have connectivity there check if you can ping If so then set the DNS in windows to and try the si labs update again.

I'm sure I'm connected to the internet inside of Windows. I did the Ping as suggested, I ran a speed test from and you can see that the SS update was fetching the needed files. But then after doing that for a minute or 2 it errors out.

So am I SOL if Hubitat can't remove my, now 2 ghosts, and I can't update Simplicity Studio to get the PC Controller installed?

If you ping does anything come back?

Yes. (Forgot "Ping" the 1st 2 times. Ooops. But then I got there)

BTW, I tried to totally uninstall SS and reinstall it, but it crashed.

I was able to install it on the Mac side. I did that as I believe I may be able to run the PC Controller from there.

PC controller is not available for the mac version.

1 Like