Ghost Nodes Removal


I had in the past to force remove a z-wave device and include it again.
Does the re-inclusion of the same device override a ghost node (if there’s one) from the previous force removal?
How do I recognize if there are ghost nodes in the database and how to remove them?
I’ve come across a topic where commenters indicated that if a node is unresponsive for some period of time, the ghost node will be removed by HE overnight after rebooting it.
Is this statement correct?

It depends, but usually not.

(Assuming this is on a model C-7) Ghosts are most often seen as an entry in the z-wave details page (from Settings) that has no route and no device (the discover button is shown instead).

Unfortunately, it can sometimes be difficult to tell what is and isn't a ghost.
From my experience:

  • sometimes devices show no route that are not ghosts
  • sometimes entries show no device that are not ghosts (this is quite rare)
  • sometimes ghosts show route even though they are not reachable

If you can post a screenshot of your z-wave details page, someone should be able to help you understand if there are any issues here.

1 Like

No and chances are trying to re pair that device would create more ghosts.

With the C7 there won't be anything in the routing column. With the c5 it will have nothing in the in/out nodes. Post a current copy of your z-wave details page in its entirety

It can allow you to remove it or it can disappear. It depends. If the device that created the ghost is still powered up it will not remove perioed.

Not necessarily. As @tony.fleisher indicated in his post, it is possible for devices to show no route, yet not be ghosts. An example would be battery-operated devices that have not communicated with the hub since last boot. For example, here are two minimotes that I use as secondary controllers only for inclusion/exclusion.


True.... That is definitely an exception

You have one incompletely paired device (0x07). The RSSI indicates poor signal strength for all your devices; negative numbers indicate signal is lower than background noise; 0 indicates signal = background noise.

Also, your mesh is completely devoid of any repeating devices. So it is rather weak.

I suggest looking at this document:

1 Like

The device in question is the last one named as Basement Bathroom Warer Sensor.
I force removed it and re-included.
Will resetting z-wave radio erase all of the ghost nodes if there are any?Do I exclude first, then reset the radio or reset the the radio, then exclude?

That’s correct. I don’t have any repeating devices. I’m just starting my journey of home automation.
Regarding the not-paired device, how do I remove it? There’s a Remove button in the status column after I refreshed the device. Should I use it? Also, should I reset the z-wave radio instead?


This may not work if you re-paired this device. If that happens, you will need to use PC Controller to remove the device. However, in my experience, ghosts of non-repeating devices - like a binary sensor will not interfere with the network.

OK. So I clicked the remove button for 007 device and the device is gone. Is this problem solved now?
My remaining issue is building a strong mesh (which I'm gonna start with reading the doc you suggested)?

1 Like



@bcopeland has also indicated that even a mains powered device that is properly connected can also temporarily show no routing - I've seen it one of my C7 hubs, with both a range extender (Aeotec) and a wall-wart plug (Jasco). Usually a simple reboot would re-populate the routing info, but it could disappear again. The function of the device was alway fine, even when no routing showed.

Unfortunately I cannot remember his explantion accurately, and don't want to badly mis-quote him here. :slight_smile: it is:

1 Like

As @aaiyar pointed out, you need repeaters. I highly recommend the Ring V2 extender. Also if you can throw some pains powered devices in there it will certainly help. Maybe some outlets or switches. Mains powered devices repeat...(though metal boxes do lower the signal a bit)

1 Like

Ok. Thanks for the suggestions. I’ll look into it.

Best repeaters for me have been Jasco\GE wall wart plugs. Like these. They repeat like crazy. Had zero luck with the Ring repeaters.

Edit... Oops posted the wrong one see my updated post below.

That's gotta hurt! :rofl:

1 Like

Um, you are aware that these are Zigbee, and the Ring v2 are Z-Wave Plus, aren’t you? Zigbee doesn’t repeat for Z-Wave, and vice versa. That might explain why the Ring repeaters didn’t repeat for you. They repeat fine for me.

1 Like

I have the Z-Wave versions... I must have posted the wrong pic above. Oops.,:slightly_smiling_face:

These are the ones I've bought. They are mad good repeaters for me.


I went to check my Z-Wave details and found the Master Bathroom Toilet fan with Device #4B had no route info. (BT it is an Inovelli Black On/Off switch). Since repair didn't work I removed it from the Z-Wave details page and then went into the device from the device page and removed it there too. I then re-included it. When I did I added it back into the Alexa and Google apps, the Dashboard app and then the one Button 3.1 rule it had been in. For some reason though, when I went back into the device it showed it was being used by the button rule and dashboard but neither Alexa nor Google.

I then went back to the Z-Wave details and saw that device 4B was still there, just with no name. I tried to remove it from there to no eval. I tried air gapping the device and then removing it, but that didn't work either.

I then excluded the Master Bathroom Toilet Fan again, air gapped it, shut down the hub, pulled the hub power from the plug and waited about 15 minutes before I plugged the C-8 back in again.

The ghost device is still showing up in the Z-Wave details page but isn't on the Devices page. Now I only have buttons to refresh, repair or discover. I don't even have a remove button. I have left the switch air gapped and I have not re-included it.

As you'll see below, no device "4B" is there,

12/11/2023 update:
I tried "repair" and then the "remove" button appeared. I tried that and now it says "Pending" (See screenshot below). How long should it say "Pending" before it actually removes it?

I only have a desktop mac so I can't use a Z-Wave stick to go up to it to remove it.

Help, please.

You can. Simply load up parallels or bootcamp and use a demo copy of windows.

It can take a day or so... I would just wait it out.