Geofence has no red dot

I have the blue current position but no red dot indicating where home is. I have zoomed out as far as possible and it is nowhere to be found on this planet. Any suggestions on what I can do to move home back to earth?

Go to Settings|Hub Details and set the longitude and latitude.

1 Like

Thanks for the quick response.

The long/lat is set (on all hubs). Definitely set on hub the phone is connected to. My other phone, connected to the same hub, is working fine.

Both phones on the same version of the Hubitat app? The app version is found under "Show Debug Information" in the Gear Menu (Settings) in the phone app.

While you are in Settings, check to be sure "Enable Geofence" is on.

Since this has been going on for awhile I uninstalled and reinstalled the app yesterday, unfortunately that changed nothing.

In the app:
Both phones are 1.6.8 build 128
Both have Enable Geofence
Validate on network change is on

From the debug info screen:
Events are correctly occurring with the phone lon/lat , but the home lon/lat is 0.00/0.00 rad 585 whereas the working phone show the correct home lon/lat with a rad 252.

On the phone:
Location permission is on
No power saving restrictions applied
No battery optimizations applied

@moncho1138 is this something you could look at?

Hi. I've been having the same issue for the last month and finally got time to look here in the community. My hub has a lat/lon but debug in the app says 0.0/0.0 for both lat/lon. I'm on the latest build as well that came out in January to fix presence issues. I only remember noticing issues for the last month though. The debug info in the app has tons of entries for"initial location set up" when I'm using the app. It clearly logs the true lat/lon of the phone. I've cleared app cache and app data and set it all up again, but it isn't getting the lat/lon from the hub. I tried slight changes to the hub lat/lon but it didn't help. Hub is on build 2.3.1.142.

I'm trying updating hub to 2.3.2.130 to see if that improves anything. Hub updated. No change to lat/lon in app. Still 0/0. Turned geo fence off and back on. No help. Deleted app cache and app data, then changed hub lat/lon slightly. Then logged back into app and set it up again. App still says lat/lon is 0.0/0.0 in the app.

I think I've exhausted all options on my end.

Chuck

@bobbyD is this something you might be able to look at, or refer to engineering?

1 Like

Thanks.

I did send an email to support on Friday afternoon referencing this thread. Hopefully it didn't end up in spam. The geofence is still at 0.0/0.0 as of late Sunday.

Chuck

Could you please share the make and model of your mobile device as well as the Android version?

It is. LG G6 (aka VS988) running Andriod 9. My wife's phone is identical and her geofence is still currently working and has the red dot over our house. She doesn't open the app often though.

Chuck

Thanks for the details.

If you are changing the coordinates in the hub's interface, those don't cascade to the mobile app. Have you tried setting the geofence on the phone by moving the pin to your location?

There is no red pin to move. The map opens centered off of Africa where 0,0 would be and zoomed out to see all of Africa, Europe, and half of South America. When you start to zoom in to look for a red dot at higher zooms, the equator disappears and you're just swimming in blue water with no reference as to where to find 0,0 to see a red pin is even there.
I'll try to upload a screen shot.

And yes I tried looking near my house for the red pin. It isn't anywhere to be found in North America either.

The phone is a guest account on my Hubitat account.
ZTE A2017U, Android version 8.0.0
Confirmed Location service is on all the time and the Hubitat App has Location permission.

The phone used to have a home location (red dot) but it disappeared a while ago.
Whin it was visible depart/arrive was spotty but a lot has changed since then.

Unfortunately I cannot replicate with new hub or existing hub, but I asked the developers if they have any idea why this might happen.

@bbholthome and @ChuckO can both of you post the first 2 fields on the "About" page?

Hi. Mine is also version 1.6.8 build 128. Even though my apps are set to update automatically, I did confirm I had the latest build available.

1 Like


Here's the screen shot.

Phone is Version 1.6.8 Build 128

Download the Hubitat app