Generic Zigbee Switch

I bought this cheap zigbee switch: ""

to test with new Hubitat. I am trying to replace a bunch of older Sonoff basics. When I scan for zigbee devices it does find it, let's me name, etc.

I am able to link it with the Alexa app, Alexa controls it fine, but Hubitat will only turn the switch off, it will not turn it on?

I have reset the switch and tried multiple times.

I am totally new to using the hubitat, sorry about that.

Any help would be appreciatted

What driver did it assign to the device?

Take a look at this thread. I think that's the same device.

You could try this driver:


@Ryan780: Sorry for the delay, replacing router in middle of network. That worked awesome, thank you so very much. Now I have about 15 sonoffs to replace. Again, thank you so very much.

While I have you, is there a way to assign a static IP to the Hubitat, I couldn't find anything in the settings anywhere.

1 Like

You have to do that in your router with IP reservations.

Ok, new router, still learning it, thank you

It may be called DHCP reservation or IP reservation. Different brands do it different ways.

1 Like

Alright, thats fixed, back to original issue, the generic switch works great with the driver, but when I add it to a dashboard, it will not turn it on, if I back out of dashboard, then turn it on, go back to dashboard, it does turn it off, but then hands on "sending", any ideas on that one?

Actually it does it both ways, will switch on, then hangs or will switch off and hangs

Cloud or local dashboard? Does the problem happen when you control the device from the edit device page?

Hey Ryan, sorry for not getting back sooner, replaced main router and things appear to working better. It works fine from the device page and using a test local dashboard. It works better with new router, the tect icon still gets stuck with "sending" on it, but if I wait a couple seconds, it will work again, if that makes any sense???

The cloud dashboard is not instantaneous. It has to go a long way to get back to you. Thats why local dashboards are so much faster.

I am just now getting my network straightened out. Decided time to get back to Hubitat testing. I still can't get the Dashboard to work correctly. I only have the one device to test with.

I am creating a local dashboard, it will only work one time, either on or off. Then I have to change to a different section of the Hubitat interfaace, then back to the dashboard to get it to work again.

It works fine off & on when viewing it in the device section.

In dashboard it will switch it, then hangs on "sending" here is print screen:

Maybe this will help. Forgive me for being a noob with this.

If you get the sending... that means the device didn't respond with a changed state. Check the device details or event history to see if the command was processed.

Typically this has nothing to do with dashboard, and is something with the device, mesh or driver not working correctly.

You can create a virtual switch to test with and confirm dashboard works correctly.

Forgive my noobness, but it isn't refreshing the the device is seems, I found another post and tried what it says (Zigbee switch not refreshing), but that didn't work.

Can you post a screenshot of the edit device page? What type of device is it?

I think this is what you're needing:

You changed back to the Generic Zigbee outlet driver? Why aren't you using the one I posted that you said worked the other day?

I have also bought a cheeap switch with 2 buttons. With gereric zigbee swítch I can only turn one switch on off. Where can I find an exmaple of driver so I can adapt it myself?


Hi All, I've got this switch, and having just got a HE, i'm trying to get all my existing kit working. It's looking really good a the moment, but I know @Cobra has a website coming and i'm assuming the above driver will be on it. However as my kitchen is currently in bits while i get the switch working, is there any where else i can get the driver in the mean time?