GE Z-Wave Switches Indicator Light Doesn't Change

Has anyone had luck changing the setting for the indicator lights on the GE Z-Wave Switches and Dimmers? I can set it in the preferences, but it always keeps the default behavior of turning on when the load is off. We use these dimmers and lights in the bedrooms, and the bright blue light can be a bit tough on the toddler's nap time.

I opened a ticket with support on this issue, #10203. Some of mine changed during pairing and I cannot change them back. Issue still open.

I was able to set all of mine without much of a problem. I am trying to remember if I had to press ‘Configure’ after changing the setting… Worth a try…

I have one switch where the light just won’t come on at all. I’m thinking maybe a bad switch.

What is your setting? I find all of them switched to “Indicator On when Light is Off” when I excluded and paired them to Hubitat.

Is that the setting you use?

yes, change the setting, save it, then click configure.

1 Like

I have mine configured to turn the LED on when the switch is on. When I excluded them from ST, this settings reverted back to the default of LED on when switch is off. I had to change it back once they were paired with Hubitat.

When they are excluded they are reset to factory default, which is 0 = on when light is off.

Mine is a linear, but you have to set it to off for it to turn on when the switch is on. It was backwards in ST too as I recall. Might try the un-obvious with your one “bad” switch.

That’s what I’ve tried from the start with no success, unfortunately. I’ve also tried repairing the mesh, dropping and adding the device and rebooting the hub.

The logs read: warn - configure... when I try to configure so something is happening on the hub side but it doesn’t take with the device.

What driver and what exact device are you using?

I have the same issue. I have several GE switches (device type: 18770, deviceID: 12338, manufacturer: 99) and was able to reverse the indicator light behavior on all but one of them. This particular unit worked fine under ST though. I tried re-pairing it but that didn’t fix it.

not working would be a consistent experience if it was related to a specific model.
I have a few GE switch/dimmers due into the maxwell lab any day now…
We’ll get this sorted.

I have multiple GE (Jasco) 12727 (three way Z-wave switch), 12728 (Addon switch) and 12729 (Z-wave Dimmer switch) that I have (almost) never been able to get the indicator light to come on either in ST or in Hubitat. I say ‘almost’ because when I first installed these several years ago I swore I saw the indicator light on one of the switches as I was installing it. I have never seen it since, on any of the switches.

I don’t think the 12727’s and the 12728’s (toggles) have indicator lights. At least none of mine do.

1 Like

I happened to notice when doing an exclude and airgap reset on mine (I think they are 12724) that the LED also works when the switch is not paired at all. It switches state with the rocker (I believe in the default LED-on when switch off mode).

@mike.maxwell I am on v701 and I just tried changing the LED on a GE switch I just added which for some reason added as a "device" instead of the generic z-wave switch. When I try to configure it to change the LED I get the following errors:
dev:4072018-03-01 17:50:02.323:errorCannot get property 'id' on null object on line null
dev:4072018-03-01 17:50:02.311:warnconfigure...

I excluded it and added it back and same results. Any ideas on how I can change the LED light on this device?

I haven’t fixed that yet, my pile of ge devices just came in a few minutes ago

2 Likes

I have an identical switch beside it in the same gang box that paired just fine but realize it has one digit off on the inClusters:

  • deviceType: 21079
  • inClusters: 0x25,0x27,0x73,0x70,0x86,0x72,0x77
  • deviceId: 13619
  • manufacturer: 99

The problem device ends in 0x76 and the good one ends in 0x77

I think you are right. I just looked up the instruction manuals and I saw no mention of an indicator light. I must have picked up a different model that had one when I initially installed these. I do recall returning one … it must have been that one. Thanks,

1 Like