GE/Jasco Z-Wave Switches Failing

I have 10 GE/Jasco z-wave switches to control inside and outside lights. All of them started failing in the past few days. They won't respond in the app and automations are failing. They are not Z-Wave Plus so I run the Z-Wave Poller app. I am seeing a bunch of failed poll responses in the logs so I assume that is related. However, I think I saw them in the logs previously but the switches still worked.

All of this is more an indication of a weak zwave mesh rather than a switch hardware failure.

Now you may prefer to replace them with modern switches, but I would recommend addressing the underlying mesh issues first.

For an immediate solution, try shutting down the hub and pull power for 30 seconds then boot back up. That will reboot the zwave radio and might bring them all back to life for now.

I've been using the same z-wave devices since I installed hubitat a year and a half ago. The only thing that's changed recently is I added some zigbee repeaters to improve my zigbee mesh. Could those signals be causing a conflict?

Thanks, but no dice.

It is possible that you have one or two failing nodes. Since the bulk of your devices are z-wave and not z-wave+, new routes are not automatically discovered to get around failing nodes.

Do you have a C-5 or a C-7? If you have a C-7, I recommend posting a screenshot of your entire z-wave settings page.


I have their zwave plus switches. Sometimes they stop functioning - state does not change manually or remotely. Cycling the power by turning the breaker off for a minute or two and then manually turning each switch on and off has returned them to full functionality. Try it …

I had a lot of non-plus devices that died over the years. Jasco support was/is amazing. They replaced them under an extended warranty (their extension) and are terrific to deal with. You should contact them and see what they can do for you.

I'll try the breakers but that will end up being the whole house, so I need to coordinate that. In the meantime, here is my z-wave config.

You have at least one ghost in there. Your mesh will at best be problematic with it still in there. 0x20 needs removed. 0x6 has a shite ton of route changes showing that it's struggling to find a good route. This would be helped by a beaming repeater.

I hope 0x06 doesn't need a repeater. It sits 2 feet from my hub! It's right next to another Jasco switch and about 4 feet from another. Is it getting confused because the other switches are so close?

How do I remove 0x20? When I click Refresh from the Z-Wave Details screen, it shows PENDING and a Remove button. Is that what I want to do?

Click the remove button...

The top switch (0x06) with all the route changes is routing through Front Lights (0x0c). Are these just z-wave or z-wave plus switches? One thing you could try is just doing an individual repair on just that node. Possibly repairing might help as well if its that close to the hub..

Thanks so much @rlithgow1 . They are not z-wave plus. I will definitely get those ghost devices cleaned up. However, everything started working again after my last post without any intervention. Could the hub restart from a day prior taken that long to get things working again?

Also, 0x06 is now routing through the switch right next to it and the route changes have dropped to 97.

That's kind of like saying my blood pressure has dropped to 180/110. Which is good when I'm dealing with z-wave issues :slight_smile:

Ha! Good point.

I'm gonna say if you can get rid of the ghost your blood pressure (and the route changes) may go down.

If you cannot get the ghost device removed I would not worry too much about it yet.

When was the house built and what type of construction is the interior walls?
Also what is the approximate sqft of the foundation?

I agree 97 route changes in around 24 hours is no where near what I would call good. If we can solve the route change issues, the mesh will be much more stable.

Built in the 1940s with plaster walls. The foundation is roughly 36' x 36.' Two floors and full basement. The hub is located in the basement with 4 of these switches within a few feet. The first floor has a number of switches evenly distributed throughout the rooms.

Anyway to re locate the hub more centrally in the house?

Plaster with metal lathe under it? Or wood slats?