GE Jasco Z-Wave Switch Wont Pair

I'm new to Hubitat and just got my C-7 yesterday. As I'm moving things over from my ST, I can't get a GE 40 amp zwave switch to pair up. It runs a well pump on 240 VAC. It works great on ST but after excluding it off of ST, I do a factory reset on the switch and try to include it to the C-7. During the inclusion, I get a popup page that has for things listed where 2 are checked. The 2 checked are Security 2 Class 1 Authenticated and Security 2 Class 0 Unauthenticated. I click OK and the page pops up wanting the first 5 digits of the switches security code and displays the rest of the code so I know its communicating. I enter the code, then it's discovered and says initializing but never leaves initializing. After 10 minutes I reboot the C-7 to clear that initializing. One time I got it to complete but the title says not known and it won't turn the switch on when selecting. I've tried checking and unchecking every option on that first popup page but can't get this switch to operate or activate when trying to turn it on. Any ideas how to pair this switch?

I am not that familiar with that particular device but some Z-wave devices can be finicky if you do not have the device close to the Hub when pairing. That can be difficult in some instances, but there are wireless extenders or Powerline devices you can use to move you Hub out if you can't bring the device to the Hub.

There is a known issue with Zwave pairing of Inovelli switches where they get stuck on initializing. @bcopeland suggested this work around, maybe it will work for your GE switch:

So I have seen this on the C-7. I have paired 6 successfully by doing the following:

  1. Go through the regular pairing.
  2. When the pop up comes up, uncheck everything.
  3. Click OK
  4. Another pop up? Click OK
  5. Wait
  6. Half the time it come up askin for name etc
  7. The other half the time, you can wait about two minutes. Go to settings->zwave details. At the bottom of the table should have the device.
  8. Follow the link; rename and change the driver if needed from there.
1 Like

I have tried all these great suggestions and it does recognize it fairly quickly and I give it a name of Well Pump. However when I create a tile, the box has a question mark in the middle even though I assign it as a switch and it says "Unknown". So at this point I can't communicate with it meaning the tile is dead and won't turn on the pump.

Forget about the dashboard for a bit... Until it works from the device detail page the dashboard will never work.

So step 1 on a troublesome device is to verify on/off works from the device detail page. If it doesn't, then there isn't any point in testing it anywhere else.

1 Like

When you say change the driver, you mean the name of the device from that long list as I chose GE smart switch. Is that the driver list? I just started hubitat yesterday.

Great didn't know that. Thanks

Got it working. I unchecked all boxes in first popup. Then clicked ok for second popup. Then the device initialized and then about a minute later it asked me to save it. I did then went to devices and renamed it to Well Pump and then picked generic Z wave switch and saved. The on/off buttons worked so as suggested, I went and created a tile. Thanks to all as it's working great now.


While I'm here, is there a way to have two tiles for the one switch or well pump. One tile for on/off and a second tile that will turn on the same switch but run it for 15 minutes and then turn it off with a text message send to my phone that pump is off? I had it setup in ST like that.

I would setup a virtual switch and then have it reset after 15 minutes with RM.

There are also virtual switch drivers out there with timers built in - no RM needed.

1 Like

I finally was able to create a virtual switch named well pump 15 to run my sprinklers. It runs the well pump for 15 minutes then automatically shuts off the well pump. One thing I can't figure out is where or how to implement a notification to send a text message only when the well pump, not well pump 15, switches off. I created the text well pump off but it sends right when the pump turns on. I could put a delay on the text but I need to have it tied to the well pump physically being turned off.

You didn't really give enough info. Where are you trying to do the notification - in an RM rule? In the Notifications app? Elsewhere?

A notification every time a specific device turns off is trivial in the Notifications app.

1 Like