GE enbrighten Z-Wave Dimmer

Found that after the most recent Hubitat update that my GE Enbrighten dimmers no longer work as expected from the dashboard.

  1. Dimmer is on: dashboard icon does not turn yellow
  2. Turn on Dimmer from dashboard: lights turn on, but hour glass remains over the icon, never goes away
  3. Able to turn on/off and set Dimmer level using device Editor.

I tried a generic Zwave dimmer driver, it did not work at all.

Anyone else seeing this issue on their dashboard for GE dimmers?

I think some additional information would be helpful. Were you using the OOB Enbrighten Dimmer driver? Do they for sure all not work? Or just one? Did you do the standard troubleshooting of air-gapping one of them? Do the dashboard states match the device edit page states? If they don't, have you tried a different browser? Or network? Are you connected to a LAN or Cloud (or have you tried both) dashboard?

Do you happen to know which model of switch it is for sure? I don't know what models the OOB driver picks up but I know that GE re-branded the 14XXX series as Enbrighten before releasing the 46XXX series. My guess is you have a 46203 if the generic Z-Wave dimmer driver didn't work.


I have the ge switches and dimmers 14294 and 14291 and i’m Not experiencing what he is describing. I am however experiencing an issue where trying to discover multiple of these switches is not showing up during discovery mode since the last patch. I’m going to make a separate post for this since it’s not the same issue your experiencing but thought i’d share my experience as it relates to yours.

1 Like

Thanks for this. I think he is using 46XXX as well.

Z-Wave devices are one at a time unlike Zigbee. From the device discovery page at the hub.
"Hubitat Elevation® can only discover one Z-Wave device at a time."


I was just mentioning it was multiple so it was unlikely a problem with the individual devices. Turned out it has something to do with my iPad,

Using both Safari and Firefox on my iPad it was doing the same thing, it would start the inclusion but not show anything showing up. So I tried rolling the firmware back to and had same issue. Noticed it always said my hub was unreachable yet I’m interactiting with it.

Used an android phone with Firefox and it was then able to discover the zwave switch and dimmer. Must be some weird problem with my iPad.

What driver are you using for them? Did you hit configure after changing the driver? Starting with v2.1.8 these now have their own dedicated driver that supports more features.

Also, the Generic Z-wave dimmer driver is for non-plus z-wave devices. These are z-wave plus. But they also have their own dedicated driver that you should be using.

The OOB Enbrighten dimmer driver works, as I can manually execute all commands from the device Management, and they work. It is only the dashboard component that is not working.

Device Type is registered as 18756
I am connecting over LAN

This is the only GE Enbrighten Dimmer device I have, dashboard worked before the hub updates. This dimmer has worked correctly via the dashboard since May 2019 without issue.

The hour glass is persistent via Hubitat mobile app, Android 10.

I tested the dashboard via Mozilla browser, the button is not synced, lights are on, dashboard button is Grey.

I tested again, with just "Generic Zwave dimmer: this works.

Yesterday I had tried the Generic zwave dimmer with CentralScene

So, points to this being a GE Enbrighten driver issue.

1 Like

@mike.maxwell Did anything change in the Enbrighten driver?

Could try my user enbrighten dimmer driver. It definitely works with the dashboard with my 2 enbrighten dimmers...

1 Like

You've tried reselecting the attribute on the dashboard setup?

1 Like


I have the same problem with a recent update. I have 2 of these dimmers. Originally had the generic z-wave smart dimmer drivers, then changed to the GE Enbrighten Z-Wave Smart Dimmer when it became available in 2.1.8. Both drivers and dimmers worked fine and as expected. Updated device and dashboard when changes were requested and occurred.

Recent update produces same results as seen by @DenverTech99 - the GE Enbrighten Z-Wave Smart Dimmer driver works (by works I mean it appears to send the requested commands), but the results of those changes are not reflected on the device or the dashboard. Clicking the manual refresh button from the device consistently updates the current status then subsequently the dashboard(s) but it does not happen automatically.

I switched both dimmers I have back to the generic z-wave smart dimmer driver and all functions as expected, with rules, commands, and device/dashboard updates.

Currently at version .

For what it's worth, the Compatible devices list still lists the Generic Z-wave Smart drivers as the driver for the Enbrighten devices.

Dunno if this just hasn't been updated or what but it should still work.


Hi. I just received my Hubitat yesterday (3/5/2020) and updated to version before doing anything else. I have 78 of the GE Enbrighten Dimmer switches that were on a qolsys controller that I moved to Hubitat with no problem. Under devices all the switches are shown properly and function properly with the Enbrighten Driver. When I create a dashboard, all of the dimmer switches just show up as buttons and do not function at all. If you press the button nothing happens and the actual switch does nothing. I changed a few of the switches to "generic z wave dimmer" driver and then those switches function properly. Hope this helps.

You'll want to use the Dimmer Template for these devises on a dashboard to allow you control both the switch and the dimmer level.

@SmartHomePrimer I did not, just went back to using the Generic driver at this point.

Thank you for your response, I have installed your driver and it is working correctly with the switch controls and dashboard indicators.

I am trying to get the double click to function, have the debug logging on, but not seeing the button # captured when I click it.

Will continue to work on it.

Just realized that my GE Enbrighten 46204 toggle dimmer will only dim incandescent bulbs. I tried a variety of LED and CFL and all had the same problem. While HE reports that the dim level is changing the bulbs themselves do not change in brillance. Am I late to the party in discovering this, or am I "a party of one"? This happens in both manual and Z-wave modes.