GE 46201 showing [physical] and [digital] in logs with every on/off

I have several GE 46201 z-wave plus switches. I am trying to write a rule based on the physical switch being turned on. What I find in the logs is that even when one of the switches is turned on or off by a rule or Alexa, the logs show a both a physical and a digital on or off.

I'm using the system driver that I think should correspond to this device

I would like to use this driver instead of the generic because I plan on using some of the double tap and button features of these switches.

What am I doing wrong?

EDIT: forgot to mention that I have done the configure on each switch

The correct built in driver is the one that Hubitat selects when the device is included.
These are also listed in the compatibility list.

Thanks, Mike - when the device was originally included (Dec 2019) the driver just showed "Device". I switched it to generic z-wave smart switch. When 2.1.8 was released in Jan it included a new driver for the 46201, so I switched to that one and did a configure under the new driver. Should I have done this differently?

That sounds right to me.

Mike is right, if you want to use in-box drivers the correct one is:
GE Enbrighten Z-Wave Smart Switch

If you want to try a user driver, then it would be the one below. It is somewhat confusingly named very close to the in-box one (it is GE Enbrighten Z-Wave Plus Switch)... But since I made mine 5 months before they did, that isn't my fault. :smile: :

Both should support correct reporting of physical/digital events, though... So that is odd that the in-box driver is reporting both.

But if you can't get the in-box one to do what you want, try the user driver (the user driver also supports triple tap events and pre-loading the dimmer level which the in-box does not).

Choice is good.

1 Like

@JasonJoel @mike.maxwell Thanks for your responses. I have 10 GE 46201's, they all show both physical and digital on/off each time they are switched on or off, regardless of how the command gets there (app, Alexa, physical). This is using the new system driver. Here is one example of what happens when I turned one on via voice command:

I tried the same with @JasonJoel 's driver and here is the result

I don't really know how to interpret the z-wave parsing but it looks like both drivers are reporting a physical and a digital "on" when I turn the switch on via voice command? Please help me understand what is going on here.

Don't know. All of my 46201 report correctly with both the in-box driver and my user driver.

Did you do anything outside the driver with associations? I assume no, but that could do it.

And when you switched drivers, you hit Configure on the device?

That particular device is used in 2 Simple Lighting Rules, 2 Groups and 2 dashboards. Do the simple lighting rules use associations?

Yes, I hit configure after changing drivers.

No, you would know if you changed associations. It takes manual steps to do it (and the in-box driver can't do it at all).

Sorry I can't be more help. Sure looks like the command is being sent to the device multiple times. You might want to pause all of your rules and groups and see if behavior changes. Make sure something isn't repeating the command to the device multiple times.

Pausing those simple lighting rules didn't have any effect. Still seeing digital and physical "on" commands in the log with a voice command. I turned the simple lighting rules back on, triggered them (using motion) , and I see same thing in the logs, both digital and physical "on".

Kinda stuck at this point.

Sorry, no additional ideas on my side.

Since it does it with the in-box driver I would submit an email to support.

Just to close out this discussion ... 5 weeks later, I have received this response from support ...

"We cannot guarantee that tested devices will work as expected. However, your ticket has been escalated to an engineer for further research."

Well, you are always welcome to try my driver. Event type works correctly on my devices - but it does with the in-box driver too, for me. :man_shrugging:

I excluded and re-included all but one of my S2 light switches so I could get them paired up without authentication. I also pointed all the GE/Jasco S2 Enbrighten ones to your ( @JasonJoel ) drivers.

I ran a global "repair" due to all the changes--and noticed that several devices had grumblings during the process:

Any thoughts what might cause those and if I should care?



There are definitely a few command classes I didn't put in my drivers (as you can see in the logs when you repair). Maybe I'll go back and add them at some point.

In terms of device functionality they aren't needed at all. They are just additional calls that @bcopeland makes on repairs. Side note, it would be handy if there were a list of these 'not needed for normal functionality' command reports that the hub makes during a repair so drivers authors would know to add them (if they are even really needed to be added).

1 Like

Hey--thanks! I just wanted to make sure I wasn't having some serious issue there. :slight_smile:

Note: Changing them all to "unauthenticated" has seemed to help out immensely with reliability. W00t! :slight_smile:

Really? Mine says "GE Enbrighten Z-Wave Plus Switch - JJ"

Oh wait, I might have tweaked the driver code a bit. :slightly_smiling_face:


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.