GE 45605 outlet not reporting state

I just got everything set up and transferred from a Vera and am pretty happy overall. However, I can't seem to get the state of my GE outlets to report state correctly. Based on posts here, it seems they may never have (correctly) reported state but I can say that the Vera knew whether or not it was on or off (maybe it was polling). This comment seems to indicate they may report back to the hub in some other way...
In any event, HE doesn't seem to be able to detect the state of these outlets at all and clicking refresh doesn't help. I tried changing to a Generic Switch so I could see if polling worked but that doesn't help at all and the UI says polling failed.

I should note that it seems marginally better in v2.0.1.110 than v2.0.1.114 (in that .110 worked some small fraction of the time). Also the same device reported fine a few times and then broke but without any changes from me; in the working case, the event log shows that the device was turned on and seems to show polling or some other update type indicating the state.

Does anyone know how to make the state of these show up correctly? I'd be perfectly happy with a polling solution as I don't need instant results but not knowing if it's on or off is a sorely missed function.

Try the Built-In App 'Z-Wave Poller' perhaps? Is worth a try.

Unfortunately generic z-wave outlets don’t show up in the list of devices that can be polled. I tried making one a generic z-wave switch and then polling it but it didn’t help and seemed to indicate polling failed.

And a manual refresh on it's device page doesn't change it's state either?

no, sadly not. What's strange is I have about 6 of these and a few still seem to show state correctly but the others don't. However, from the logs I can see that they did (or at least appear to have). I'm going to try unpairing and repairing one and see if that helps at all.

Excluding and then re-adding one of the devices seems to have landed me in worse state; it's operable but the "Status" reads "UNKNOWN" rather than "ACTIVE" and still no state shown.

I've tried repairing the z-wave network and rebooting the hub but neither helped. I also tried repeating the remove/add (and repairing again) but it remained unknown.

I tried removing/re-adding a second device and it shows ACTIVE but the state doesn't change.

And I just went through and verified the two devices that were working last night (and haven't been touched since) and they no longer show the state correctly. If it helps, I enabled debug logging on one of them and tried toggling it on and off. On logs nothing, but off emitted some info. This device was reliably reporting status last night...

[dev:69]( 10:51:15.059 am [info]( Tub Outlet is off [digital]
[dev:69]( 10:51:15.033 am [info]( value: 0
[dev:69]( 10:51:15.031 am [debug]( description: zw device: 07, command: 2003, payload: 00
[dev:69]( 10:51:14.963 am [info]( Tub Outlet is off [digital]
[dev:69]( 10:51:14.957 am [info]( value: 0
[dev:69]( 10:51:14.952 am [debug]( description: zw device: 07, command: 2003, payload: 00
[dev:69]( 10:51:14.839 am [info]( Tub Outlet is off [digital]
[dev:69]( 10:51:14.835 am [info]( value: 0
[dev:69]( 10:51:14.832 am [debug]( description: zw device: 07, command: 2003, payload: 00
[dev:69]( 10:51:14.728 am [info]( Tub Outlet is off [digital]
[dev:69]( 10:51:14.722 am [info]( value: 0
[dev:69]( 10:51:14.716 am [debug]( description: zw device: 07, command: 2003, payload: 00

I tried resetting the entire z-wave mesh but that didn't make any difference. I've now also reconnected one outlet to my Vera and it still behaves correctly and indicates state. Excluding and re-adding that same outlet back to the Hubitat exhibits the same problem (of not showing state).
So it seems to me that there's something else Vera must be doing to read the state and that's not included in the generic outlet driver. If it helps, the Vera adds the outlet as a BinaryLight.

Also noticed the antenna seems a lot weaker on the HE than the Vera and the pairing process is much slower... not really an issue once the mesh is all set up but makes for slow setup.

I have only 2 of these and it was messy with the status until I bought it back close to the hub. Somehow the outlets didn't like or missing messages when connected to a repeater.
Don't forget to press configure, save and do a Z-Wave mesh repair.

Thanks for the tips. With one exception, these are all within 20’ or so of the hub. I am finding the radio is much weaker than the Vera for pairing though... last night I reset everything and then dragged the hub within 5’ for pairing and set it all back up again. For some reason that seems to have done the trick and, at least for now, everything is reporting correctly with the hub now back in its original location. I’m hoping it’ll remain stable now.

Don't forget to do a Z-Wave repair since the hub is not at the same location as during pairing.

These were all stable for the last 14 days but today two of them decided to mis-report state again. One shows on all the time while the other shows off. Both still respond to commands though.
I've tried rebooting the hub and performing a mesh repair but nothing seems to work. Tomorrow I'll try moving the hub within a few feet again and repairing things again. Not knowing much about the underlying z-wave protocols, I'm curious if anyone has thoughts on why this might happen; other outlets in the same location seem to work just fine still.

I had a GE fan control that did something similar (no updates, wouldn't refresh, but still responded to commands), rather than removing and re-pairing I put the hub into inclusion mode and tapped the switch a few times. Nothing registered on the inclusion screen but the switch started behaving itself after that. Might be worth a shot, although this doesn't explain why yours was working then stopped...

GE switches can be frustrating. I have over 100 and have been using them for 5 years. I experience this issue every so often and turning off the breaker for a minute or two and then turning back in helps bring it back to life. Give that a try.

These are very old devices. They have either a 200 or 300 series Z-Wave chipset. The older 200 series chips were notoriously bad at reporting switch state. The 300 series comes with newer firmware which solves the reporting issue but can still be slow to update. This behavior is due to workarounds (i.e. HAIL) to avoid the Lutron patent for instant status updates.

If you can afford it, upgrade to the newest Z-Wave plus receptacles which have a 500 series chip sets with newer firmware which offers better range and faster performance, but they also are rumored to now have firmware that provides instant updates without any workarounds.

I wouldn't have thought to do this but it worked! They're still a bit slow to update but at least they do finally get the right state. Thanks!

Yeah, I was looking at that option but it sure adds up quick... I'd guess you're referring to the GE 14288 outlet? Looks like Walmart had them at $20 each a while back but are out of stock.

If you know of other outlets that perform as well or better, let me know. I only found z-wave plus in the GE model.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.