Frustrated newbie - unable to see ZigBee devices with C7

Hi folks,

Frustrated newbie here.

I've previously used WiFi smart bulbs with a different ecosystem, but I want to scale to 30 or 40 devices eventually, so I thought taking a jump into ZigBee is a good approach.

So I bought a C7 on eBay and some ZigBee compatible IKEA Tradfri bulbs (806 lm, 105.415.02) to start with.

Steps followed:

  • Factory reset C7 and set up, updated to latest software version available
  • Factory reset bulbs into a lamp right next to the C7
  • Bulbs flash quickly for a few second, then flash slowly for a few minutes (I believe this is pairing mode)
  • I've tried starting to search for a ZigBee bulb either before or after that pairing mode starts, and I've also tried waiting 10 mins after it and even longer
  • I've tried to add a device either specifically looking for an IKEA bulb, or looking for a generic ZigBee device
  • Whatever I do, the C7 just doesn't seem to find any of the bulbs I've bought
  • I've tried to follow various troubleshooting guides both for the C7 and for IKEA bulbs

Welcome to the community!

What are you seeing on your ZigBee Details page?

Have a look at this post for info on uploading screenshots.


Hi @Ranchitat

Attached a screenshot. I assumed the null Extended Pan ID was because I didn't actually have any Zigbee devices attached to my network yet, but maybe not?

When you click on the red balloon what does it say?

The Status: should be ONLINE.

1 Like


I thought the Null seemed wrong, so I went into Settings > Diagnostic Tool > Advanced > Reset Zigbee Radio.

Then I see that after a reboot, I do have a Pan ID.

However, both before and after I reset the Zigbee Radio, the red balloon is saying "ZigBee network is offline." - even though on the Zigbee Details page, it's saying "Zigbee is enabled and is in join mode". :melting_face:

Try another Reboot with both boxes checked.

I tried the reboot with both boxes ticked, but it's behaving the same, still showing Zigbee offline in the red balloon and nothing will pair.

Version Downgrade
I was running version I was noticing that every reboot it get to about 35% and say something about updating apps to this version, then say it needed to reboot.

So to check if it was a software issue, I downgraded to version to see if that fixes it. Unfortunately not, although it doesn't reboot twice every time anymore.

Tagging @support_team & @gopher.ny ...


Upgraded again to
Still didn't work.

Rebooted with both boxes ticked
FYI I'm seeing both these statuses in the screenshots below on every reboot when I'm on I didn't see this on It feels like this is something I probably only should see on my first boot after upgrade, not on every reboot.

Full Reset

Just tried a full reset whilst on I get the screenshot below.

It is starting to sound like the radio is dead. Have you verified with the previous owner that it was working properly? (Assuming it was used.)

1 Like

It is starting to sound like you'll be making a return to eBay...

I'd stop futzing w/it and wait for Bobby or Gopher to reply.

1 Like

They've said it was working and are a 1000+ feedback 100% positive seller, so I'm inclined to believe them.

Will do! Happy to return via eBay, although I imagine they'll just be raising a warranty claim anyway, will wait for support here to advise :slight_smile:

With what? Maybe they were a Z-Wave user and never even tried the Zigbee radio. :person_shrugging:

I'm 1000+ skeptical about the seller review process on ebay.


It's not a channel issue @danabw ?

Seen a solve in a post for a C8 that resolved it.

Don't remember that, frankly...been too may topics and I have too little RAM. :wink:

That's an easy try...could try incognito mode if it hasn't been tried yet, or try Firefox, Brave, etc.

EDIT: Oops, misread, thought you said browser, not channel... :slightly_smiling_face:

But these issues look different...

No idea if this will help... but you could try going back to an even older firmware, like 2.3.5 maybe, guess it won't hurt much at this point. :man_shrugging:

1 Like

If the radio is offline, you cannot reset it because there is nothing to reset, the radio is not there. I would try shutting down the hub from Settings, then when the led on the hub turns red, unplug the hub for a minute. When it comes back online go to Zigbee Details. If it doesn't show that status is ONLINE, I suggest returning the hub.

1 Like

Hi, quick update in case this helps anyone searching in future:

Changed ethernet cable and changed power supply
It was previously plugged into a USB port of another device, I was wondering if it was a low voltage issue.
:x: Still didn't work

Tried again to downgrade/reset
:x: Still didn't work, was getting the "Zigbee reset failed" error

Tried to restore a backup
I was lucky here as one of the last 6 local backups on the device was from before I purchased the device.
After restoring it, I still had the same issue.
As a last try before sending it back I tried to do a full reset.
:white_check_mark: Then I noticed that the Zigbee Network Status = ONLINE and I'm able to add devices.

Hypothesis: updating to or doing a full reset after receiving the device must not have worked properly and caused the issues. I'm surprised that neither the updates, rollbacks, nor the full reset (before it stopped being able to fully reset) were able to fix it.

1 Like