First all my blinds stopped working and now half of my zooz switches stopped working. Not a great first few weeks with hubitat. What could be going on?

I am setting up a home automation system from scratch using all new equipment. I have a c7 downstairs in my network closet and I have added quite a few z-wave devices slowly. I have a bunch of zooz zen22 dimmers, 3 somfy/graber shades, a few plugs, 6 smoke detectors, and a lock. Probably a few other items in there. Mostly things were going well, but suddenly all 3 blind stopped responding. I had to manually remove and add them again. Now this evening, my chandelier would not respond. I tried some other switches and some worked and others didn't. I tried a zwave repair and got the following:

Stage: Re-trying Failed Nodes
Z-Wave Node 12: Repair is running
Completed Nodes: 20 21 24 11 16 1D 1F 23 07 14
17 18 19
Failed Nodes: 06 09 1B 08 0B 12 13 15 1E

10 failed nodes. I am starting to wonder if hubitat is going to work for me. I don't feel like I'm doing anything too crazy. What can I do to check what might be happening? Would having one of the zooz switches turned off at the breaker cause the whole z-wave network to go crazy? They were finishing electrical work in the kitchen and it looks like power to the kitchen sink light and disposal are off. It doesn't work with the physical button and there is no light on the dimmer nor will the light turn on in the ceiling. That's one of the failed nodes.

Screenshot your z-wave settings page, to look for ghosts :ghost:.

It could if your mesh hasn't had chance to settle or you also have ghosts it could be the tipping point.

Yes, especially if you have a weak mesh and many devices are routing through that switch and have no other route to the hub.


(1) read How to Build a Solid Z-Wave Mesh - Hubitat Documentation

(2) get some good repeaters. I suggest (and use) the Ring Alarm Extender Gen 2, which has a Z-Wave 700 series chip and internal battery backup, and can give power fail alerts

(3) install Tony Fleisher’s (@tony.fleisher’s) excellent user-contributed Hubitat Z-Wave Mesh Details app. It will show you where the issues are.

(4) and, as noted above, get rid of any “ghost nodes” (devices on Z-Wave details page with no in, out clusters) that result from failed pairings. They mess up your mesh. Search the forum for how to remove.

I have had a setup with SmartThings in the past, but used Hue bulbs. This is my first time going for smart switches over smart lights. I got ired of making sure non of the switches were off to make the bulbs work.

As for repeaters, arent each of my Zooz switches a repeater? Do I need more if everyone in the house will have a zooz smart switch? I will have about 30 in total when it is all said and done.

I installed the Z-Wave Mesh Details app. I am attaching a screenshot from both that and the Hubitat settings page.

I do notice that some of my zooz switches have 0 security while others have S2 Unauthenticated. They are are the same dimmers and models. Im pretty sure I added them th exact same way by leaving what is checked by default. Could having them on different security protocols also be an issue?

Ok, no ghost nodes that I see, so that’s not an issue.

All of your devices are Z-Wave Plus (see the 0x5E as first in cluster item).

But node 0x15 is Pending, and 0x1E is Not Responding.

Try shutting your hub down cleanly (Settings, Shutdown), wait for red light, power down (at the wall socket, not the mini USB, which is fragile, and the solder joint to the PCB can break) for 30 seconds. That’s the only way to reboot the Z-Wave radio. Then apply power, allow to reboot. See if those two devices then work from their device page, try Refresh on them on the Z-Wave Details page. Either they will clear up or may show Failed, in which case you will need to exclude, factory reset them, include.

Yes and no. If you want them with security, then I would exclude the S0 ones, factory reset, include. You only get to change security during pairing.

I wouldn’t advise using S0, it’s a more chatty protocol, takes 3x the packets.

If you don’t need security on those devices, you could exclude, factory reset, include, and uncheck all the security options when including.


No security is OK, as is S2. Many people pair all devices as no security.

S0 is not the same as no security, and typically the only time you want it is for locks or garage doors.

Um, did I say anything contrary to that?

1 Like

No, but just pointing it out for OP, who is a newer user and might not be aware of the poor naming choices between these two things.

But they really don't have any non-security things on S0, that is why I mentioned it.

1 Like

Sigh, well I shutdown as instructed and the Chandelier switch still was having issues. Well, now the actual physical switch is not working and the blue light (which by default on when the light is off) is stuck on. I tried to reset it to factory according to which is "tap-tap-tap’n’hold the upper paddle for at least 10 seconds. The LED indicator will flash to confirm successful reset"

That also did not work. Now I wonder if the switch went bad.

If Zooz switchs have an air gap you can pull that out to remove power and then push it back and see if the switch comes back to more normal operation. If it doesn't have an air gap, you could try turning its circuit off and then on again. Make sure you hub/computers, routers, etc., aren't on that circuit - they won't like being shut off like that.

Thank you. Pulling the air gap made the physical switch respond again. I initiated the exclusion mode on the dimmer and set the hub into Z-Wave exclusion. It found the dimmer but it says it was an unknown device that was excluded. The chandelier switch, which is the one I just excluded, is still showing up in the Z-Wave device list on hubitat. I tried using the remove button in the Z-Wave settings for that device and it didn't work.

Do I just try to reinclude it and hope it overwrites the chandelier switch entry? Let me try rebooting and shutting down the hub to remove it first.

As long as the hub can still ping the device (even if it is now included at a new node address, go figure), you will not be able to remove it. Do the air gap thing again so that power is removed from the device, try to do the remove again, you should be successful.

I've never understood why Z-Wave works this way with Hubitat, it just does. I shrug my shoulders and do the voodoo chants and make the necessary sacrifices.

Supposedly, you should be able to do a "Replace", which is an Include with putting the included device into any automations. Sometimes it works, sometimes it doesn't. Go figure.

I forced removed it from Hubitat on the Edit Device Settings page. I was then able to successfully include it again.

When the construction workers are done for the day, I will test the others in the kitchen. I am a little worried about stability. I need these to be pretty rock solid.

1 Like

Once you get everything included, it's a pretty stable platform. I never reboot my Hubitat C-7 unless there are firmware updates that are released. This week has been a wild ride with all the updates.

And, before all the forum members jump on me, yes, I realize that there is nothing that forces updates, but I always want to get all the latest bugs.

Make sure you have your hub on a UPS if you want stability. Make sure that you have a way to shut it down while still on UPS power if there is a power fail. You can search the forums for various approaches that people have taken. Many of those approaches require an external Raspberry Pi. To each his own. I just use a Ring Alarm Extender v2, which, in addition to having internal battery backup and behaving well as a Z-Wave repeater, also can deliver power fail events to your Hubitat so that you can shut the Hubitat down with a simple Rule Machine rule if power is not restored in some amount of time. I can post my simple rule that does this if you want.

Just to double check, is the device still listed on the zwave details page? Removing something from the devices list is a separate thing, so force removing that listing may have just removed it from the hub’s database.

Ah it was still there but I was also able to remove it from there. Thanks for he heads up.


It does get better. Things will stabilize. Glad you were able to solve this problem. You didn't mention whether your blinds were working again, etc. Hopefully, that has cleared up when you fixed the other issues.

If you have other questions, or if other issues develop, post back in the forum and someone with experience with your particular issue will try to help.

I had to force remove those and re-add as well. I just dont understand why all three stopped working suddenly after working for a week.