Firmware Updater App Update Firmware Button Not Showing


I am trying to update the firmware on a Zooz ZEN17 Multi relay using the Device Firmware Updater App in Hubitat. I have the C7 hub. I uploaded the firmware file but the "Update Z-Wave FIrmware" button does not appear. I am following the device updater hubitat document. My hub firmware is up to date and have tried a shutdown and power cycle. I don't know what to do next?

go to apps, add built in app. Add the firmware updater and make sure you click done. Once you do that it will be in your app list.

From the device firmware updater select the second button, “Update Zwave Firmware”

Then select the device you want to update;

After that select the desired OTA file

Oh and welcome to the community!

Thanks for the quick reply guys!

The problem is, the second "update zwave firmware" button is not shown in my updater app.

This one isnt showing?

Are you using the built in app or the custom one from HPM?

Yes, that is the one. I am using the built in app

1 Like

Can you remove the app and re-install it?

yes, I have tried that several times with the same result

Are you sure? Check Settings > Hub Details and see what is listed for Hardware Version. What you're seeing will happen for sure on older models, as they do not support this feature. That's the only time it should.


Thats it. It is a C-5. Sorry my mistake.

How do I update the firmware on the Zooz ZEN17 with the C-5 hub?

If you only want to use the hub (i.e., not a secondary controller, etc.), you'll need to use something like this:

For the ZEN17, you will likely need the "binary" version (for .GBL files and possibly others) from this post instead of the one in the first post:

Or perhaps this minor modification of that, which apparently fixes some issues some encountered, but I have not tested this one to say anything for sure: [BETA] Updated binary firmware updater


Ok I will take a look at these. Thanks for your help!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.