Fibaro Double Switch 2 FGS 223 - Cannot stop power reporting

Apologies. I've started a fresh post on this as I'm desperate. I have three of these devices and this morning the HE homepage reported a high number of events for them. This coincides with me switching power reporting OFF as I have on all of my devices. I've had no issues with these before (other than a stuck relay on one that I've now swapped out). I'm using the driver by @ericm

How do I stop the "spammy" power reports? I switched what I thought the relevant parameters were to 0 (disabled) as I don't use or need the power reports. This morning I got a warning on the HE homepage and when I've looked the three Double Switch 2 devices are sending events several times a second! (these appear in the device events, but not in the log)

I've tried altering the settings in the driver preferences - setting the time periods to maximum rather than 0 (disabled) and clicking save preferences then configure. The issue remains with 3 events per second per device and I guess this is going to kill my system. Can anyone help?

Due to the location of some of the modules I do not want to exclude them and start again. They are working normally with regard to switching both digitally and physically and reporting their status normally so I shouldn't need to reset. Surely the settings should be configurable.

Which parameters did you set? Looks like these 6 may be relevant (note that some are 1 byte and some are 2)

1 Like

Initially all of the parameters were at default. When adding them to my system I simply adjusted the switch type where required. A couple of days ago, on each device I set all of those options you've shown to 0 - disabled. Looking at Location Events within the logs, it's at that point that the HE "spammy devices" alerts started. I've now tried increasing them so that they're enabled but update infrequently but despite saving and clicking configure it appears to have no effect.

Edit: I've just restored the Energy level change and Power level change values to their defaults and this looks to have immediately stopped the reporting on the first device.

1 Like

Oh dear what a complete fool I am. I had the below options set to zero....which I guess translates as send a report when nothing changes. A clear cut case for RTFM

1 Like

Just for documentation and for you not feeling like an Idiot :rofl: - acctualy, setting the parameters to zero should have stopped the power and energy metering.
The problem resides on the Fibaro side. They have a faulty firmware on the FGS-223 that for some reason does not do what they wanted it to do.
In order to fix this I saw they are telling users that they should upgrade to the latest FGS-223 firmware version.
How? well, this is the fun part, you can only do it by either connecting the FGS-223 to a Fibaro hub or take it to a distributer that will do it for you.
Meaning, you first haver to exclude it from the system, disconnect the electric wires, buy a Fibaro hub (3 times more expensive than Hubitat for the light version) or pay a distributer to do it for you. Then, reconnect, include. etc.....
I think this is unacceptable.
Most people just end up setting the parameters to the largest values possible to reduce power and metering reporting, but not able to disable for good.
By the way, they could allow Hubitat to have the firmware update and use the OTA update capability in Hubitat.


Yeah setting the timers to zero does disable them. However if you read the 2 items in the pics - a value of 1 would be an energy level change of 0.01 KWh. The range is 0 - 32000 and 0 is not designated as "disabled" when you look in Fibaro's manual for the module. Effectively 0 forces it to send a report when there is no change - so it will generate that event repeatedly while the device is off or on.

I knew about the Fibaro firmware update debacle and had considered getting a second hand Control Center Lite for firmware updates but as it happens all of my modules are pretty much up to date. The FGS-223's are on the latest v3.3 firmware.

I am not sure we are on the same page.
This is from Fibaro official site's user manual:

Zero in all parameters should have disabled all reports.
My FGS-223 are not on the latest version and they do not follow this logic.

1 Like

I stand corrected. At least that makes Fibaro the idiots not me lol - what I had set originally should've worked. Never mind it's working as I want it now. Thanks.

1 Like

Just for anyone else out there suffering - I hit the same issue when I set mine to 32000 - supposedly the longest possible report.
I don't think that Fibaro are interpreting the setting correctly.
I found that setting them to 30000 worked OK - I think this may have something to do with the 2nd byte coming out at zero, but I don't care too much as it looks to be fixed now!
(I'm wondering whether this was the cause of my Z wave network being rubbish on ST, and forcing my move to Hubitat.... at least Hubitat has the debugging tools to let me find issues!!)

Do yo mean that by setting this parameter (which one?) to 30000 you got rid of ALL power and energy reporting?

sorry - I wasn't very clear - no, but it reduced the reporting to a manageable level.
That said, I've still got some that are chatty. It's hard to find out for sure whether the settings have actually been transmitted without switching the driver to Z wave Tweaker