Fan Control: Low, Med, High, Off

Is there a way to set the values for Low, Medium and High fan speed settings? I think they are 15, 50 and 100, but my fan likes 33, 66 & 99.

The slide dimmer is a bit too touchy to use with my fan, as the fan reallydoesn't like values above 66, except for 99/100.

I haven't found a way, and my workaround is 3 separate buttons with individual fan speeds set, as well as an off button.

It works, but the appeal of a single button for Low, Med, High, Off cycling is significant!

I'm using a GE Zwave fan controller.


You can on my user fan controller driver (assuming your GE fan controller device is zwave plus, and not regular zwave)... A side bonus is that it also supports the dashboard fan template.

At least it is possible to change it on my driver when controlling from HE. When controlling from the physical switch there isn't any way to change it.

If it IS a standard zwave (not 14xxx device) then you are out of luck.

1 Like

In your dashboard, make sure you pick the Fan template instead of the Dimmer template. Then when you tap on the device (not on the slider) you get a pop-up with the speed control.

1 Like

Thanks for the Driver Jason, and the tip Ryan!

All 5 or 6 of these things I have are the 14287 model, so we're good there!

It works great from my Desktop, Firefox on Android, and whatever browser is on the wife's iPad. For some reason, it doesn't generate a popup on my Android Tablet using Chrome. Not a problem, I just used Firefox, and all was well.

Love the custom speed settings! I calculated a medium-low and a medium high, but the fan seems go to high at anything above 66% anyway, and I don't really know for sure if Medium Low is any different than Medium (or low!).

Being able to define the levels is a GREAT thing. Thank You.

If you're thinking of extending this at all:
It would be nice to be able to enable or disable the speeds (e.g. only have low/med/high/off) from the settings page, such that the popup only displays the allowed speeds.

What's the "auto" speed for?

Does "on" simply default to the last set speed?

Again, thanks. This is magnificent!


Depending on how old the iOS version is, that may make sense. Older iPads/iOS releases don't support the full complement of features in Safari needed to use all features in the dashboard.

The popup on the dashboard isn't configurable. It is a 'one size fits all' template. So hiding them in the driver wouldn't change the popup options.

Auto, as I understand it, is for some fans (Hunter Douglas maybe) that have an auto/breeze feature. It isn't used on the GE driver (it does nothing if you try and select it).

Correct. ON should turn the fan on at last speed.

It works just fine on the iPad, it's the Android with Chrome that it doesn't like!

Ah, I see. Thanks!

For the record, the driver works OK with the Hunter I have (as far as I can tell, 33/66/99 ranges are all it has), but it works extremely well with the Harbor Breeze which seems to support a much broader range of set-values than the Hunter. It works so much better, that if I hadn't just replaced the old fan in the Master Bedroom with the Hunter, I'd be headed to the store to buy a Harbor Breeze!

This driver is great! Thank You.


Jason, Ryan,

Have either of you tried one of these Fan Controls with 2 fans on the same circuit?

I've one set of fans in my living room wired this way, and the behavior through the controller is odd. I'm guessing the switch is looking at current and limiting it in some way in different states. But the twinned fans now seem to have to have just three states. On low (<70%), and on high (>70%) and off.

The remotes no longer work properly (current limit?), but on the original toggle, they certainly supported three states. (Low, med, high).




That won't really work. The fan dimmer controls the load going to the circuit. So, on anything but high, it will effectively be splitting the power between the two fans and they won't spin at the proper speed. At least that is what was reported over on the ST forum when someone tried this exact same thing.

It was actually posted by frequent Hubitat forum contributor @destructure00. So, maybe he could commend on this specifically.

I had this exact problem on ST in a different thread a couple of years ago. On high, the two fans both spun at 100%. But at low or medium, they spun (approximately) ½×33% and ½×66%.

I was afraid of that. When I started thinking how the three speeds must work, I figured there must be some issue with current vs voltage for the fans when you split them (e.g. at any given voltage, the current is going to be 2x, which probably throws the controller for a loop!)

It works in "2 Speeds" right now, effectively "low" and "high". I'll have to look at alternative solutions. For sure.


That's sort of what I'm seeing too. Except I think my fans don't like the 1/2x33% mode, they effectively shut off. So really, I get two speeds, one at ~60-65% (which results in something like 33%) or so, and the other at >75%, which effectively gives me "takeoff mode".


As an alternate solution, I just ordered a pair of the Hampton Bay Zigbee in cowl fan controllers. I have a pretty good Zigbee mesh, and the room in question h as at least one repeater, so all things being equal, they ought to work OK. If they work, I'll put a Zooz Zen26 on the switch (replacing the GE Fan control) and make it "always on", then however bizarrely the fans are wired, the in cowl fan controllers will have power.

Nice feature of these is that I should be able to control the lights too.


1 Like

OK, fitted the two Hampton Bay Zigbee Universal Fan controllers today. Took a minute or five and a relocation of a Smartthings Zigbee plug, but both fans are now connected and controllable.

I ended up removing the "old" GE Fan control, and slapping a dumb decora paddle switch in it's place, which isn't ideal, but it'll do until I order another Zen26 to control the power.

I was fortunate, in that the ceiling boxes are plastic, so I was able to tuck the Zigbee antenna up into the box, meaning it isn't hanging out of the fan hood being an eyesore (and keeping the WAF factor high).

I've got a couple of the GE Smart fan things in place, and I like these Hampton Bay things so much better (so far) that I think I may replace them with the Hampton Bay ones, and fit them into the two remaining ceiling fans as well!

Why do you need a Zen26 to control power? I would put in a dumb switch so you can reset the HB units if necessary but there is no need at all for a smart-switch to control the power to 2 other smart-switches. You are going to want to keep the HB's powered on 24/7.

Short answer: Guests, Kids, accidents.

The switch is in the middle of a quad-gang, and the frequent way of finding which switch to use is to switch them all, one by one.

Longer Answer: For a short period, we had a maid service, and they couldn't resist leaving our switches in a somewhat random state. So, for lights that I program, particularly those on Hue, I tend to put a smart switch in that allows me to ensure that my "always-on" switches are actually on.

I'm really looking forward to RM 3.0 and conditionals for this purpose!

They make physical switch locks, too. Just fyi, if you want to go that route instead - much cheaper.

Then just remove the switch all together and put a blank in it's place. If someone switches the switch, the fan will be uncontrollable from HE.

Yep, good idea! However, WAF = 0. So, that's a non-starter.



Who asked her? Lol

1 Like

Yep, definitely a solution. I thought about a switch that does nothing too.

However, as was pointed out, I might want to switch them off at some point.

As for being un-controllable, yup you're right. Hence the desire for the conditional. IF the switch is off, turn on switch. Delayed action, turn on fans. Issue of course is how long it takes the fan controllers to stabilize on the network.

Its kind of a jury-rig solution to a edge condition problem, so I'll likely just leave the switch as is until I actually have a problem. perhaps sneak a label on the switch that says "Leave On", but I guess that would likely have a WAF=0 too!