Failed IP reservation leading to network problems.


Since upgrading to (at least that is when I noticed it) I have been struggling with some weird network issues. I use a reserved IP address, but the hub does not use that connects to a different one. When this happens, I can no longer access my hub outside the local network. Currently I am running the hub with no reserved IP and it seems to be working normally for now. I had assumed this was an issue with my router, but I switched to a different router and the problem is the same.

Any ideas?

Is the hub set to DHCP when reserving an IP?


That seems... odd. Can you post a snapshot of your networking page? Under the settings tab? Make sure there's no PII in your post :slight_smile:

Yes, it is!

Here are the network settings. Is there something I should try?

By the way, sometimes when I boot the hub, it cannot be found. The find hub tool shows an IP, but then I try I get no response. Another restart will usually result in the hub getting an new IP address and being accessible. Good lord this is frustrating!

Thanks for all the help.

Think it is worth a try going to the previous platform version?

Hmmm I mean I wouldn't rule it out but this seems more like a networking/router/dhcp kinda thing. If you look at the router's DHCP table does it have two entries for the router, one with the old reserved IP and one with the new one? And are the MAC addresses of the two entries the same?

I know you said you tried swapping routers but did you swap for a different brand or just a different router of the same kind? It almost seems like some sort of communication issue between the hub and the router. Timeout, reconnect, bad cable, speed negotiation, something like that. Or I could be totally off base.

You could try a ping test either from the hub out or just from a workstation and ping the hub a hundred times or so... see if the connection looks solid. Not a definitive test by any means but certainly if it shows errors that would point to some sort of connectivity issue.

Your other option is to just use a static IP on the hub. Absolutely should not be necessary, but would take DHCP out of the picture. If you decide to go that route I would make sure you choose one outside of your router's DHCP scope so the router does not re-issue the IP you've chosen as your static IP for HE.

Thank you! I think I may have found the issue or a contributor. My hub was connected via an old router that had been reconfigured as a wireless access point. It had been working that way flawlessly for several months. I checked the configuration of the WAP and although it was in access point mode, for some damned reason DHCP was enabled. Very strange and I have no idea why. Obviously this is not definitive, but I am not going to make any other changes for a while and see what happens. Make sense?

Absolutely. If its DHCP server answered the request first and issued a new IP that would be a problem. You might be able to look at its DHCP clients table and see if that's what it did.

1 Like

Thank you for the help. Things seem to be working better except for the fact that I am no longer getting any notifications. That must be a different issue. I tried sending a test notification in the mobile device, and nothing.....

It may be a different issue but I wonder if it's related. Is your HE connected to the Internet? If you don't have any cloud integrations to test you can try checking for a new firmware version and seeing if it responds.

I assume if your router is in AP mode that means it's basically a bridge and not doing any NATting. Double-NATting can cause weird issues.

That is correct for the AP. I have verified that the hub is connected to the internet, both by checking for an update, and by making a change with my phone through a cell network.

I did try sending text from the mobile device page, and the logs say it went....but my phone did not seem to get it. Please let me know if you more ideas and thanks again!

I just sent a test notification to be sure the problem was actually not more global. Went through fine. I wonder if since you took that second dhcp server out of line a reboot of the hub isnt in order... just to "normalize" the network stack etc.

1 Like

Good have been rebooted a number of times with no change in notification. Still Weird!

Out of curiosity, and I have no idea whether this has any bearing at all, if you go to and look at your hubs there, does the Ip address that Hubitat thinks is your hub match the IP of your hub?

Yup, it is the same!

If you go to the iOS app, go to settings, is the info correct? Device name should correspond to the device on your hub, hub name should be the same, etc?

It is an Android. However, I deleted and reinstalled the app and now notifications are working! Thanks again for all of your help.

1 Like

Perfect. I bet somehow the address changes got the mobile app association confused.

Now just make sure your hub reverts to the right IP address and stays there :slight_smile:

Well, something is still wrong. The AP config might have been a red herring. I tried on the new router to reserve the IP address. It entered fine, but I asked to assign and the hub showed up on Same problem, new router. Arg!