Fading night light help

Hi,
I'm trying to set up a nightlight in my little one's bedroom that would fade to 0 over time. However, the following rules turn on the light to the corresponding color but do not fade. I've tried it with a 30 minute delay and shortening the fade time to 10 minutes and still no joy. Any advice?
The bulbs are hue bulbs brought in through the hue integration and the switch device is an inovelli red with scenes. I'm using the button controller app but have tried in rule machine and basic rules with no luck there either.

Do you see any errors in the logs?

I just tried one of my hue lights (from the device page). Dimming up in 10 seconds works, but down turns it off immediately. Is this what you are seeing?

I'll check the logs when the little one goes to bed tonight. I'm laid up on the couch right now and can't do stairs.

The light comes on but does not fade to off.

I’ve setup a similar rule in RM to test this and am seeing the same - It doesn’t dim.

Nothing in the logs except showing the rule has run (with all logging):

@bravenel, any ideas?

What is the initial level of Dining Room Light 1 ?? Before the Fade over time.

In my test, it was set to 100% (Prior to running the rule).

Based on your question, I changed the rule to the following and it works:

I'm not getting the "interval parameter" in the button controller app.

Here's the log when button 4 was pushed (four up clicks). disregard the top entry as my wife turned on the lamp with the hue button/switch. but notice the "fade" command did not initiate.

I've been able to fade lights to off (zero) using the motion app.

Hi @bravenel, would this explain my problem. 3 of my different rules which used a dimmer variable as a trigger wouldn't run when the value hit zero? 2.2.7.123 issue
PS, I've re-written these rules as a carbon copy and they all work as expected in the latest version

I just tried using the device page and used the "push" command (button 4) and got the following:

Do you know how to setup a button in RM? Setting them in RM instead of the button controller app provides the same “look & feel” but more functionality. It will allow you to set the “interval parameter” and based on my small test, I would assume it would work.

I prefer setting them in RM myself to have access to that extra functionality.

Sorry, I missed that this is Button Controller. I'll check that, although it's about to be updated...

You might try putting a 1 second delay after setting the light. There's a chance you have a race condition where the Fade action is grabbing the light level before the Set Color has taken full effect.

Set Color: WOW lamp ->Purple ->Level: 25
Delay 00:00:01
Fade WOW lamp down to 0 over 45 minutes

See if that works. The hub is multi-threaded, and in this case the thread running the app is faster than the device is to respond to having its level set.

Download the Hubitat app