Everything Xbee

Yes...it just took me a while to get it to work. Had to clear back to baseline a couple times.

1 Like

I received my xbee pro and xbee explorer usb today and am trying to get started following the guide in the OP. In XCTU, when I click the + button to add a module, the dialog doesn't list any serial ports to select, but if I choose the magnifying glass option next to it, it does show up. Searching that way, it finds the xbee, though it detects it at 9600 baud instead of the 115200 recommended here.

Assuming that isn't a problem, I try to proceed with updating the firmware, but when I click on the xbee in the left column, I get a message that it couldn't find a fimrware for the device. It offers to update the firmware library, but still doesn't find a firmware to install.

Where did I go wrong?

Do you have the windows driver installed for the xbee?

The explorer USB was detected and installed as a USB Serial port, using an FTDI driver. Is there a driver for the Xbee itself that's needed beyond what was included with the XCTU install?

I ran xbee recovery, and that seems to have loaded the firmware successfully. Now after removing and re-adding the device in xctu, it shows the name as something other than just '1003' and gives me a UI to work with.

I can confirm that these settings work on a DIGI XSTICK2 ZB with 23A7 router firmware.

I had everything setup in HASSIO and Windows, but wanted to get it on my Linux laptop so I could wander about and diagnose weak links. I had one Zigbee plug routing a bunch of traffic. It had been outside for Christmas lights and when the lights came down....everything broke and wouldn't re-mesh.

In order to save someone 2 hours of Google.....Do these steps:

  • Install XCTU from Digi Website
  • Click on "Tools" -> "Firmware Explorer" -> "Can't Find Your Firmware? Click Here" -> "Install Legacy Firmware Package"
  • Use the 23A7 firmware
  • Apply those settings I mentioned. Key settings are Encryption Key and Name. The firmware should already be set for router mode.
  • You may need to install a couple extra libraries via apt to make Java happy with XCTU.....so there may still be Google in your future.


Out of interest, has anyone seen their HE PAN ID change, and this lose all Xbees?
Mine had changed, no idea how, and all zigbee devices routing through my 3 Xbees also dropped.

Had to reprogram, and re-pair and now all ok again. I suspect this isnt the first time its happened either.


@Royski I have never noticed the HE PAN ID change honestly never watched for it.
But if it did I have never lost my Xbee3 from it.
Was it after a Hub update?
The only time I have had to reprogram is my micropython after a Xbee3 firmware update.

1 Like

Hello, with my xbee network scanning my devices, I see in XCTU on repeaters, "validation underway" but it rarely completes to "Active" The devices work fine and show an Okay LQI in XCTU.
The pain in the arse devices are you guessed it !! The aqara dual relays.

Is XCTU reading that from the aqara, or is that internal to XCTU, because Xiaomi lives in their own NON-standard world?

are they connecting through other routers or directly to the hub?
They likely connected through that router device at one point but then choose a different route.

the AQ relay is direct to the hub. The devices under validation are directly connected to the AQ relay, not through any router.
It was mostly a curiosity, network is performing well, well outside of a single xbee that refuses to connect.
On a sperate note...
Can anyone decipher the messages below? 2321 is the xbee that won't be discovered by HE, and i can't scan the network. It's an Xbee pro 3 SMA, that was connected to HE and fell off. I know others have had this issue, and not sure where in the 830 messages, does the solution exist.

dev:23212020-03-16 06:20:22.403 pm debugskipped description:catchall: 0000 8001 00 00 0040 00 5DBE 00 00 0000 00 00 AA0083F06A10006F0D007547

dev:23212020-03-16 06:20:07.950 pm debugskipped description:read attr - raw: 5DBE0804000A000021AE03, dni: 5DBE, endpoint: 08, cluster: 0400, size: 0A, attrId: 0000, encoding: 21, command: 0A, value: AE03

dev:23212020-03-16 06:19:54.952 pm debugskipped description:read attr - raw: 5DBE0804000A000021B505, dni: 5DBE, endpoint: 08, cluster: 0400, size: 0A, attrId: 0000, encoding: 21, command: 0A, value: B505

dev:32742020-03-16 06:19:41.251 pm infoPlug Washing Light current is 0.32 A

dev:32742020-03-16 06:19:40.244 pm infoPlug Washing Light voltage is 124.54 V

dev:32742020-03-16 06:19:39.253 pm infoPlug Washing Light power is 40.63 W

dev:32742020-03-16 06:19:38.263 pm infoPlug Washing Light energyDuration is 131.84 Days

dev:23212020-03-16 06:19:37.945 pm debugskipped description:read attr - raw: 5DBE0804000A0000216803, dni: 5DBE, endpoint: 08, cluster: 0400, size: 0A, attrId: 0000, encoding: 21, command: 0A, value: 6803

dev:23212020-03-16 06:19:34.445 pm debugskipped description:read attr - raw: 5DBE0804020A000029C308, dni: 5DBE, endpoint: 08, cluster: 0402, size: 0A, attrId: 0000, encoding: 29, command: 0A, value: C308

dev:23212020-03-16 06:19:31.951 pm debugskipped description:read attr - raw: 5DBE0804000A000021F205, dni: 5DBE, endpoint: 08, cluster: 0400, size: 0A, attrId: 0000, encoding: 21, command: 0A, value: F205

dev:18652020-03-16 06:19:18.699 pm debugBreezeway Light off

app:17672020-03-16 06:19:18.677 pm infoTurn On Breezeway Light when Motion Breezeway Hue 2, Motion Breezeway Iris active anti-Turn On

dev:26012020-03-16 06:19:10.928 pm infoPlug Zooz Wash Machine energyDuration is 201 Days

dev:25052020-03-16 06:19:09.887 pm infoPlug Addtn Power energyDuration is 209.05 Days

dev:23212020-03-16 06:18:59.722 pm debugskipped description:catchall: 0000 8001 00 00 0040 00 5DBE 00 00 0000 00 00 A90083F06A10006F0D007547

Because it is already paired to the hub. How can you discover it again when it's already connected? The fact that you have catchall messages in the log means that it's connected and receiving messages from the board. Is it an end device or a router?

Thanks Ryan.
It's configuered as a router. I took the config from my other working xbee3.
I say not paired, as it wont scan the network from XCTU-says error discovering neighbors. I had to manually type in the 16 & 64 bit addresses, after it would not be recognized by HE.

I was curious what the payload in those messages was "trying to communicate"

Do they both have the same name? The NI value in XCTU.

There was a note that we had to change that if we were going to use the same config on multiple boards.

No they do not. I saw that tip about avoiding same name and they are uniquely named, based on home location.

I just checked and had a thought. It seems my other 4 xbees are all directly connected to the hub, so possibly the xbee must be joined directly to the hub, and I have 21 currently connected directly to the hub, so did I exceed some limit on directly connected devices. I thought i read 32 was the limit or maybe that was ST?

@Rxich what are your settings for these on the Xbee3 that will not join?

JV = 1 (I changed to 0 after pairing to the hub to keep the Xbee on the same channel after power cycling I have never seen it change but just to be safe)
JN = 1 (optional but device appears faster in the network digikey recommends not enabling on a large network but does not define large network I enabled it and works for me)
KY = 5a6967426565416c6c69616e63653039 (standard home automation key)
(but will be blank after you write and try to read again it is a write only option for security)
AR = 6 (I found that setting this rebuilds networks if the last router is not found)
Hubitat zigbee PAN id
SC = 7FFF (default setting) scan channels if having trouble pairing your Xbee try changing this to your Hubitat Zigbee channel in Hex. I use channel 20 so i would put in 14.

Nope...i have one that routes through other repeaters.

You have 21 that are directly connected to the Hub?!? Are you sure? I show that all of my repeaters are "connected" to the hub but when I look at the connection details, it says "inactive" next to the coordinator for several of them that are furthest from the hub. So, I don't think all my repeaters are going directly to the hub all the time.

Thank You !
Mine mostly match yours, with exception of course on the HE PAN ID.
and my AR=FE, so I'll try the "6". I also will try my SC set to my channel of 25

channel 25 I found in general did not work well for some devices
I found channels 15, 20, or 21 worked the best for me
but if channel 25 is working for your other Xbee3 then it should work fine for that one as well.

I believe so, based on the below, but honestly I'm no expert, by ANY means

And the other odd thing, even tho the xbee is sending messages to HE , the readout in XCTU says no network or channel associated