Everything Xbee

Yes, different name. The only repeating devices on the network are 2 Ikea plugs and 2 Ikea repeaters.
Also seems that newest 1009 firmware won't work DTH. [error]groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.lang.Long#minus. Cannot resolve which method to invoke for [null] due to overlapping prototypes between: [class java.lang.Character]
On 1008 firmware for now.

Are the Xbee3 dropping Ikea plugs or other devices?
If so what are the devices they are dropping.
I have not updated to 1009 but have seen that the mico python gets corrupted when updating to new firmware.
So the mico python may have to be reloaded.

I just update two of my Xbee3 pro to firmware version 1009 and it did corrupt the micro python again.
I reloaded the micro python and power cycled (reset should also work) the Xbee3 and it started working again.

for the groovy error
Also you may have to go to the device settings and

  • select configure
  • select save preferences

I have 3 Xbee 3's here. The first 2 I have paired to HE without issue, but the 3rd is being a pain!! Navigating to the http://hub_ip/hub/zigbee/getChildAndRouteInfo I can see that this Xbee is connected, although not properly, as it wasnt found by searching for new devices, so I've been unable to name it in HE etc, but it is there.

[null, 6DC3], LQI:255, age:3, inCost:1, outCost:1

Route Table Entry
status:Active, age:0, routeRecordState:2, concentratorType:High Ram, [null, 6DC3] via [null, 6DC3]

I've tried powering the Xbee down, rebooting my hub and searching for devices before powering it up, but HE never ever finds it, and low and behold it pops up again in the results in http://hub_ip/hub/zigbee/getChildAndRouteInfo

Does anyone have any suggestions on how I can stop this connecting and be found when searching for devices?


Is the device listed in the Zigbee details page? If so, I would remove it there, reboot the hub once and then try to pair the Xbee again.

Are you going through a repeater to pair it in place? I have seen this behavior once before when the repeater was at its maximum number of devices in the routing table. Doesn’t mean it is your situation but possible

You could also try to pair it close to the hub to see if you get a clean join

1 Like

Sadly not, part and parcel of my issue really.

No, its around 8ft away from my Hub.

My issue is its connecting without me really wanting it to, until I pair it that is.
I've also reset it, reprogrammed etc, etc. Its driving me a little mad :crazy_face:

I saw once an attempt from Mike to deal with phantom Zigbee devices. His idea was:

  1. Join a new Zigbee device successfully
  2. Factory reset the device without removing it from Hubitat
  3. Change the DNI in the device to the one that is not listed, it is 6DC3 for you
  4. Change it to the “Device” Driver
  5. Go into the device and hit the “Get info” button
  6. Now remove that device from Hubitat

He said it theoretically should work, admitting that he had never tried it

1 Like

Try reset to defaults in XTCU and then reprogramming the bad Xbee3 as an end device (change NI as well can't hurt) and pair it to the hub. Then remove it from the hub devices
reprogram it as a router (change NI) pair it again.

You beauty!! I hadnt thought of that.

I just added a "device" called Xbee Ghost with the DNI 6DC3, and then powered up the Xbee.
Searched for devices, and bingo! It found the device, I then removed the Xbee Ghost.

Cheers Dan, this was driving me mad :slight_smile:

1 Like

Glad that it worked!!!!!


Hey guys, I finally got around and posted my remix , and new designs for the Xbee Grove dev board case on Thingiverse website. (Remix) of the Xbee Grove dev board case by Morpheus2001 - Thingiverse

The original "base" is not my design, but I did a lot or redesigning to add different options for mounting as well for an antenna option.


Just got my Xbee gear ready to do a map, but now the download of XCTU is sooooo agonisingly slow. You'd think Digi could afford some decent ftp servers......

just tried the download from work it only took about 10 seconds for both windows and mac
XCTU v. 6.5.0 Windows x86/x64

Wow good for you, here in Australia right now I'm chugging along at at about 5-10KBps! To compare I started a download of raspbian at a staggering 2MBps!

With the Raspbian you're likely downloading from a local mirror.

Download sorted, looks like some kind of ftp data throttling at my local level.

1 Like

Throttled down to that speed is brutal! Nothing worst than watching a slow download.

1 Like

Indeed, VPN is your friend in this case!

Having mapped out the mesh it's pretty painful to have to refer to the device address (which changes everytime they are re-paired) or the mac. Is there a way to name the mesh nodes in xtcu based on the macs?

1 Like

unfortunately no
You can submit a request in XTCU under help and provide feedback
I submitted a request for this a while back
but if more people request it maybe they will implement it.