Everything Xbee


#528

have you updated the firmware on the Xbee and what kind of usb board are you using?
Is it connected to the PC when you are trying to join it or remotely?
If connected to PC have you tried rebooting your pc then joining?


#529

Has anyone tried this that's having problems adding it to HE?


#530

I did update firmware (1006). I have not rebooted host computer. It seems like the Xbee3 still thinks it's part of mesh. According to Xbee3 manual, I need to either break out the commission pin (to a button, or just short it, which is DIO1 according to XCTU), or issue a command in it's console to get it back into join mode.

Will try something tonight.


#531

I would try this first
If it is showing up as part of the mesh in the scan then it has already joined just Hubitat didn't add it.
I had it happen once and I am overly paranoid worried that it would not work correctly.
So I actually set the Xbee settings for an end device (see first post) and then put hub in pairing mode and added the Xbee as an end device then removed it and reset the settings back to a router and readded back to Hub.

But that was a long time ago and it was a pain. I think just using jrfarrrar suggestion and leaving it or then deleting it then adding it again would be faster. You will know that it worked for removing the device if after you create a device and add the address's then delete the device and you then do a XTCU scan (before trying to add the Xbee again).
The scan should not see anything other than the Xbee.
Then put the hub in pairing mode and add the Xbee again.
(to be clear you should not need to change the Xbee settings to an end device if you do it this way)


#532

will have to try that tonight. I'm remote, and for whatever reason my Xbee3 module now requires me to hit the reset button every time I add it to XCTU now. =( Not sure if it's 1006 or not.

I can't get it deleted from HE because it's already been deleted. The Xbee still thinks it's part of the mesh though. I can't find any way to send the command to the xbee to forget it's network, or restart pairing. But again, remote, and can't get it back into console without readding. =(


#533

I see what you're saying though. Add a virtual device and plug in its info to that Virtual Device, then delete it from HE and see if that gets it to actually leave the network?


#534

yes exactly I never narrowed down the cause (I suspected computer reboot fixed it) and it was a long time ago and only happened once. I have 3 different usb adapter boards and 4 Xbee3.
Also double check your Xbee settings a mouse wheel scroll can easily accidentally change one of those settings.


#535

I've done a couple reset to defaults. and then repopulated. The issue is the list of config variables provided only lists those to change, not all of them. =P


#536

@bertabcd1234 thanks for the link I missed that thread. Would be great if they get that working. Doesn't work for me (yet).

I had asked Hubitat if there was anyway for me to use the Xbee in place of the zigbee/zwave usb stick on the hub similar to how they have done it for UK zwave sticks in case the usb stick ever died and to give me a stronger zigbee signal/longer range but they say I could not do that.
I tried but could not get working.
Will be great if they add device mapping directly to the hub though.


#537

It's a ghost device in HE. Leaving the xbee off power and HE will delete the ghost device nightly or you can try flashing your xbee and hope it will join with another ID.


#538

negative on flashing it. I didn't completely power off last night, so it may have stayed that way.

I'll try readding via the virtual device route, or just leave it powered off tonight.


#539

Don't give up, mine didn't work, then today it works. Didn't change a thing. Not sure what's going on


#540

Same here. It's working now after reading your post. Weird......


#541

weird. came home, fired up XCTU, and it immediately went into pairing mode with HE. Got it paired, and it's behaving MUCH better.

Still didn't finish the "Initializing" stage in HE when pairing, but it shows up as a "Device" and allowed renaming. It found many of my end devices quickly, but it still seems like it must have to wait for the Xiaomi devices to checkin before it finds them (maybe that's normal for battery devices?) Within 3 minutes it's found 25 of my 31 devices. I think the remaining 6 are all Xiaomi window contact sensors, but I haven't checked.

Is there a way to export the scan in some way (so I can then crossreference)? I also still don't get the notes over the lines between peers.

Lastly, what causes the module to now need a reset every time I fire up XCTU?


#542

Strange, mine is too. I didn't change anything and have tried a dozen times before.


#543

The hubitat zigbee routing page is working for mine as well but it is missing some devices.
Looks like if a router is going through another router all the devices on the last router do not show up and no cool map but it has all the names of the devices.
Pretty useful for people starting out.

@staze
have you tried rebooting your pc?
If that doesn't fix the constant Xbee resets then it is likely the usb adapter you are using.
For exporting look at XTCU tools and export table will export to note pad.
Notes over the lines are signal strength for transmit/receive "?" is on end devices because they only transmit.

I haven't had any devices including any of my Xiaomi devices fall off in many months.
I did remove/upgrade my old GE zigbee switches and my iris 3210 plug a month ago.
I could make them work if added after all the Xiaomi devices were paired but not worth the headaches and a good excuse to upgrade them.
I also changed my 2.4 WiFi channel away from my zigbee channel months ago.


#544

Thanks @NoWon. Can you elaborate on this? Maybe a screenshot? How do I see this list of all the devices?


#545

to be clear the names are only in Hubitat's zigbee mapping not Xbee XTCU

XTCU -tools -export table
exports to notepad and looks like this with just the hex address's (no names)

Hubitat's (with device names)
https://your hub's ip/hub/zigbee/getChildAndRouteInfo
looks like this

as you can see atleast with mine less devices are reporting in Hubitat's.
Still very useful and easier to read.
This will differ for everyone of course some people may see them all depending on how your devices are routed.


#546

I need some help as by Xbee cannot find any Zigbee devices and I cannot figure out why - I am a newby...

I have two Zigbee networks, Xiaomi and HE. I am at this point interested in getting the HE mapped.

The hardware I use is XB3-24Z8ST and 76000956 (Digi Xbee Grove Development Board) both bought from Mouser.

I have XCTU installed and have the radio module identified and have made the configuration the same as at the start of the thread. You will notice I am now on firmware version 1005, I have tired 1006 but it has the same results as 1005.

I have initialized the device in HE and have the same result as many other, it initializes but you have to go into the Systems Settings --> Zigbee to find the device and give it a name. ie. It is known to HE.

I can confirm the the details in the config file after commissioning match those of the HE hub (that is the the PAN ID's - OP and OI). And the channel in HE is 19 and in Xbee 1C (CH). I also have the KY key set as at the top of this thread.

So all seems in order.

Now when I start a "Discovering remote devices" nothing is found even if I leave it on for some hours. The HE hub and Xbee router are very close. I have tried many many times on firm ware 1005 an 1006.

Anyone have any suggestions, thanks. (sorry for all the attached data but it may help)

Here are the details

  1. Xbee initializing in HE
Summary

  1. HE Xbee device information
Summary

  1. HE Hub information
Summary

  1. Xbee configuration
Summary

  1. Xbee discover process - that never finds anything
Summary


#547

To map your zigbee mesh, click on the Network mode icon (top right corner, IIRC). Then click the scan button. I think the discovery you detail in your step 5 is for finding other Xbee type devices.