Everything Xbee


#467

Tip -to view wireless xbees(included in zigbee network but not connected to PC) just double click the icon for the xbee in the map-see attached PIC


#468

That did the trick! Thank you! To clarify for anyone reading this, I wrote my Hubitat hub's "extended PAN ID" as the "ID" parameter for the Xbee. (I'm not an expert, but my understanding is this: setting that will cause it to only try to join networks that match that ID. I had it previously set to 0, which should let it join any open network and by my understanding should certainly include the hub I had in discovery mode, so I don't know why that works, but I'll take it.) The rest of my settings were as mentioned by @ogiewon above (this time around...I knew someone had a post like that beyond the two I was able to find with a search, and that was it!).

Thanks to all. Now to figure out what to do with the thrid Xbee I ordered (and has already shipped) just because I convinced myself I messed this one up beyond repair. :laughing:


#469

I’ve had an Xbee pro for a good while now and all my Xiaomi and Zigbee battery devices were working great until recently. Most Xiaomi devices keeps dropping off.

I’m more a user than tweaker but I recently plugged my Xbee into computer and when I do a scan, it prompts with “Error discovering neighbors of “xxxxxx” (Xbee MAC address). Cannot find the local device “xxxxxx” address. Remove it from the radio Modules list on the left and additional again.

I think I’ve done it all, rebooted it, reset it etc.... anyone else encounter this?


#470

I saw this on earlier Xbee3 firmware when I was playing with the settings and the unit became corrupted. I had to reset and reprogram the Xbee but I have not seen that in quite awhile.
Make sure you update your firmware.
A power surge or brown out could do this as well all mine are on battery backups.


#471

I've resetted the device, reentered your inputs, rebooted Hubitat. Firmwar at 1005. When I went to pairing mode, it picked up the XBee almost instantly, but it just hangs in initializing. When I look on the Grove board, the yellow lights blinks occasionally and the red goes on and off and repeats the pattern indefinitely as if rebooting over and over. Could my Grove board be damaged?

I don't want to give up, its fun yet frustrating. Just want to move all devices to Zwave and be done with my Zigbee nightmare.


#473

have you tried rebooting the computer?
Then resetting and programming the Xbee
could be something on the com port causing an issue


#474

Ya tried everything. I even went back to 1003 firmware to try.

Will try again later today after family activities. I plan to try on my desktop as I used my notebook before.


#475

So here is an odd one. I have 4 xbees, and since day 1 the cheap s2c(non pro- XB24CZ7WIT-004) is consistently picking up more devices, with an almost perfect LQI(9 clients at lqi255 & 2clients at 254 LQI). My 2 xbee3 pro's with a 3 dbi sma antenna do not have similar LQI's. I even tried moving them around the house thinking it was an environment issue, but no. For what common settings exist, I have them all configured the same.
I even tried a bigger 5dBi antenna with no change on the xbee3 pro's.
Anyone has an idea or similar experience? Possibly the lower power s2c has a higher sensitivity to the weak zigbee device signal? I don't know but at this point I'd say don't waste money on the xbee3 pro, unless you need a zigbee signal 1/2 mile down the road.


[Release] Xiaomi / Aqara device drivers
#476

yup, see my post above yours ( # 460) I just went through this.
What is your model number?


#477

I’ve got the following Pro version. XB3-24Z8ST I use an external Antenna.

I tried resetting the Pro version etc.. to no avail. Funny thing, this Pro version worked great initially. It routed everything I threw at it since I had over 40 Zigbee battery devices. This Xbee was such a benefit I went out and bought another, but not the Pro version..

Luckily I did not reset the non pro version and powered it up and is now routing good. When I get some time, I’ll tinker with the Pro version to see if I can get this thing routing and scanning again. Hopefully it didn’t go kaput on me.


#478

Yes that's the one I have. If you'd like I can share my config, you could just upload to your device and change PAN ID to match your hub.
PS- only 2 of my xbee show as device in hubitat, but all 4 are included in the mesh and route messages even without being listed as device in hubitat


#479

I've got a really strange zigbee network. There must be a router in my network that eats up endpoints. I have at least 12+ endpoint devices, but only 4 show up in my Xbee scan. They all work, they all function OK.

Could it be a driver issue? Or just bad device? I have no Xiaomi sockets (i removed all of them). I have moved all my lights to the Hue hub, so no bad lights either. Only zigbee light switches (which I cant turn off to test).


#480

How many scans have you done? I have a Sylvania LED strip whose children will not appear for 30 to 40 scan cycles.


#481

Yeah, I have scanned it >40 times. Nothing more ever shows up.


#482

Your xbee will get kick off the HE mesh if it's not on power and you reboot the hub. It was a pain but at the end I managed to get all 4 of my xbee added to the list.


#483

None of my three have ever joined as a device, but that's okay. My OCD can't handle devices that don't have activity. Heck, I even keep my virtual switches warm with a daily refresh. :crazy_face:


#484

Don't worry. You are not alone. :joy:


#485

Hi all
Not sure if anyone knows the answer to this, I have the 3 button grove dev board with my XBee module sitting on it and was wondering what the commission button does and when is it used, if at all?
I’ve had a look over the manual for the XBee and it looks like you can press the button to add new devices to the zigbee network. Have I interpreted that right? Does pressing that button make it easier for a new device to associate with the XBee? As in, can you press the button and add new devices without needing to do device discovery from HE?

Also when do people generally use the reset button or user button?


#486

So, I tried to wire my Xpee 3 up in my garage to act as a repeater for my ST arrival sensor. It seemed to work for a couple days but then just stopped. Obviously I can't run any scans of it while it's out there, since I don't have it hooked to my PC. When I pulled it down and brought it back to my PC, I found that it was still on my HE zigbee network because I was able to map the network immediately. And if found all my devices including my arrival sensor just fine. I'm wondering if anyone knows why that might happen.
Also, I've noticed that even if I have the Xbee powered on, nothing ever repeats through it. Even if I add a zigbee device to HE while the Xbee is on and the device is right next to it, it never joins through the xbee. I'm able to map the whole network and the Xbee shows up in XCTU as a repeater. Now, in HE it only shows as a device. Do i have to assign a different driver for devices to repeat through it?


#487

Chiming in here as I've been following and using this for a while. First, this thread is awesome and really provides all the details needed. It's also long. Months ago when this thread started I ordered the parts from the original post. Ordered 2 of the ebay boards and 1 of the xbees with external antenna XB3-24Z8ST. Then just recent purchased one of these (thanks for that link BTW)

I have the original attached to the computer which is at a far end of my house. It's in a small plastic box and double sided taped to the back of my monitor with the antenna sticking up. Honestly, this can talk to everything in my entire house with the power it has. However I just added the 2nd one in my garage which is at the other side of the house. In a post above it mentions that you can actually talk to the 2nd one without it being connected to the computer through XCTU which is absolutely correct (and the reason I ended up getting #2). Now I can map the entire network and talk/update both units with only 1 being connected to the computer.

I bring this up because I saw a few posts about not wanting to put them in places that's it's hard to connect a computer to them. You don't need to. You do need 1 connected to your computer, then the others can be adjusted controlled remotely. You do need to attach them to your computer for initial setup, but that's it. Just hoping this helps someone else.

Now if we could just get a solution similar to this for zwave to make it this easy...