Every single Z-wave device I try to add gets stuck on "initializing"

It just sits there on initializing, the page freezes (the "stop z-wave inclusion button no longer works).

And that's all it does. I am constantly restarting the hub, trying to exclude then include to see if it takes the device. After like 15+ tries it sometimes works, other times it just never works.

I'm bringing devices within feet of the hub, seems to make no difference.

This can't be normal.

Definitely not normal. :slight_smile: What model of hub are you using, and if a C-7, are you pairing devices with S2 security? Since you're new I might assume so. The C-7 and its Z-Wave stack are somewhat new, and some people do have issues with at least some particular devices. Here's one example where staff have noted a problem, though there are only workarounds for it at the moment:

For other devices, here is unofficial advice that may help for some devices:

Finally, assuming you are trying S2, if you don't care that the device is securely included, then you may wish to consider pairing without it at the moment (many people do this for motion sensors, dimmers, and other devices where they don't care; this would not include things like door locks or garage door openers, which probably won't even pair without at least S0 even if you tried). You can do this by unchecking all the S2 and S0 options when pairing, though also check the manual for the inclusion procedure if there is anything different for "regular" vs S0 or S2 inclusion (I haven't seen this with S2, but all S0 devices that also support "regular" pairing have a different inclusion procedure, like tapping the device button a different number of times--probably not likely anymore). "Regular" inclusion tends to be far less problematic, though Z-Wave is still sometimes a bit finicky.

My guess is this will get better in the near future as more people use the new C-7 hub and new Z-Wave stack with more devices in the wild, allowing them to identify and iron out issues that were not apparent in testing.

Running the C7 hub, and it has the same behavior (of stuck on initializing) if the device supports S2 or not.

For instance I just tried a First Alert ZCombo, stuck on initializing. Also tried a ecolink Z-wave motion sensor, same thing.

Also, if I click on logs in the z-wave settings, it doesn't show anything. Just a blank page. Not sure if that's normal either.

I've now paired 72 devices to my C-7. I had a few get stuck - mostly S2 issues - but not many. I only have 5 or so S2 devices. Probably 60 or so of the devices are GE/Jasco switches and dimmers.

When you reboot, are you just rebooting - or shutting down, pulling power, then booting back up?

For me just rebooting without doing a shutdown/pull power was enough to get things going again. But I know some others indicated that pulling power after a shutdown helped as well.

Other things to try are shutting down any other zwave hubs ((or moving then physically farther away from the C-7) to reduce interference - at least while pairing. You shouldn't have to do that normally, but what the heck?


My GE/Jasco switches are having the same behavior of stuck on initializing. S2 enabled or not.

I have only tried pulling power once, usually I am just rebooting from the device.

I have no other Z-wave hubs operating. Already killed the smartthings hub after I went around and excluded every single device.

I have a GE switch like 10 feet from my hub that I finally got paired earlier, then it just randomly disconnected, and seems to not be able to reconnect. Refreshing just says not responding.

I don't know if its some strange mesh issue? When you exclude devices they should lose whatever mesh devices they were attached to before, shouldn't they?

I'm hoping when it says "clusters" and these devices have a long list of things, that isn't other Z-wave devices they are somehow connected to.


No, it shouldn't be.

Same. I've been getting them paired by rebooting nearly every switch (mostly GE switches as well), but when I run a Network Repair a few nodes fail. All in all not a great introduction to the platform moving over from ST. All of mine are apparently non-S2 switches as I've only been asked for the key for two switches.

What I've found works is initiate inclusion on one switch, sometimes it'll let me do two. Let it sit for a couple of minutes. Reboot through the interface. Then go back into inclusion and include them again (without excluding the switch). If a switch won't pair at all I have to flip the breaker, shutdown, and physically unplug the hub. So annoying. And I've been running a network repair every 20 devices or so, which takes an hour so to complete.

Just finished with 55 zwave and 80 zigbee devices. I too found some of the zwave devices (especially switches and fans) problematic. Mostly, it was just get the hub to recognize the pairing “sequence”. I found a z-stick to be invaluable. I used it to exclude the device and verify the include sequence (on/off vs 3 down-taps). Excluding the battery devices was also mitigated with the z-stick.

Following the C-4 to C-7 guide probably saved me days of work. Even so, I have put in about six hours of effort.

I found if the device got “stuck” in initialization, and I waited a few minutes it would “show up” in the zwave detail page. It would be named the default name, but following the link would allow me to edit/save as usual.